1. dbergeron07's Avatar
    I have recently gone from my iphone 5 to my husbands galaxy s3.. After switching all of his stuff to his new phone I did a master reset.

    Everytime I try to download any apps I get error 927. I have researched some and found this:

    Go to system settings>> Accounts>>Google>>remove your Gmail account
    - Now from settings>>Apps>>All> Force stop, Clear data and cache for Google Play Store, Google Service Framework and Download Manager (like in method 1)
    - Now again go to settings>> Accounts>>Google>>Add your gmail account
    - Restart your android and then accept all the Google terms and setup Google settings
    - Rerun Google Play Store and update or install your app.

    I tried that and it didnt work. I tried to do a battery reset and it still didnt work. I have tried on and off of wifi.

    I also removed my google account, signed into my husbands google account - it all of a sudden worked. But when I removed his google account and re-added mine, it stopped working again!

    Does anyone know why this is happening and how I can fix it?

    I did try just waiting it out, thinking it would fix itself, but its been a few hours and nothing...

    I am on android version 4.4.2... I also tried looking for updates on the phone, but there weren't any.

    11-27-2014 01:27 PM
  2. anon8380037's Avatar
    Hello. I would guess you would need your husband to remove the S3 from his device list on his account, then start again. Even though you have factory reset it, which is good, his Google account will have the S3 listed on his account and so also the Play Store account.

    From my Note 3 on Tapatalk
    11-27-2014 03:26 PM
  3. anon8380037's Avatar

    I think you can only hide or untick a device from an account. See demo here:

    From my UK Note 3 on Tapatalk
    11-27-2014 03:46 PM
  4. ttkk1's Avatar
    For the past couple of hours I've had the same exact problem on all of my devices whether on wifi or cellular network, there other people posting about the same problem so I'm thinking it must be something on the server side not on our phones or tablets

    Posted via Android Central App
    anon8380037 likes this.
    11-27-2014 03:50 PM
  5. steven252000's Avatar
    I too have been having the exact same problem today. My phone is an S3 and obviously I have had it for a while. Just out of no where I started getting the 927 error when I tried to update my apps. I have tried EVERYTHING to fix it that I found online. I too added another account and it works with no issues. So it seems to be specific to my original account. My wife's Maxx is working fine on the playstore. On my newly created account I can update apps by finding them in the app store but it does not automatically show my apps and show which ones that need updating because they were downloaded from my other "messed up" accounts. So if anyone finds the answer on what to do on this please let me know. Frustrating more than anything.
    11-27-2014 07:34 PM

Similar Threads

  1. How can I get out of system recovery mode on an Android Nextbook?
    By Justin D English in forum Android 4.0 Ice Cream Sandwich
    Replies: 2
    Last Post: 02-25-2015, 05:28 AM
  2. [FREE GAME] Bird Beat 2 - You can't beat 32!
    By omnicubegames in forum Android Games
    Replies: 1
    Last Post: 12-14-2014, 12:52 AM
  3. hiding app button, etc. on main tablet screen
    By freedda in forum ASUS MeMO Pad 10
    Replies: 1
    Last Post: 11-28-2014, 01:33 AM
  4. Why isn't my Sportscenter App opening inbox links?
    By Braden Sprecher-Reinke in forum General Help and How To
    Replies: 1
    Last Post: 11-27-2014, 12:38 PM
  5. can't open files
    By lcb943 in forum Sony Xperia Z1
    Replies: 1
    Last Post: 11-27-2014, 12:22 PM