1. AC Question's Avatar
    WatchEspn won't play live videos on my Motorola Maxx. It was working fine two weeks ago. All the standard reboot, uninstall, install new, don't help. Other devices on the same account work fine. What settings or updates am I missing?
    01-24-2015 10:21 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Apps​, select WatchESPN, and Clear Cache/Clear Data, then Force Stop. Does it work now?
    01-24-2015 11:24 PM
  3. 52Larry's Avatar
    That didn't help
    01-24-2015 11:41 PM
  4. B. Diddy's Avatar
    Try wiping the system cache partition: https://motorola-global-portal.custh...p/30,6720,8697
    01-25-2015 01:38 AM
  5. 52Larry's Avatar
    I went through all the steps and performed the partition cache wipe. It did not fix the problem.
    01-25-2015 10:07 AM
  6. B. Diddy's Avatar
    At this point, the best thing I can suggest is to email the developer and let them know about the problem. no_response@espn.com
    01-25-2015 11:04 PM
  7. 52Larry's Avatar
    The email address isn't valid
    01-28-2015 06:59 PM
  8. 52Larry's Avatar
    I called ESPN support. They said there was an android update about the time that the watchespn app quit working. They are working on making it compatible again. Meanwhile there is nothing I can do. Thanks a lot android for screwing all your users again.
    01-28-2015 11:35 PM
  9. 52Larry's Avatar
    So apparently the Lollipop update is responsible for making the WatchEspn app fail. How do we get rid of the update?
    02-04-2015 07:08 PM
  10. jojosh's Avatar
    I am having the same problem. It started around January 5, the same time I switched from Fios to Optimum. I thought it was related, but I guess not. ESPNWATCH works fine on a laptop or on an iphone, but not my android. It was about the same time that I updated to KitKat 4.4.4. Not yet on Lollipop. It sounds like it is related to the KitKat upgrade. Very painful. Is there any way to roll back the update?
    02-07-2015 10:37 AM
  11. jojosh's Avatar
    Are you sure your update was to Lollipop and not to KitKat 4.4.4? I thought mine was going to be to Lollipop, but it was KitKat 4.4.4. I did not see any difference in the appearance of the operating system on my phone. Did you? As I understand it, if you did not see meaningful changes in appearance, it was not the update to Lollipop.
    02-07-2015 10:48 AM
  12. jojosh's Avatar
    It appears that there is an issue between Kitkat 4.4.4 and the latest version of WatchESPN - version 2.3.2. One way to remedy this that worked for me was to install the prior version of WatchESPN - version 2.3.1. I cannot post a link for where to find that, because apparently I do not yet have enough posts on this forum. Once you find that version, goto Settings, Apps, WatchESPN and Uninstall the current version. Then, goto the site and download the prior version of WatchESPN. You might then need to adjust your Security Settings to install the download. Goto Setting, Security & Screen Lock and check Unknown Sources. After installing the prior version, you can uncheck this. Now open the downloaded file/app. It will install. Finally, you need to prevent the WatchESPN app from updating. Goto Google Play, click the menu button in the upper left corner, and select My Apps. Now, select WatchESPN from the list. Click the menu button in the upper right corner and uncheck Auto-update. Once you get Lollipop, you can try updating WatchESPN and see if it works. If so, you can recheck Auto-update. This worked for me. Good luck.
    02-07-2015 01:44 PM
  13. Rukbat's Avatar
    One way to remedy this that worked for me was to install the prior version of WatchESPN - version 2.3.1. I cannot post a link for where to find that, because apparently I do not yet have enough posts on this forum.
    1) If you always back up your apps, you can always uninstall the current version and install an earlier version.

    2) You can post a link, as long as it's not in link form - i.e., www . my . link . com.

    3) It's BAD form to post contentless posts to increase your post count.
    02-07-2015 02:53 PM
  14. 52Larry's Avatar
    I couldn't find the older version. My update on my Maxx was Kit Kat. The rep at Verizon store had told me it was Lollipop and I didn't check before I posted that. Factory reset also didn't help. So I did the Edge up to a new Motorola Droid Turbo. Now WatchEspn works again on the Turbo. I'm pretty sure that 2.3.7.en.us obake update of KitKat was causing the previous error.
    02-10-2015 08:29 PM
  15. Sceeb's Avatar
    I am having the same problems on my Motorola Android Ultra. WatchESPN quit working when it updated in January. I have talked to ESPN, my cable provider and Verizon. I don't understand when you say that you did a Edge up to a new Motorola Droid Turbo? Can you explain? Thx
    03-11-2015 02:54 PM
  16. Bmoski9's Avatar
    enable developer options. change runtime from Dalvik to ART. Done.
    someguyatx likes this.
    04-07-2015 08:36 PM
  17. someguyatx's Avatar
    enable developer options. change runtime from Dalvik to ART. Done.
    Thank You!!! Watch Espn finally works on my Droid Maxx. Phone seems a bit snappier on Art runtime as well.
    05-30-2015 10:59 PM
  18. fjamison's Avatar
    I made the switch to ART to solve this problem as well, which it did, but at the expense of battery life.....cut it in half! still looking for the older version of ESPN if anyone finds it please let me know!
    09-17-2015 12:38 PM
  19. jdbrechtel123's Avatar
    I know this thread is old but I spent most of today setting up a new phone I got and ran into this exact problem and these were the best tips I came across.

    I was using a Coolpad Rogue and never had one issue with the WatchESPN app.

    I purchased a Samsung Galaxy Mini for the purposes of some more storage space but still having a basic smart phone and keeping things simple, plus I prefer my phones to be smaller if possible.

    Anyways, back on point. I tried installing the WatchESPN app like normal through Google Play in its latest version, 2.4.8, but everything the app would crash when trying to open/sign in.

    Version 2.3.1 does the job for me right now, and I have it set up to where Google Play/WatchESPN won't ask for updates. For testing purposes I attempted to install version 2.4.1, but that didn't work, the app crashed as explained above.

    So, I uninstalled then reinstalled 2.3.1 once more. I'm leaving it alone at that for now and keeping an eye out making sure the app performs as normal, as I am always cautious in downloading programs/apps from third party vendors, whether it is on PCs or phones.

    The URL below has previous versions of the WatchESPN app - if you go here, after selecting the WatchESPN version you want to download, click either the Google Play Server or apk4fun server to proceed.

    Many thanks for all suggesting this and going through the pain and time-consuming steps to make these good suggestions.
    05-07-2017 08:41 PM

Similar Threads

  1. Replies: 3
    Last Post: 01-28-2015, 10:04 AM
  2. Replies: 1
    Last Post: 01-24-2015, 11:32 PM
  3. micromax a350 new apps or updation issue.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-24-2015, 11:29 PM