1. AC Question's Avatar
    I have a galaxy s5 and it was working fine up until the lollipop update... now when I try to click a link from the Facebook app chrome will open, but not to the clicked link. It will either open the last site I was on, or if I closed all tabs it will open the Google homepage. I already tried turning off and on the external browser, clearing my defaults even trying the original browser, nothing works and it's getting me really aggravated, it works if I use the mobile site, but not the Facebook app. Please help!
    03-24-2015 03:56 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I've noticed this as well on my Nexus 5. I think it's a Facebook app problem related to Lollipop--it's up to Facebook to fix it. Report the bug to them.
    03-26-2015 01:52 AM
  3. Jaime Serrano's Avatar
    Its helped me to use my wifi instead of my data. But thats kind of annoying because i don't always have wifi around :/
    03-27-2015 02:20 AM
  4. Smply_Rckless's Avatar
    I've noticed my Note 4 does this as well. I tried clearing the cache & data already.

    Tapatalk'n On The IPhone 6+ 
    03-27-2015 02:27 AM

Similar Threads

  1. How can I delete duplicate contacts from my Droid phone?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 04-02-2015, 07:42 AM
  2. My galaxy tablet won't work
    By Mychaela Richards in forum General Help and How To
    Replies: 1
    Last Post: 03-26-2015, 01:53 AM
  3. How can I remove icons from my Android phone?
    By Tony Hackett in forum Ask a Question
    Replies: 5
    Last Post: 03-25-2015, 10:35 AM
  4. My s5 won't turn on. Please Help!
    By Brandon Khan-Fagg in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 1
    Last Post: 03-25-2015, 05:44 AM
  5. Stock Samsung message app Tab S 10.5 ?
    By felloffthetruck in forum Samsung Galaxy Tab S 10.5
    Replies: 3
    Last Post: 03-24-2015, 05:54 PM