1. Manic Droid's Avatar

    I've tried to install a non-market app from a SD Card, after unisntalling it, but sadly, after trying to install it for the 2nd time it gives the error "Application not installed". So after looking for a solution to fix this issue, I found that the file "sdcard/.android_secure/smdl2tmp.asec" needs to be removed, but I can't access to it because the permission is denied.

    I tried plugging the USB cable of the cell phone to my PC, with the options of show hidden files (enabled) and hide protected OS files (disabled), but I can't see the folder. My other option was to use a terminal app, ConnectBot, but I'm not sure how to do a command to change permissions on that file.

    Basically what I'm trying to replicate is a tutorial to install Hearthstone in a SD Card, 'cause I don't have enough internal storage. The first time I tried it I was succesful, but after uninstalling FolderMount by an accident, I can't install that app again.

    I have a LG L80, Android version is 4.4.2, and rooted. Please I need to delete that file, so I can install that app again.

    Can anyone help me to solve this?

    Thanks in advance!

    05-25-2015 04:33 PM
  2. Manic Droid's Avatar
    I can't believe that I solved this, after scratching my head for so long. I came up with this fix: tried to download Hearthstone from the Play Store, and see if I was able to install it that way. Didn't work, but that led me to the solution. Apparently, there were remnants of Hearthstone after uninstalling it the first time and, of course, this is something that often occurs with other games or large applications.

    The key was in an empty directory: /data/data/com.blizzard.wtcg.hearthstone. So I deleted the folder "com.blizzard.wtcg.hearthstone", and proceeded to install the non-market app (just to try). The result? 100 % success!!

    So, basically, if you have this very same issue and if you're rooted, try to look on /data/data/ and look for the corresponding app folder (which will be empty if you uninstalled it, so there's no real loss if you remove it), delete the app folder and try to reinstall again.

    Problem solved, guys!

    05-26-2015 04:01 PM

Similar Threads

  1. voice command to lock the screen or power off?
    By rob913 in forum Motorola Droid Turbo
    Replies: 2
    Last Post: 09-27-2017, 05:52 PM
  2. S5 Display timeout keeps getting changed
    By Dallan C in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-14-2016, 09:24 AM
  3. Nexus 4 KitKat to lollipop. Downgradable if needed?
    By markyb555 in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 05-31-2015, 02:20 PM
  4. Replies: 1
    Last Post: 05-25-2015, 05:26 PM
  5. How do I change to Celsius to Fahrenheit on Galaxy S4?
    By AC Question in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 05-25-2015, 04:14 PM