1. AC Question's Avatar
    I have a very odd wifi issue and I have yet to find an answer. I will try to be as detailed and thorough as possible.

    I have Comcast as a provider, and I recently switched away from their all-in-one modem/router. I got a really good deal on a Motorola Surfboard 6141 and Linksys AC1200+ (EA6350) router due to a going out of a business sale from a local place.

    Everything has been working perfectly except our phones (both 1st Gen Moto X's. Contract is almost up) and my Samsung Galaxy Tab Pro 8.4. We have tested 5 different Macbooks, an iPad, a Windows laptop, and a Microsoft Surface. Everything else is working without issue as in the speed is great and streaming/surfing/etc. is great. The only thing hardwired in is the Xbox One which works beautifully.

    So on to my wireless settings. I've got both the 2.4ghz and the 5ghz enabled. They both use the same name and password. The 2.4ghz is set to channel 11, auto width, N-Only, and WPA2/WPA Mixed Personal The 5ghz is set to auto channel, auto width, mixed(AC and N), and WPA2/WPA Mixed Personal.

    I've tried changing some of the DNS settings as well. I set static DNS1 to and DNS2 to and left the third space blank.

    For the firewall settings IPv4 SPI and IPv6 SPI are enabled. And under Internet Filters, filter anonymous and filter ident are checked, while filter multicast and filter internet NAT redirection are unchecked.

    Nothing has really helped much. I can set the Moto X to 2.4ghz only and I get about 10mbps down, 11 up. On 5ghz only, I get a much better 37mbps down, and 12up. Unfortunately, either way, actual browsing/streaming are sluggish. Similar results on my Galaxy Pro (not an easy way to set to 2.4 or 5 only). Sites are just loading slow. Just google.com is taking roughly 20 seconds. I've been using Chrome and Dolphin browsers on both devices with similar results.

    I'm a little lost here. Even tried wiping the cache on both devices. I feel like there's just something I'm missing here and I'm not finding anything online. I can provide any other relevant details. Just not understanding why my Android devices are the only ones with issues.
    07-12-2015 09:09 PM

Similar Threads

  1. Samsung Galaxy s4 Stuck on Recovery Mode everytime it turns on
    By bobbei in forum Vodafone Samsung Galaxy S4
    Replies: 1
    Last Post: 07-12-2015, 10:31 PM
  2. Replies: 1
    Last Post: 07-12-2015, 10:29 PM
  3. My Asus fonepad is having a power on problem, what should I do?
    By Pi Zeta Acoba in forum General Help and How To
    Replies: 1
    Last Post: 07-12-2015, 10:26 PM
  4. Replies: 1
    Last Post: 07-12-2015, 10:24 PM
  5. Replies: 0
    Last Post: 07-12-2015, 08:35 PM