1. AC Question's Avatar
    I recently received the Android Marshmallow update on my Nexus 5. Ever since it finished updating, wifi simply does not connect. It gets stuck in the authentication loop. Occasionally it connected but went off immediately back to authentication.
    10-07-2015 07:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I've been seeing a few mentions of wi-fi connectivity issues with MM. Have you already done the usual cache partition wipe after the system update? http://forums.androidcentral.com/nex...-recovery.html.

    How about going to Settings>Wi-fi, tap Menu>Advanced, then change Wi-fi Frequency Band to either 2.4 or 5 GHz only (instead of Automatic)?
    10-07-2015 11:36 PM
  3. NewUser2015's Avatar
    Thanks for the reply! Unfortunately both the methods did not work out for me.
    10-08-2015 04:07 PM
  4. B. Diddy's Avatar
    Ok, try the tips in this guide, starting with a router reboot: http://forums.androidcentral.com/amb...-problems.html
    10-08-2015 06:53 PM
  5. NewUser2015's Avatar
    Sorry for the delayed reply. None of these options worked for me. So I went ahead and flashed Cataclysm WiFi is working fine now. Thanks a lot for your suggestions.
    B. Diddy likes this.
    10-11-2015 01:17 AM
  6. Falak Dua's Avatar
    Hey...could you please tell me what exactly did you do as I am facing the same issue. WiFi is stuck in authentication loop.
    Androniks likes this.
    10-14-2015 01:18 AM
  7. Nick_Lowe's Avatar
    If you're connecting to a WPA2-Enterprise/802.1X SSID, check out: https://code.google.com/p/android/issues/detail?id=188867
    10-27-2015 04:30 PM
  8. Androniks's Avatar
    If anyone has such problem see my reply for Falak Dua above.
    11-06-2015 07:29 PM
  9. Chetan Malakiya's Avatar
    Dear sir
    Good afternoon
    i have a moto g2 phone & i have update 6.0 android version but in thise maser problem wifi connection
    02-18-2016 03:06 AM
  10. Chetan Malakiya's Avatar
    dear madam
    good afternoon
    Marshmallow 6.0 update and not connected to WIFI in my Mobile
    pls give me a solution immediately

    thanks & Regards
    02-18-2016 03:11 AM
  11. Aric47's Avatar
    I am using Moto G2 and recently upgraded to 6.0 Android OS. Since this upgrade I am facing this same issue where the connection goes into infinite loop (obtaining ip address..connecting...saved)... tried everything but nothing works
    02-24-2016 10:35 AM
  12. Theozzmancometh's Avatar
    After being pissed off for over 24 hours due to this MM nonsense, I read up on the debugging thread above. Although most routers will not have an update available, I found that simply changing encryption from "WPA-PSK [TKIP] + WPA2-PSK [AES]" to simply "WPA2-PSK [AES]"

    completely solved my problem. In the past it was the other way around.....

    Hopefully this helps some others as well.

    Note: Netgear wndr3700 and LG G4
    02-28-2016 07:59 AM
  13. jasonsmoothon's Avatar
    I am having the same problem - but with a work router that I cannot access.
    The router is configured to [WPA + WPA2][Auth(PSK)] and all apps I downloaded to try to fix do not work.
    05-13-2016 09:46 AM
  14. Rukbat's Avatar
    1. Wifi connectivity is a known problem with Marshmallow (and it's intermittent - it works with some phone and not with others).

    2. It probably won't connect to a router set to use TKIP encryption.
    05-13-2016 01:23 PM

Similar Threads

  1. Replies: 2
    Last Post: 01-25-2016, 01:49 PM
  2. Old Samsung Galaxy S with Android 2.6 - can upgrade to 4.x?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-08-2015, 11:34 AM
  3. Tap to talk freeze?
    By Italianloe in forum Ask a Question
    Replies: 1
    Last Post: 10-07-2015, 11:57 PM
  4. How to set Chrome as default browser?
    By Gordo Allinson in forum LG G4
    Replies: 1
    Last Post: 10-07-2015, 07:43 PM
  5. Replies: 1
    Last Post: 10-07-2015, 07:39 PM