1. AC Question's Avatar
    So I was browsing the internet looking for minecraft mods for a specific launcher and hit install and a screen came up that said on the right side "Install" and on the left side "Cancel" so I hit install and nothing happened so I hit install again and nothing happened so then I hit cancel and it worked and brought me back to my browsing page. So I tried downloading something else and it did the exact same thing. Any ideas on how to fix this?
    11-02-2015 08:36 PM
  2. Rukbat's Avatar
    Try a different browser. It would appear to be a browser issue (assuming you have enough free internal space to download the mod).
    11-02-2015 11:11 PM

Similar Threads

  1. How can I get iOS emoji on my Moto E?
    By natygrosso in forum Moto E
    Replies: 3
    Last Post: 11-04-2015, 09:27 PM
  2. Replies: 1
    Last Post: 11-03-2015, 07:19 PM
  3. How to change my messaging app
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 11-03-2015, 10:41 AM
  4. Replies: 1
    Last Post: 11-03-2015, 01:39 AM
  5. Replies: 1
    Last Post: 11-02-2015, 08:41 PM