1. AC Question's Avatar
    I have tried different PCs -- 3 of them all running Windows 7 -- different cables, different software like Smart Switch which I've never had to use and it did nothing, rebooting everything, updated drivers, tried different usb ports (obviously)... the USB ports work for other things like thumb drives, I have Debugging on and set right (for months), I know to swipe down and select File or Photo Transfer, and one computer makes the connection sound, but never sees the device. The other two don't even do that. Everything worked fine for over a year; why does it refuse to work now and what else can I try? I researched the web including these forums and haven't found anything that works.
    11-29-2016 02:29 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The problem might be with the phone's microUSB port. Make sure it's clear of debris by blowing it out with a can of compressed air. If it's completely clean and the problem persists, you might have to bring it to a repair shop to replace the port.
    11-29-2016 04:36 PM
  3. eblackwell's Avatar
    Thanks for replying!

    It charges fine. If it was the port, wouldn't it not work at all?
    11-30-2016 08:19 AM
  4. eblackwell's Avatar
    Update: I just tried Smart Switch with the Wireless option. Didn't work. So it's not the port or cable.
    11-30-2016 09:16 AM
  5. B. Diddy's Avatar
    It charges fine. If it was the port, wouldn't it not work at all?
    Not necessarily. It's possible for only certain pins/contacts to be damaged, which means that you could encounter isolated charging issues or isolated data transfer issues.

    I'm not familiar with Smart Switch's wireless connectivity option, so I'm not sure how much that correlates with USB connectivity.
    11-30-2016 06:08 PM
  6. eblackwell's Avatar
    A friend let me try her computer (Windows 10) and it immediately connected. No problems.

    But! File Explorer would freeze up whenever it had to list files, not just folders. Like Phone->DCIM->Camera. Even if it's only 2 files.

    I disconnected the phone, run multiple scans for virus, malware etc. Clean. Cleaned out junk files and cache.

    Shut the phone down and then powered up. Now her pc could list the files, but couldn't display icons. Only tiles. And it couldn't open or do anything else with the files.

    I disconnected the phone, ran all scans again with multiple apps, powered down and up. I did the same with my Windows 7 PC. But it still wouldn't even connect when I plug in the phone with the same USB cord.

    AirDroid CAN connect, but it's slower than being able to just connect the phone and move files around.

    UPDATE: I went into Device Manager on my PC. Searched for hardware changes, reconnected the phone, no luck. Did the search again, then right clicked and updated drivers again.

    Now I can connect. However, I have the same behavior problems with File Explorer. It freezes any time it has to list files. Under my Camera folder, for example, it started listing photo files, then gave me 25 local disk icons. Then froze. I tried again and this time went into Downloads, froze, Ringtones, froze, a different app's folder, froze, nothing opens and lists.

    But AirDroid and those type of apps can access the phone files easily, copy them, rename them, etc. So the files themselves are okay.

    It's the PC interacting with it that's the problem.
    11-30-2016 07:54 PM
  7. B. Diddy's Avatar
    Sorry, I'm kinda stumped here. It might be worth reinstalling the firmware via Smart Switch, in case something got corrupted: SmartSwitch: Install & update or replace firmware
    11-30-2016 09:39 PM

Similar Threads

  1. NVIDIA Sheild Tablet K1 vs Samsung Galaxy Tab A 10.1
    By Laserbutt in forum SHIELD Tablet
    Replies: 4
    Last Post: 01-01-2017, 01:18 PM
  2. Galaxy Note 4 - WiFi switching on and off
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 12-26-2016, 04:34 PM
  3. Double Tap to wake?
    By Melanizm in forum Honor 8
    Replies: 9
    Last Post: 12-05-2016, 01:06 PM
  4. Why won't my phone ring?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-29-2016, 04:46 PM
  5. Replies: 1
    Last Post: 11-29-2016, 02:50 PM
LINK TO POST COPIED TO CLIPBOARD