1. AC Question's Avatar
    it's happens quite often unless somehow i grip the edges while taking out my phone. Most of the time, if 1 of my fingers land on the screen, it will either accept or reject. Is there a way around this or do i have to install a different dialer app?
    12-10-2016 10:43 PM
  2. Rukbat's Avatar
    Get a case that has a screen cover. Other than that, the only thing you can do is make sure you pull it out of your pocket by the edges. There's no "don't answer call" function.
    12-10-2016 11:06 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Doesn't the S7's incoming call screen require you to swipe the answer button to the right in order to answer the call? Answer Phone Calls - Samsung Galaxy S7 edge User Guide Are you inadvertently swiping the screen when you take the phone out of your pocket, or is the call answering when you simply tap the screen?

    You don't have it set to answer with a Home button press, do you? Call Settings - Samsung Galaxy S7 edge User Guide
    12-12-2016 02:00 AM
  4. waynew73's Avatar
    If you go into the Phone App and then go into settings, there's a category called Answering and Ending calls. There are 2 settings within for auto-answering calls. Try turning them off. I used to have similar problems until I did that.
    B. Diddy and ksanger35 like this.
    12-12-2016 02:06 AM
  5. ksanger35's Avatar
    Welcome to Android Central! Doesn't the S7's incoming call screen require you to swipe the answer button to the right in order to answer the call? Answer Phone Calls - Samsung Galaxy S7 edge User Guide Are you inadvertently swiping the screen when you take the phone out of your pocket, or is the call answering when you simply tap the screen?

    You don't have it set to answer with a Home button press, do you? Call Settings - Samsung Galaxy S7 edge User Guide
    Your link to the obsolete are obsolete instructions. I found an entry to auto answer if you are connected to bluetooth. Hope that fixes my pocket answering device. I hate updates. I didn't do anything to affect this change. Someone else did. BS Phone OS. Times like this I miss my flip-phone.
    11-20-2017 06:36 PM
  6. B. Diddy's Avatar
    Glad you found a solution -- can you let us know where that is in the menu? Since I obviously can't have every device in existence, I have to rely on what's on the web, which admittedly can become obsolete relatively quickly.
    11-20-2017 07:04 PM
  7. ksanger35's Avatar
    Glad you found a solution -- can you let us know where that is in the menu? Since I obviously can't have every device in existence, I have to rely on what's on fthe web, which admittedly can become obsolete relatively quickly.
    I have a Galaxy S7 on Verizon. After my latest "UPDATE" my phone is again hanging up as I pull it out of my pocket. Plus it tells me it sent the caller a Message. Sending a message to a land line is a great feature. I believe two updates ago all the menus changed, Answering and Ending Calls is now under Accessibility. However auto answer, automatic answering when on bluetooth was turned off, so that may no longer be the fix.

    When I call myself I have to swipe to decline. Don't see how pulling the phone up out of the pocket swipes it left to right. I had answer by pressing the home button turned off. Will try turning that on.

    Also the latest update keeps sending me notifications when I open an app, like new features I don't want to know about and will never use. Or I like the notification to turn OK Google On. You must accept, then teach it ok google, then it will search, then next time you must reteach google your voice. Probably because I only want to use OK Google when I start the app up. I do not need my phone to run when I am not using it.

    If I can't get my phone to stop hanging up, or must keep is outside my pocket in order to do so, then I don't really need a mobile phone. I don't carry a purse.

    SAMSUNG-SM-930V, SM-G930V, HW Rev0.6, Android 8.0.0, Samsung Experience version 9.0, Kernel
    3.18.71,
    11-12-2018 02:03 PM
  8. B. Diddy's Avatar
    Does this sound like the same issue? https://forum.xda-developers.com/gal...xy-s9-t3768837
    11-12-2018 05:15 PM
  9. ksanger35's Avatar
    Sounds like it though my phone shows Easy Mute is OFF. The only advanced features I have enabled are Smart Stay and Quick Launch Camera. I have no idea what Smart Stay is and I'll have to research it. Which is exactly what I planned on doing this morning NOT. More Android/Samsung/Verizon crap to deal with. New features should never be enabled by default. then us users that will only turn them on if we want them don't have to figure out what went wrong and how to return the phone to the way we had it setup.

    Still having issues with OK Google. It used to be you could enable it only in the google app, or the google apps. If I turn on the app, I have to train OK Google with my voice. Then I have to disable OK Google but the in app option is no longer there. So I only select enable OK Google in Maps. But then turning on the app, we must train ok google again. Some feature NOT. I suspect this is going to disable using android phone through my car unless I enable it all the time. Which I would never do, at least on purpose. Turns out that updating the software turns ok google on. Argh.

    Google and Android are turning me off.
    11-15-2018 07:31 AM
  10. B. Diddy's Avatar
    Smart Stay will keep the screen on as long as the phone detects that you're looking at it (by using the front-facing camera to determine where your eyes are looking).

    Can you clarify how you want to use the Google app? You can turn off Google Assistant by opening the Google app, tapping Menu>Settings>Google Assistant - Settings, then tap the Assistant tab. Tap Phone under Assistant Devices, and then turn off the Google Assistant toggle.

    EDIT: Never mind, I just tested turning off Assistant -- if you do that, every time you say "Ok Google," it'll prompt you turn it on again, so that's clearly not what you want.
    11-15-2018 12:44 PM
  11. ksanger35's Avatar
    Smart Stay will keep the screen on as long as the phone detects that you're looking at it (by using the front-facing camera to determine where your eyes are looking).

    Can you clarify how you want to use the Google app? You can turn off Google Assistant by opening the Google app, tapping Menu>Settings>Google Assistant - Settings, then tap the Assistant tab. Tap Phone under Assistant Devices, and then turn off the Google Assistant toggle.

    EDIT: Never mind, I just tested turning off Assistant -- if you do that, every time you say "Ok Google," it'll prompt you turn it on again, so that's clearly not what you want.
    That's exactly my issue. I would like OK Google enabled only when I am in the Google App or Google Maps or when I'm voice calling through the car's bluetooth connection. I would never want OK Google on all the time.

    This was all working prior to 8.0.0.

    Surely people working in secure locations may no longer keep their smart phone on. The same for people working for companies concerned about security. Individuals should be concerned too. Note the update to 8.0.0 turned OK Google on. It started up by itself, which is why I turned it off, and then it wouldn't work unless I started the Google App, though turning if off results in it starting over.

    If Updates only updated security issues I wouldn't have a problem with them.
    11-16-2018 11:50 AM
  12. ksanger35's Avatar
    Another pocket answer occurred today. I believe the phone might have been in my upside down but did not specifically pay attention to how I place my phone in my pocket. More than I really want to do. Anyway I am not imagining that this is happening. It really is. The person on the phone was trying to talk to me before I pulled my phone completely out of my pocket and accepted the call.

    Guess I'll go to Verizon and complain that the phone does not work after the update. That wireless charging does not work after an update over a year ago. Plus I see if my GM vehicle still lets me voice dial out. I should not have to get a new phone to get features I had when I purchased this one. If so I won't buy another one from Android, Samsung, nor Verizon.
    11-16-2018 06:34 PM
  13. ksanger35's Avatar
    Another pocket answer occurred today. I believe the phone might have been in my upside down but did not specifically pay attention to how I place my phone in my pocket. More than I really want to do. Anyway I am not imagining that this is happening. It really is. The person on the phone was trying to talk to me before I pulled my phone completely out of my pocket and accepted the call.

    Guess I'll go to Verizon and complain that the phone does not work after the update. That wireless charging does not work after an update over a year ago. Plus I see if my GM vehicle still lets me voice dial out. I should not have to get a new phone to get features I had when I purchased this one. If so I won't buy another one from Android, Samsung, nor Verizon.
    Tired calling from the gm car today. was able to call out. but then I couldn't talk and barely able to hear as the phone was in my pocket and no longer going through the car radio. got home, checked bluetooth settings for my auto, found use car audio checked, unchecked, and checked again then it worked. But th.e phone was no longer in my pocket so I'm suspicious that having the phone in my pocket while driving my car might make it fail next time I try. great new feature I would never want. Updates keep wasting my time. Have another one pending today and still haven't found and fixed all the bugs introduced from the last update.
    11-17-2018 05:08 PM
  14. B. Diddy's Avatar
    Sorry you're running into all of these issues. It's hard to tell if they're bugs being introduced by the system updates, or if they're from some other source. This is one of the reasons I favor Pixel phones, because the updates from Google don't have to go through multiple tweaks and modifications (by the manufacturer and by the carrier), and they don't have to deal with interfacing with manufacturer-specific UIs or preinstalled features that can potentially cause glitches or incompatibility. Those glitches are what beta testing are for, but just as with any type of beta testing, you can't account for all of them all the time.
    11-17-2018 07:03 PM
  15. Velenoso's Avatar
    There is a setting I can't remember where it is off hand that rejects calls while the phone is in your pocket, that's what is more than likely happening to some.
    11-17-2018 07:13 PM
  16. Velenoso's Avatar
    Tired calling from the gm car today. was able to call out. but then I couldn't talk and barely able to hear as the phone was in my pocket and no longer going through the car radio. got home, checked bluetooth settings for my auto, found use car audio checked, unchecked, and checked again then it worked. But th.e phone was no longer in my pocket so I'm suspicious that having the phone in my pocket while driving my car might make it fail next time I try. great new feature I would never want. Updates keep wasting my time. Have another one pending today and still haven't found and fixed all the bugs introduced from the last update.
    Does the S7 have this setting in display? I couldn't find the setting I mentioned before but I know it was on my S9+ and S8+ because it was discussed on another forum.

    Samsung Galaxy s7, how do i prevent answering/rejecting calls while removing phone from pocket?-screenshot_20181118-124713.jpg
    11-17-2018 07:57 PM
  17. ksanger35's Avatar
    Under Settings, Display, I now have an option to block accidental touches which was off. I've set it to on to see if that helps. Though yesterday I received a call and the phone answered before I even attempted to retrieve it from my pocket.

    I assume this uses the phones camera to see if its dark. I'm not thrilled with an app or phone using the camera to see if its in my pocket or anywhere else.
    11-19-2018 09:19 PM
  18. ksanger35's Avatar
    Tired calling from the gm car today. was able to call out. but then I couldn't talk and barely able to hear as the phone was in my pocket and no longer going through the car radio. got home, checked bluetooth settings for my auto, found use car audio checked, unchecked, and checked again then it worked. But th.e phone was no longer in my pocket so I'm suspicious that having the phone in my pocket while driving my car might make it fail next time I try. great new feature I would never want. Updates keep wasting my time. Have another one pending today and still haven't found and fixed all the bugs introduced from the last update.
    I found that the phone drops the bluetooth connection after making a call through the car radio if its in my pocket. If the phone is out of my pocket it works as it should. It used to work from my pocket prior to all these updates.

    After updates the phone I have now is not the one I purchased, nor does it work as well, nor does it have all the features I wanted and paid for. I probably will not be buying a Pixel 3 as I'm not going to ever spend that much money on a phone again so it can be updated, annoying, frustrating, and disappointing.
    11-19-2018 09:37 PM
  19. B. Diddy's Avatar
    For what it's worth, updates on Pixel phones rarely cause big problems, because these are Google's own phones, and the updates don't have to be tweaked multiple times by the manufacturer or carrier. Samsung phones have been somewhat notorious for buggy updates, mostly due to the need to modify them in order to play well with TouchWiz/Samsung Experience/OneUI/WhateverTheHeckTheyCallItNextUI. The S7 Oreo update appears to have been particularly buggy -- there are multitudes of threads on this forum about many different Oreo issues on the S7. I realize I probably won't convince you otherwise, but I would caution against assuming that problems on one particular phone from one particular manufacturer equate to the same problems across all Android phones. Good luck!
    11-23-2018 10:38 PM
LINK TO POST COPIED TO CLIPBOARD