1. AC Question's Avatar
    So. I bought a brand-new Meizu M5 the other day and almost immediately plugged it into my Windows 10 laptop to transfer photos, movies, the like.

    It ran happily on my computer for about 4 -5 minutes then vanished. Now, when in MTP mode, it only appears under Devices & Printers, and Device Manager. It works happily as a PTP or as a "virtual ROM disk" but not as MTP (which is the only really useful mode obviously).

    What I've tried:
    Downloading new ADB drivers and installing them
    Downloading drivers from phone and installing them (Meizu ships backup drivers with phones, accessible in the "virtual ROM" mode)
    Downloading and installing multiple KN/N media packages for Windows 10
    Connecting it to another Windows 10 computer (exact, identical problem occurred)
    USB Debugging
    Troubleshooting as prompted from right-clicking on the device in Devices & Printers

    What I haven't tried:
    A different version of Windows (don't have any older versions, could try at work in a couple days)
    Factory resetting phone (last resort, already spent a fair bit of time setting up!)

    Willing to try practically ANYTHING!

    Thanks in advance!
    Tim Marshall1 likes this.
    01-28-2017 03:07 PM
  2. Tim Marshall1's Avatar
    Update - Works on Windows 7, this isn't really a solution just a point of interest as most of the time I have no access to a Win7 computer. Cheers!

    (yes the above is my post, just prior to creating an account)
    01-28-2017 10:27 PM

Similar Threads

  1. I cannot call with my samsung sgh 1467m.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-28-2017, 03:35 PM
  2. What is the fastest way to charge your phone?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-28-2017, 03:04 PM
  3. Replies: 1
    Last Post: 01-28-2017, 02:54 PM
  4. Replies: 1
    Last Post: 01-28-2017, 02:54 PM
  5. Replies: 2
    Last Post: 01-28-2017, 02:40 PM