1. AC Question's Avatar

    I have a Samsung A5 phone running Android 6.0 and a Archer C5 router. When I am at home Facebook, Instagram and Google Play Store will not load any data (says no connection).

    These apps work fine on mobile data and if I am connected to another WiFi network it works as well. I have gone to a neighbours house who has the same router as me and that didn't work either. I have also used these apps on other phones on my network without issue, so it seems to be this specific phone with this specific router.

    I have done some research and tried all the tips people give (clear data and cache, uninstall, reboot router, change setting to IPv6, remove password frrom network...I think thats all of them) Nothing seems to work!!!

    Does anyone have any other solutions? The only other idea I have is to load a Custom OS onto the phone and see if that helps but that seems like a lot of work. Anyone have a reason that this might or might not work?

    Any help would be greatly appreciated, this problem is destroying my data plan!!!
    02-08-2017 03:39 PM
  2. CaroDroid2's Avatar
    I had a similar problem with mobile banking not working. I assumed it was to do with my IP address or ISP and the app went into security overdrive and blocked it. I can't imagine that would be the case with social media sites though.

    Sorry I can't be more help, I feel your pain though.
    02-08-2017 04:59 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! You should try disabling IPv6, not changing the setting to IPv6. Some sites still seem to have occasional problems with IPv6, and do better on IPv4.
    02-08-2017 07:11 PM
  4. Paperbak's Avatar
    Thanks B.Diddy but it was originally disabled and I've since set it back so that doesn't seem to be the issue.
    02-09-2017 08:26 AM
  5. B. Diddy's Avatar
    These are less likely to help, but try changing the wi-fi channel (if you're using 2.4 GHz) on your router, and also make sure the DHCP range is wide enough to accommodate all of your devices.
    02-09-2017 11:02 AM
  6. Paperbak's Avatar
    Thanks, but that hasn't helped. I tried assigning a permanant address to the phone too but no luck.

    Do you think loading a custom ROM might solve it or is this strictly a hardware issue?
    02-09-2017 03:33 PM
  7. B. Diddy's Avatar
    I'm not sure. It would seem like more of a router issue to me. Is the router's firmware up to date? Are there any strange firewall settings in the router's settings webpage?
    02-10-2017 03:11 AM
  8. Paperbak's Avatar
    Yes I updated the firmware and I don't see any firewall settings that would be causing it
    02-11-2017 02:19 PM
  9. B. Diddy's Avatar
    There might be some kind of weird glitch in the router's firmware that conflicts with the A5. A custom ROM might be worth trying then, as you were thinking.
    02-12-2017 03:19 AM

Similar Threads

  1. Replies: 17
    Last Post: 02-14-2017, 03:11 AM
  2. Replies: 1
    Last Post: 02-10-2017, 01:24 PM
  3. How Do I transfer photos to PC at high resolution?
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 02-10-2017, 10:09 AM
  4. can't unlock my phone
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-08-2017, 02:36 PM
  5. why does my screen have only light
    By AC Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 02-08-2017, 02:25 PM