1. AC Question's Avatar
    Hi, first of all sorry for the spelling, i'm from Argentina and my english is not the best.

    i have a samsung s3 phone with a broken screen. I think also the touch-system is broken.

    I want to access the device via VNC to configure it as a media server, or a camera or maybe buy the mhl cable and use it as a smart-tv.

    I tried to install every app available but all of them requires me to authorize the adb interface (i have it enabled).

    on the adb command linethe phone shows as "unautorized"

    i tried the solution of rebooting the phone on recovery-mode and change the adb hosts files to have it autorized with no luck.

    In my several tests i think i broke the download mode and recovery mode because now it doesn't seems to reboot in those modes, it always boots in normal mode no matter wich keys i press.

    So, now i have a working cyanognemod rom (i don't remember wich version, if it's a 5.0 or 6-0 rom).

    I don have acces to recovery mode.
    I dont have access to download mode.
    I don't have wifi connected.
    I have adb enabled.
    I dont have adb autorized.

    I tried the vysor app, the teamviewer app etc.

    Is there any app to access the phone (vnc, or edit system files remotely) without autorize the adb interface?

    I bought a usb-jigg (it on its way) but i think it wont help, maybe it will allow me to enter download mode, but if i flash a new stock or custom rom i will be in the same place, because i dont have a way to autorize adb whitout a working screen

    So, i woinder if there's an app or script to authorize adb, or directly to access the phone wihout having to enable it

    Thank you in advance

    Greetings
    03-21-2017 10:36 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. You can try the solution in this thread: http://forums.androidcentral.com/gen...ml#post5467294
    03-21-2017 10:41 AM
  3. semental's Avatar
    Thank you for the quick answer, but that guide is oriented to unlock the phone (make the movement of swipe the screen or put the pin).
    What i need is to access the screen to authorize the adb or access the system files (whitout adb) to authorize adb access
    03-21-2017 08:06 PM
  4. Golfdriver97's Avatar
    I was thinking to use that method to turn on USB debugging.
    03-22-2017 01:05 PM
  5. semental's Avatar
    Thanks again for answer, i have usb debugging activated, what i need to do is to authorize the device (click ok on the dialog that appears on screen when new adb device is detected)
    I. ve already tried with a mouse and clicking in the dark with no luck
    03-22-2017 04:34 PM
  6. Golfdriver97's Avatar
    In this case, I am running out of ideas. Not sure what else to suggest.
    03-23-2017 01:16 PM

Similar Threads

  1. Why do i only get 4 hours of screen on time on Moto Z Play
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 03-21-2017, 01:32 PM
  2. I tried to root my S7 Edge but it has a locked bootloader...
    By AC Question in forum Samsung Galaxy S7 edge Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 03-21-2017, 12:51 PM
  3. what is the screen size of Samsung Galaxy S8?
    By TazyeenKhan in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 03-21-2017, 11:00 AM
  4. My phone screens are all in negative,how do i fix that.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-21-2017, 10:29 AM
LINK TO POST COPIED TO CLIPBOARD