1. AC Question's Avatar
    Problem: Cannot get rid of additional PIN lock for specific applications

    R7_Blackview_20160824 (a variant of the Oppo 7)
    Android marshmallow 6.0

    After installing and uninstalling
    Lock Screen IOS 9

    some of (but not all) the applications, including Settings, require that the PIN is reentered:
    (luckily the same original PIN is preserved).

    I have tried to reinstall Lock Screen IOS 9 but now it hangs whem I try to configure it, so I’ve had it removed. It’s very annoying. Even to answer a call I need to insert the PIN.

    And when the app opens, I see a flash for about one second with this notice "App will be locked after screen off" which is unfortunately true.

    I did a filesearch and deleted a folder and data file named “app_lock” – no luck after rebooting.
    ( /storage/emulated/0/android/data/com.comapplock/files/ app_lock )

    Settings > Security > Device administrators are all unticked

    I’ve tried and ran these in sequence locking/unlocking the individual apps did not do the trick:
    CM Security AppLock Clean
    CM Locker-AppLock,ScreenLock

    I have restored
    Lock Screen IOS 9
    and same situation 

    Thanks for your help!
    03-30-2017 03:43 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. You may have to consider doing a factory reset to get rid of this error.
    pkcable likes this.
    03-30-2017 09:33 AM
  3. satam's Avatar
    Thank you, that's what I feared. I'll have to back up first. Do you recommend doing this using my google account, or Helium, or...?
    03-30-2017 02:29 PM
  4. mstrblueskys's Avatar
    Thank you, that's what I feared. I'll have to back up first. Do you recommend doing this using my google account, or Helium, or...?
    Depends on what you want to backup. I agree that you may have triggered something deep within the system and uninstalling without deconfiguring (not sure that's a word, but let's run with it) may have locked some things in there forever.

    Backup your contacts to Google for sure. That's simple enough. There are two options for backup, maybe try both? I've used SMS Backup & Restore, and my brother uses SMS Backup+.

    Helium is amazing. It's pretty hands on if you're not rooted, but that's fine. If you're willing to do it (it's worth it!) then go for it!

    Good luck. Sorry there's no obvious quick solve for this.
    Golfdriver97 and pkcable like this.
    03-30-2017 02:52 PM
  5. satam's Avatar
    Thank you. Before I do a factory reset I'll see if rebooting in safe mode gives me any clues. I'll post the results tomorrow (it's almost 11pm here in Madrid)
    pkcable likes this.
    03-30-2017 03:41 PM
  6. satam's Avatar
    I'm afraid I've lost a phone. After starting it requests for a PW in the lockscreen, I input the usual unchanged PW and says wrong password. It's in a loop, I don't even see the POWER OFF option (which would maybe enable to start safe mode). Is there a way to rescue a bricked phone? (If this is the case as I suspect) Thanks!
    04-01-2017 07:05 AM
  7. satam's Avatar
    (see attached file)
    I finally managed –don’t ask me how, it was just trial and error- to recover my smartphone.

    First, I fully charged and left charging.

    Second, fiddling with the buttons, and just by chance, I happened to see in a flash this Recovery Menu:

    It’s a very, very small font, so I almost missed it, as it only shows for a few seconds.

    Here’s how you bring it up:
    Press&hold PWR & Vol Up for 10secs

    Select Boot Mode:
    [VOLUME_UP to select. VOLUME_DOWN is OK
    [Recovery Mode] (1)
    [Fastboot Mode] “Fastboot mode…”
    [Normal Boot]

    (1) Result: “No command” and the green android showing an open belly with a red sign.

    During start, and while the Blackview logo is on, VOLUME DOWN takes me into Safe Mode, where most of the apps do not start, so that I was able to go
    Settings > Apps > OS9 ScreenLock > Uninstall

    I could now even do a factory reset, but it was not necessary. Most of the apps are there, just a few settings have changed.

    Lock Screen IOS9 was the culprit, it must have a flaw that took me into the “wrong password” loop.

    It does have an option to introduce an email in case of a lost password, but the email never got sent.
    Attached Files
    04-03-2017 02:59 PM

Similar Threads

  1. Looking for new phone
    By AC Question in forum Google Pixel & Pixel XL
    Replies: 10
    Last Post: 04-07-2017, 04:36 AM
  2. How much could sell for?
    By yourfamilybank in forum Samsung Galaxy Note 5
    Replies: 14
    Last Post: 04-03-2017, 11:52 AM
  3. Samsung Galaxy S8's DeX dock - Will you be picking one up?
    By Bla1ze in forum Samsung Galaxy S8 & S8+
    Replies: 14
    Last Post: 04-01-2017, 03:24 PM
  4. Replies: 2
    Last Post: 04-01-2017, 03:39 AM
  5. Replies: 0
    Last Post: 03-30-2017, 02:55 AM