1. AC Question's Avatar
    After my Samsung S7 updated from Marshmallow to Nougat, my SD card (previously encrypted) can not be decrypted to be encrypted again in the new system. How to solve this issue?
    05-09-2017 09:57 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Can the phone still read the data on that card? If not, it sounds like the phone lost the encryption key during the update. I don't think this is supposed to happen, since you shouldn't have to remove your SD card prior to a system update, but every now and then, we hear about people losing data on the SD card after an update, so it may have been some glitch.

    If the phone has lost the encryption key, then the data on the card will be useless. You'd have to reformat the card.
    05-09-2017 10:29 AM
  3. sergiopezzo's Avatar
    Thanks for the reply, Diddy. But, since I don't have the option to reformat it on Android, do you have any suggestions on how to do it?
    Many thanks,
    05-09-2017 10:56 AM
  4. B. Diddy's Avatar
    Can you remove it and insert it into a PC to format it there?

    Thanks for registering -- when you get a chance, head over to the Introductions forum and tell us something about yourself! Introductions
    05-09-2017 11:48 AM
  5. LostButWnaBeFound's Avatar
    Hello there!
    This is my first time ever posting on a forum so I hope I'll do it right 😊
    I'm afraid I have a similar problem on my S7. My SD card is encrypted. I've noticed this problem today
    I'm able to access my files (pics, videos, recordings) on my SD card on my phone. When I connect my phone to my computer via USB, I can see all the files on the SD, I can copy them to my computer HOWEVER about 10% of all the files are not fully copied e.g. a picture sized 7 MB on my SD will be 5MB on my computer and won't open or will open so that some portion of the pic is OK and some of it just.. brown! Or gray :0 – that is although on my phone the picture is perfect! The videos and the sound files won’t even open ☹
    The other 90% are working fine on my computer however I really need some of the files that aren't being properly copied.
    When I go on my phone and try to decrypt the SD card I receive this message:
    “Unable to decrypt SD card
    This SD card cannot be decrypted”

    I have no idea how long this problem exist, I’ve just tried to backup my SD content to my computer and noticed this problem when I checked the size of the files that I copied to my computer and saw that they were smaller than the files on my SD card..

    However two days ago I had an update on my phone – not sure what it was, it run overnight, Samsung update or Google update- maybe it’s related??

    I’m hoping that this is fixable because I’m able to access the files on my phone..
    Tried to send them via email, WhatsApp, internal phone memory – no Luck.
    Tried to unmount and mount SD card – no luck.
    Tried to switch Screen lock type on my phone to “None” (I usually have a password) because I read it somewhere – still no luck ☹

    I’m running:
    8.0.0 Android version
    SD card is: SanDisk Ultra 64GB MicroSD XC I (10)

    Please help me 😊

    Many thanks!
    06-14-2018 02:08 PM

Similar Threads

  1. Why am I unable to do update Sony Xperia Z1 (SO-01F)?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 05-11-2017, 12:08 PM
  2. Replies: 0
    Last Post: 05-09-2017, 08:56 AM
  3. Replies: 1
    Last Post: 05-09-2017, 08:41 AM
  4. S7 edge restarts while chargine-sd corrupts
    By Willsamsung in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 05-09-2017, 08:34 AM
  5. S7 edge restarts while chargine-sd card corrupts
    By Willsamsung in forum General Help and How To
    Replies: 0
    Last Post: 05-09-2017, 08:23 AM
LINK TO POST COPIED TO CLIPBOARD