1. Android Central Question's Avatar
    My Samsung galaxy s7 edge seems to be running on the symbol h instead of 4g
    02-23-2018 12:35 AM
  2. Laura Knotek's Avatar
    Welcome to Android Central.

    Did you purchase your device from your carrier or elsewhere? Exactly what variant is your device? What country do you reside in, and what carrier do you have?
    02-23-2018 12:38 AM
  3. Healy10's Avatar
    Welcome to Android Central.

    Did you purchase your device from your carrier or elsewhere? Exactly what variant is your device? What country do you reside in, and what carrier do you have?
    I got my phone from the 3 store here on the UK. Which is also my service provider.
    02-23-2018 12:54 AM
  4. chanchan05's Avatar
    1. Make sure there is 4G coverage in your area. If there is none, or you are on the fringes, the phone may be defaulting to the stronger signal.

    2. Check the settings. Settings>Connections>Mobile Networks>set it to LTE/3G/2G
    Laura Knotek likes this.
    02-23-2018 01:00 AM

Similar Threads

  1. didn't set up a PIN - how do I get in after restart
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 02-23-2018, 04:25 PM
  2. My Samsung S8 frequently thinks I'm on a phone call when I'm not
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-22-2018, 11:20 PM
  3. How do i get my home screen back
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-22-2018, 10:01 PM
  4. Why is my led lights not working on my galaxy j3
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-22-2018, 06:56 PM
LINK TO POST COPIED TO CLIPBOARD