1. Android Central Question's Avatar
    Hi all,

    My Moto X Pure Edition's home, back and recent buttons suddenly stopped working last night. Every once in a while the recent button is activated and but it's never when I press it, just randomly. Sometimes after a restart the buttons work for a little while and then they stop again.

    I have not updated any system software recently, and am running android 7.0. I have tried clearing cache, freeing up space, clearing cache through recovery mode, and even factory reset. None of these measures worked. The problem persists.
    I removed my SD card and factory reset again, still no improvement. I know the touchscreen itself works because the area where the buttons are was used for other buttons in the factory reset process and they worked fine.

    I am desperate, I hope someone can help me! Thanks!
    05-19-2018 05:07 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does the same thing happen in Safe Mode? https://motorola-global-portal.custh...p/30,6720,9541
    05-20-2018 02:58 AM
  3. Linh Nguyen12's Avatar
    I have the same Phone same OS and the same problem. The soft keys extremely slow to respond at first but now are not at all.

    Safe mode or any other suggested solutions are not working.

    Factory reset several times (without restore) don't help either.
    08-20-2018 12:55 PM
  4. Rukbat's Avatar
    I'd guess it's a bad board (the one the soft keys are on). You'll have to get it replaced.
    Laura Knotek likes this.
    08-20-2018 04:22 PM
  5. B. Diddy's Avatar
    Welcome to Android Central! Since the keys are onscreen, that would suggest either a problem with the touchscreen or with the firmware. Doing a factory reset for corrupt firmware won't help, since the phone is still using the same copy of the firmware. On some phones, it's relatively easy to reinstall the stock firmware, but I'm not sure about the X Pure.
    08-21-2018 04:43 PM

Similar Threads

  1. Alarm sound doesn't work on Huawei P10
    By Android Central Question in forum Huawei P10 & P10 Plus
    Replies: 3
    Last Post: 07-27-2018, 02:03 PM
  2. Android Version & Names
    By mali01 in forum General News & Discussion
    Replies: 4
    Last Post: 07-13-2018, 03:03 AM
  3. moto G5 plus heating problem
    By luvkv in forum Moto G
    Replies: 5
    Last Post: 06-07-2018, 06:11 AM
  4. My phone audio and video is not playing in mobile
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2018, 03:01 AM
  5. Nokia Health mate stopped tracking steps after Oreo update?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-19-2018, 02:56 AM
LINK TO POST COPIED TO CLIPBOARD