1. Android Central Question's Avatar
    So if I want to send a text when I type in a name in the "receiptient" box, it will not recognize any contacts. All contacts are Google. If I create a contact and save to the phone, messages works as it should. Email works fine.
    Maui1 likes this.
    06-10-2018 07:09 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Apps and select the Messaging app. Then tap Permissions -- does the app have Contacts permission?
    djrakowski likes this.
    06-10-2018 05:06 PM
  3. 64rocket's Avatar
    Yes permissions are turned on. Had set to all contacts, phone, Google, Samsung, etc. I did find a fix.

    More settings
    Contacts to display
    Changed from all to custom.
    Chose Google account
    Checked all radial in the Google account. Prior imports etc.

    Now works like a charm. Phone knew where to look for contacts, google, but Google contacts needed to specified I guess.
    Thanks for the reply and hope this helps others.
    06-13-2018 10:02 AM
  4. B. Diddy's Avatar
    Thanks for the update! That's an odd bug. I remember something similar when trying to sync contacts to my old car's Bluetooth system -- it wouldn't work right if All was selected for Contacts to Display. I had to select specific groups.
    06-13-2018 11:07 AM
  5. 64rocket's Avatar
    Yes very puzzling indeed. I've owned androids for years and have never encountered an issue such as recognising contacts for messaging. Email and phone worked, just not texts. Start to type a contact in email or phone app and the list populates with possible contacts. This only affected messaging. Very strange indeed. Solved for now but when I told the phone to use all contacts groups, I would expect that it picks all contacts in each group, without having to go to a submenu to tell specific subcategories to use with Google. Again thanks for the input.
    B. Diddy and Run2Eat like this.
    06-13-2018 07:12 PM
  6. B. Diddy's Avatar
    If you want to investigate further, see if the problem persists in Safe Mode: https://support.t-mobile.com/docs/DOC-34283
    06-14-2018 11:16 AM
  7. Run2Eat's Avatar
    thanks for this list - saved my sanity!
    Maui1 likes this.
    09-24-2018 03:26 PM
  8. monicajo's Avatar
    I'm having this same problem, and the first recommended solution was already turned on, and i don't have a "more settings" in my contacts app from settings. Any other recommendations?
    02-27-2019 03:52 PM
  9. Maui1's Avatar

    It just worked for me. I own a Note 8.

    Try... Settings - Apps - Contacts.
    Then @ top right, click on the Settings logos (looks like a 6 petal flower).
    Then Contacts to show - Custom list (at bottom) - Then Settings logo (flower) to the right.
    Expand and add check mark to every file.... Google, Exchange, MSN Exchange ActiveSync, Outlook, etc ....

    I did that and now the messaging app finds my contacts!!!! Finally after hours of research.
    I hope this works for you as well..

    03-10-2019 04:42 PM

Similar Threads

  1. Why does updaflickering between the article I want to read and the home page
    By Shez wrong-un in forum General Help and How To
    Replies: 1
    Last Post: 06-10-2018, 05:11 PM
  2. Does any1 know to fully restore a LG 5 II to "brand new"?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2018, 05:08 PM
  3. Why is my sd card apps transfer and multuplying in the main screen
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2018, 03:03 PM
  4. Why my phone is not using google play service its mi 2s
    By Isingoma Francis in forum General Help and How To
    Replies: 1
    Last Post: 06-10-2018, 02:44 PM
  5. Issue: SD card not added up as internal
    By Koir in forum Android 6.0 Marshmallow
    Replies: 2
    Last Post: 06-10-2018, 08:45 AM