1. Android Central Question's Avatar
    Hello, i tried to flash my stock firmware (android 4.4.2) on my Galaxy A3 2015 (SM-A300FU). I flash the firmware and it went black, the phone is not turning on, i´ve tried to start the Phone into Download mode, but the Phone isnt responding to everything! When i plug the cable to my phone nothing is happening. I can´t take out the battery because the back of the phone is glued. Please help me, i´m thankful for every idea or comment
    04-22-2019 03:39 PM
  2. Rukbat's Avatar
    The phone came with 4.4.4, so whatever you flashed it with wasn't for the SM-A300FU. So the phone probably is hard-bricked, meaning you turned it into a paperweight. You can try holding the power button down for about 30 seconds, but if that doesn't bring it back, it's going to cost a lot more to fix it than to replace it (it's a 4-1/2 year old phone - you can get much better phones for the repair cost of that one).

    Next time, ask first, before you flash anything.
    04-22-2019 04:55 PM

Similar Threads

  1. P30 Pro not retaining 'Developer options' changes after phone restart
    By King Mustard in forum Huawei P30 & P30 Pro
    Replies: 1
    Last Post: 04-22-2019, 05:14 PM
  2. how to backup phone contacts samsung note 3
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-22-2019, 01:15 PM
  3. Replies: 1
    Last Post: 04-22-2019, 12:30 PM
  4. Replies: 1
    Last Post: 04-22-2019, 09:50 AM
  5. Replies: 1
    Last Post: 04-22-2019, 09:35 AM
LINK TO POST COPIED TO CLIPBOARD