1. sekramer10's Avatar
    I just got a new Samsung Tab E and the WIFI is absolutely horrible. Most times I go to a web page, it just hangs and doesn't load anything. The little blue progress bar never moves. Sometimes it will start to load a page and then just hang and display nothing. This is with me sitting right next to the router. I'm using Chrome, but also tried the Kiwi browser.

    The only thing that fixes it is if I cycle the WIFI enabled status. Turn it off and then back on right away, and the page will begin to load. I have to do this for almost every page I go to, or any link I click, I have to cycle WIFI first to get it to do anything. Sometimes I have to cycle WIFI several times to get pages to load. I also tried cycling airplane mode per a suggestion and it's the same thing as cycling WIFI.

    I am absolutely frustrated and disappointed with this device. Other devices I have work normally. Does anyone have any ideas as to how I can fix this?
    02-03-2020 09:54 PM
  2. mustang7757's Avatar
    Hi welcome !

    Is it only on your wifi or other places also ?
    sekramer10 likes this.
    02-03-2020 10:07 PM
  3. mustang7757's Avatar
    I took care your other post .
    sekramer10 likes this.
    02-03-2020 10:08 PM
  4. belodion's Avatar
    14h later.

    We obviously cannot help you if you don't respond.
    sekramer10 likes this.
    02-04-2020 12:58 PM
  5. me just saying's Avatar
    is it only at home or at other wifi locations too?
    sekramer10 likes this.
    02-04-2020 03:36 PM
  6. sekramer10's Avatar
    I'm really sorry for the delay. This is an important issue to me also. I have a 10 year old HTC Android phone that loads webpages 5x faster than this tablet, and it never hangs up trying to load them. I have another tablet, a Teclast that is just as good. My Win10 PC is also really good. The Tab E is really bad. I haven't tried it at another location yet. Thanks for the suggestion. I've noticed the Kiwi browser seems to do better than Chrome, but is still hanging. With the Tab E I have to toggle WIFI like 5 times to get it to log into my bank website.
    02-06-2020 07:44 PM
  7. B. Diddy's Avatar
    Welcome to Android Central! See if the tips here help: http://forums.androidcentral.com/amb...-problems.html
    02-06-2020 08:24 PM

Similar Threads

  1. How do I delete location history?
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 02-06-2020, 10:56 PM
  2. How do i accept a call on my phone?the press
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 02-04-2020, 01:00 PM
  3. I need to recover files from my phone, but the touchscreen is broken - Huawei P20 Pro
    By Android Central Question in forum Huawei P20 & P20 Pro
    Replies: 2
    Last Post: 02-03-2020, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD