1. Moltres_rider's Avatar
    Trying to connect to friend's wifi. My Droid RAZR keeps saying the password is incorrect but the same password works on all three of my laptops and sister's iPad. But my Droid RAZR insists that it is incorrect no matter how many times I enter it!!! I even told it to show password and verified that it is correct but it STILL says it's wrong!!! Google doesn't get much results on the issue, just a couple of isolated iPhone problems but NOTHING for Android or the Droid RAZR!!! I am ripping my hairs out on this one!!! Help!!!

    Posted via Android Central App
    07-13-2014 11:21 AM
  2. recDNA's Avatar
    This is an odd suggestion I know but ask your friend if he ever changed the password in the router. I did and a couple of months later I ran into your problem. I tried the OLD password and it worked! All my other devices were logged in on the new password for months. A while later I had to log in again and the new password worked again. Never figured out why but its never happened again.

    Another thing you can try is to unplug the router for 5 minutes, plug it in, then try again. That often works.

    Sent from my Hyperdriven Note 3
    07-13-2014 11:25 AM

Similar Threads

  1. Note3 (Verizon) still has 4.3, GooglePlay Music app not connecting
    By DeltaBond in forum Verizon Samsung Galaxy Note 3
    Replies: 4
    Last Post: 07-14-2014, 07:58 AM
  2. Memo Pad 10 password
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-14-2014, 03:24 AM
  3. argh! make it stop!
    By Baz69 in forum LG G3
    Replies: 5
    Last Post: 07-13-2014, 02:44 PM
  4. Voice guidance not working with Google Map
    By Axr6 in forum Verizon Samsung Galaxy S4
    Replies: 1
    Last Post: 07-13-2014, 11:15 AM