1. shanedw's Avatar
    I have a Galaxy S7 and I can't send emojis through text. It want me to go to text settings and change the input mode to Automatic. The problem is there is no input mode. Under text messages settings it says Manage Sim card messages. When you click on that it refreshes and says no messages. Is there anyone that can help?
    06-10-2018 04:44 PM
  2. Thacy's Avatar
    Input method should be set/changed on Settings app > Language and input. Not sure which keyboard/input method you are using and which you're going to move to, but the change should apply to all apps require a input method for text.
    06-10-2018 10:03 PM
  3. freeman10's Avatar
    I'm having this same issue. While it says to go to Settings and change input mode to automatic, when you click on Settings, the only option to click on is "Manage SIM card messages." There is no option to change the input mode. I've googled this issue, and no one seems to have a solution. Emojis send in MMS, but not SMS. When sending in SMS, they show up as question marks ??? This is using Samsung messages app.
    10-11-2019 10:41 AM
  4. B. Diddy's Avatar
    Sorry, are you saying that even with mobile data turned on and the message sending as MMS, the emojis still don't go through?
    10-11-2019 11:01 AM
  5. freeman10's Avatar
    Sorry, are you saying that even with mobile data turned on and the message sending as MMS, the emojis still don't go through?
    It sends if a MMS, with 2 or more recipients. If just sending to one recipient, it says to go to Settings and change input mode to automatic. Specifically, a pop-up says:

    "Change input mode

    In your current input mode, special characters, such as emojis and letters with diacritics, may not be shown correctly on the recipient device.

    To resolve this, tap SETTINGS below, then set the input mode to Automatic, or tap SEND to send the message anyway."

    When I do tap on Settings, the only option to click on is "Manage SIM card messages." There is no option to change the input mode. If I tap Send and send anyway, the emojis show up as question marks ??? This is using Samsung messages app.
    10-14-2019 02:43 PM
  6. freeman10's Avatar
    It sends if a MMS, with 2 or more recipients. If just sending to one recipient, it says to go to Settings and change input mode to automatic. Specifically, a pop-up says:

    "Change input mode

    In your current input mode, special characters, such as emojis and letters with diacritics, may not be shown correctly on the recipient device.

    To resolve this, tap SETTINGS below, then set the input mode to Automatic, or tap SEND to send the message anyway."

    When I do tap on Settings, the only option to click on is "Manage SIM card messages." There is no option to change the input mode. If I tap Send and send anyway, the emojis show up as question marks ??? This is using Samsung messages app.
    I should add emoji also sends if sending to 1 recipient with a picture attached (which converts to MMS). But if just 1 recipient, emoji will not send. Yes, data is on. Thanks for any input!
    10-14-2019 02:49 PM
  7. B. Diddy's Avatar
    Can you show a screenshot of what it looks like when it tells you to go to the settings menu?
    10-14-2019 03:43 PM
  8. freeman10's Avatar
    Input mode does not show up under messages>settings>text-change-input-mode.jpg



    And then, when I do click on Settings, the only option I have is to Manage SIM card messages:

    Input mode does not show up under messages>settings>text-manage-sim-card-messages.jpg

    Can you show a screenshot of what it looks like when it tells you to go to the settings menu?
    Please see images - thank you!
    10-14-2019 04:01 PM
  9. freeman10's Avatar
    Also, when I click on "Manage SIM card messages," it says "No messages." No options lead to changing input mode! This is an issue others on this forum report having, but so far, I can't find a solution.
    10-14-2019 04:05 PM
  10. B. Diddy's Avatar
    Hmm, that's not very good coding, is it? What if you go to the main settings menu for the messaging app -- any options there?
    10-14-2019 04:07 PM
  11. freeman10's Avatar
    Other threads here on this apparently unresolved issue:

    https://forums.androidcentral.com/sa...ing-issue.html

    https://forums.androidcentral.com/as...galaxy-s8.html

    Some have the option to change the input mode, and some don't!
    10-14-2019 04:16 PM
  12. freeman10's Avatar
    Hmm, that's not very good coding, is it? What if you go to the main settings menu for the messaging app -- any options there?
    The applicable option under the main settings menu is "More settings," which leads to the Text messages option captured above, Multimedia messages, and a few other settings, none of which lead to changing the input mode.
    10-14-2019 04:18 PM
  13. B. Diddy's Avatar
    Hmm, seems like the best thing to do would be to send feedback to Samsung (or contact Samsung support to see if they're working on this issue). In the meantime, you may want to try using a different SMS app, like Google Messages or Textra, and see if the problem persists there.
    10-14-2019 04:31 PM
  14. freeman10's Avatar
    Hmm, seems like the best thing to do would be to send feedback to Samsung (or contact Samsung support to see if they're working on this issue). In the meantime, you may want to try using a different SMS app, like Google Messages or Textra, and see if the problem persists there.
    Thanks for responding! Interestingly, no problems with sending in Google Messages or Textra, so it's an issue with the Samsung app (and possibly compatibility with my carrier?) Persists regardless of using Samsung Keyboard or GBoard. Just irksome that I can't figure this out!!
    10-14-2019 04:37 PM

Similar Threads

  1. I am not getting notifications for some apps
    By Android Central Question in forum Samsung Galaxy S9 & S9+
    Replies: 6
    Last Post: 06-11-2018, 04:21 PM
  2. Samsung tab E SM-T900 will not connect to Wifi
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2018, 04:43 PM
  3. Moto e4 Plus not allowing picture downloads with Windows 10 Home
    By denjones52 in forum Android 7.0 Nougat
    Replies: 1
    Last Post: 06-10-2018, 04:42 PM
  4. Why are my regular text messages showing up in my tango account
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2018, 04:39 PM
  5. Handwriting to text
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-10-2018, 04:30 PM
LINK TO POST COPIED TO CLIPBOARD