1. raceroz12's Avatar
    After 5 hours of work including an hour on the phone with Chromecast support who couldn't help me solve my issue I finally figured out how to make the Samsung S3 communicate with Chromecast! I thought I would post up the solution here in hopes of saving someone else hours of frustration, as once I got Chromecast working, I am absolutely thrilled with it.

    After installing Chromecast on my TV HDMI connector, my phone recognized its signal, but when I clicked on setup Chromecast on the phone, the screen twirled for about 2 minutes and then gave me the error "could not communicate with chromecast, please make sure your chromecast is nearby"

    The problem was not my WiFi router, its settings or proximity to the TV, It ended up being the WiFi setting on the phone.

    I went to Android settings, clicked on WiFi, then under WiFi click on the connection, click on edit connection. Scroll down and check the box labeled "advanced settings", this brought up a hidden menu for IP Settings. In IP settings choose "static" instead of "DHCP" and click apply or ok to save the settings.

    The moment I chose "static" connection and saved the WiFi settings, restarted the router it worked flawlessly!!!

    Chromecast support was pleasant, but could not resolve the issue, among the things they tried to change that didn't work were:

    1. Changing the "AP Isolation" setting on my router which I could not find anywhere in the router manual
    2. UPnP settings which come turned on in the default setting in my (belkin 750 N) router which is the setting you want
    3. Moving the router upstairs which did not work
    4. Trying a different router that produced the same error
    5. Resetting the router to default settings and resetting Chromecast

    Again, was an extremely frustrating experience, however now that it is working, I am thoroughly enjoying the Chromecast system. Rented a movie on Google play and it was excellent video quality, casting videos via youtube and through realplayer cloud. Can't wait for more apps to utilize the Chromecast platform.

    Hope this helps someone out there!

    Ken
    Trajadoja likes this.
    12-26-2013 07:49 PM
  2. Rajan Phull's Avatar
    Sir, you are my saviour!!!!
    Thankfully I was only an hour into trying to set it up, so thank you so much!
    03-21-2014 01:16 PM
  3. PatMac75's Avatar
    Hi...very appreciative of your post also! I just cant seem to get to the wifi settings part as you describe.
    I go to analogue settings
    go to wifi
    but then I cannot seem to find an edit option....?

    Sorry about this as I'm sure its simple but could you give me another steer on finding this please?

    Thanks guys,
    Pat
    10-07-2014 03:55 AM
  4. Jakepr's Avatar
    I bought the Chromecast with high hopes but alas the beast won't work with my S3. Too many settings and a new version software - 4.4.2 have me really confused as to where the problem lies. I tried the wifi change under 'advanced' but there was no change. Now I don't know if I have hosed up the entire communications. I can't get the display showing the Wifi networks to connect to Chromecast or my home network. Is this a problem with the 4.4.2, or is it because I changed the wrong setting? HELP
    11-14-2014 09:50 AM
  5. AC321's Avatar
    The moment I chose "static" connection and saved the WiFi settings, restarted the router it worked flawlessly!!!

    Hope this helps someone out there!

    Ken
    This drove me CRAZY on my Nexus 5 and Nexus 7 (neither worked). Thought it was because of Lollipop! Static IP fixed it!! THANK YOU!!!!
    11-22-2014 11:23 PM
  6. luke mersh's Avatar
    thanks for that info.
    but there is no static IP setting on my Samsung galaxy S3 pebble.

    maybe you can shed some more light
    12-30-2014 05:47 AM
  7. luke mersh's Avatar
    I found out how to set up static Ip-
    now for trying out
    12-31-2014 05:41 AM
  8. luke mersh's Avatar
    Hi...very appreciative of your post also! I just cant seem to get to the wifi settings part as you describe.
    I go to analogue settings
    go to wifi
    but then I cannot seem to find an edit option....?

    Sorry about this as I'm sure its simple but could you give me another steer on finding this please?

    Thanks guys,
    Pat
    hi there..
    if you havent found how to change it - go to your connection and long press the connection (y)
    12-31-2014 06:15 AM
  9. Rukbat's Avatar
    I went to Android settings, clicked on WiFi, then under WiFi click on the connection, click on edit connection. Scroll down and check the box labeled "advanced settings", this brought up a hidden menu for IP Settings. In IP settings choose "static" instead of "DHCP" and click apply or ok to save the settings.

    The moment I chose "static" connection and saved the WiFi settings, restarted the router it worked flawlessly!!!
    Something's wrong with Android or your router, then. I just did a little analysis on my phone. If you change the connection from DHCP to Static, and don't change anything else, the only thing that changes is that the phone doesn't ask the router for an IP address, it uses the one it got from the router the last time. (Most devices make you enter an IP address, because the router isn't supposed to allow a static connection from an address its DHCP server leases - which is what's happening here.) IOW, from a TCP/IP viewpoint, changing the setting doesn't do anything.

    That says that either something else is happening when you set the phone to a static IP (which is like saying that making a right turn includes filling the gas tank) or your router is trying to give Chromecast the same IP address as it's giving your phone - which isn't going to work in this universe. When you restart the router, your Chromecast probably gets an IP address before the phone does, so you don't have 2 devices with the same IP address on the network.

    But, since what you found solves everyone's problems, I'm not going to waste any more time trying to figure out who caused the problem. I had enough of a headache trying to figure out why KitKat won't connect to modern Linksys routers at full speed. (And was very sad to learn that Linksys, once a company interested in technology, now only cares about the technology of green ink on rag paper, and how to amass lots of it.)

    So good find, Ken. You've helped a lot of people.

    And Luke, yes. Long press the connection you're connected to, press Modify network config, then check the Show advanced options box. Scroll down to IP settings and press DHCP and select Static.
    droidntn likes this.
    01-01-2015 08:17 PM
  10. luke mersh's Avatar
    I actually managed to get it to work without using static IP.
    Only prob now is, some series on youtube are rather large and tend to play and stop and then start again, so I guess thats just the buffering.
    But thanks all the same for sharing the info.
    01-02-2015 05:56 AM
  11. Alistair McCulloch's Avatar
    I have galaxy s3 mini and tried everything listed on forums about changing to static, my phone connects and I see phone screen then message to say lost connection, please help

    Ally
    02-24-2015 01:19 PM
  12. droidntn's Avatar
    THANK YOU THANK YOU THANK YOU......
    This finally fixed my error on my S4 and my son's S5.
    I'd hate to mess with router settings and screw something up.
    Good deal and thanks for posting.
    03-01-2015 08:11 PM
  13. Laurie Reese's Avatar
    Thanks so much for the tip!! I had given up on giving my husband control over his phone & Chromecast -- your solution worked perfectly!! Even though you posted this years ago, it still works!!
    08-10-2015 11:36 AM

Similar Threads

  1. S3 camera voice control doesn't work
    By talltail13 in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 14
    Last Post: 11-14-2015, 02:18 PM
  2. 4.3 update wont allow me to Sync my Emails with built-in Email app.
    By LionheartedNJ in forum AT&T Galaxy S III
    Replies: 6
    Last Post: 08-26-2014, 07:27 PM
  3. Samsung TV Turning Off
    By Rocky Wenskus in forum Google Chromecast
    Replies: 4
    Last Post: 01-07-2014, 04:49 PM
  4. Samsung Galaxy S4 battery life
    By ToastedJellyBowl in forum Verizon Samsung Galaxy S4
    Replies: 5
    Last Post: 01-02-2014, 08:54 PM
  5. Problems with Mobile ID via Virgin Mobile- HELP!
    By Allyson Skinner in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 12-26-2013, 10:28 PM
LINK TO POST COPIED TO CLIPBOARD