1. jrsnow94's Avatar
    My Bluetooth earbuds have been performing flawlessly with my Pixel 3 and I recently updated my phone yesterday. It was an Android 9 update. Now, this morning, my earbuds keep disconnecting from my phone and can't even stay connected for 10-15 seconds. They're fully charged and I even re-paired them. For all I know, it's a coincidence and my Earbuds may just be kicking the can already and I need better ones, but this didn't happen until I updated my phone last night. Anyone else having the same problem after this update or do I need to get a new pair of earbuds?
    01-09-2019 11:19 AM
  2. Thegreatone3's Avatar
    Same thing happened to me between my Pixel 3 and my Gear S3 watch. Constant connect and disconnect. Restarting both devices seems to have fixed it for me.
    01-09-2019 11:27 AM
  3. swebb's Avatar
    Fortunately for me, the update seems to have fixed some issues. My car (Acura) and my Plantronics Legend did not play well together prior to the update. Now, both are working as expected. My Sammy Gear Sport watch is also fine with the update.
    01-09-2019 12:42 PM
  4. J Dubbs's Avatar
    I always restart my phone twice after an update, the pixels no longer have the option to wipe the cache partition in Android 9, but restarting them now has a similar effect. So far I haven't had any issues ;-)
    01-09-2019 04:10 PM
  5. pbc's Avatar
    Try adjusting the AVRCP version from 1.4 to 1.3 under developer options for Bluetooth. Then do a hard reset by holding the power button until it resets.

    Had the same issue where Bluetooth was working with my new pixel 3 xl last week and then suddenly topped this week with other older Bluetooth devices also connecting and disconnecting every several seconds (my Tune2air device}.

    Reverting to 1.3 fixed everything.
    dabiker68 and mrpackerguy like this.
    01-09-2019 07:33 PM
  6. bcfour's Avatar
    I had to re-pair two devices (car and one set of earbuds). Everything else like my Fitbit and other speakers worked fine. Bizzare.
    01-09-2019 09:23 PM
  7. cknobman's Avatar
    I'm not on a pixel (note 9) but after my pie update I noticed increased battery drain.

    Turned off bluetooth and battery drain issues went away. Anyone noticing increased battery drain with their Pixel?
    01-10-2019 08:52 AM
  8. silentandcliche's Avatar
    On my Galaxy S9+, in call Bluetooth stopped working. It works for media, just not in call. When I go into the Bluetooth settings to manually turn on the in call Bluetooth, every time I attempt to select it, the toggle automatically goes back to the "off" position.
    02-12-2019 10:11 AM
  9. Mike Dee's Avatar
    On my Galaxy S9+, in call Bluetooth stopped working. It works for media, just not in call. When I go into the Bluetooth settings to manually turn on the in call Bluetooth, every time I attempt to select it, the toggle automatically goes back to the "off" position.
    If you are looking for a solution have you tried the Samsung threads?
    02-12-2019 10:26 AM
  10. J Dubbs's Avatar
    On my Galaxy S9+, in call Bluetooth stopped working. It works for media, just not in call. When I go into the Bluetooth settings to manually turn on the in call Bluetooth, every time I attempt to select it, the toggle automatically goes back to the "off" position.
    Unpair and re-pair your headset, with a phone restart in-between, that should fix it. Also if your Samsung still gives you the option to clear the cache partition do that after every security/os update.
    02-12-2019 03:30 PM
  11. chuck1118's Avatar
    I have the Samsung Galaxy S9. Since i updated to android 9 my LG Tone Infinitim headphones and Ford Sync features don't work for listening to music. The buttons to skip, back to previous song, stop features don't work. They work for a minute until the phone locks. Then the features don't work. Very frustrated!!
    03-15-2019 06:56 AM
  12. DroidFanSakura's Avatar
    Workaround Solution for my Samsung S9+, Android 9


    I had an issue with my S9+ not pairing with my bluetooth car stero and my PC. I reset network settings, and even did a factory reset. None of that worked.


    What worked for me was to put my phone in Safe Mode and then pair it to my car stereo or any other bluetooth device that I was having issues with. To put your S9+ in Safe Mode, hold own the power button on the side of the phone. Hold down the Power Off button on the screen until Safe Mode appears on the screen. The phone will reboot. While the phone is in Safe Mode, pair it with your bluetooth device(s). After a successful pairing, Safe Mode can be turned off. The phone will reboot and it should keep the bluetooth pairing that you made in Safe Mode.



    https://android.gadgethacks.com/how-...-mode-0183343/
    03-17-2019 12:54 AM
  13. mrpackerguy's Avatar
    I just noticed this morning several bluetooth disconnects from my bose bluetooth speaker this morning. Irritating
    03-17-2019 05:15 PM
  14. dabiker68's Avatar
    Try adjusting the AVRCP version from 1.4 to 1.3 under developer options for Bluetooth. Then do a hard reset by holding the power button until it resets.
    This worked perfectly - thanks!
    03-18-2019 05:14 PM
  15. Spartan 1's Avatar
    Fixed
    04-20-2019 05:33 PM
  16. GSDer's Avatar
    Other phones work with bluetooth in the car. Not sure what to do??
    Get one of the other phones?
    J Dubbs likes this.
    04-20-2019 08:15 PM
  17. J Dubbs's Avatar
    Get one of the other phones?
    LMAO
    04-21-2019 04:10 AM
  18. mustang7757's Avatar
    I suggest the people having issues with their Samsung phones to try the Samsung forums for better help with bluetooth issues as this is more specific for Pixels.
    04-21-2019 09:42 AM
  19. mrpackerguy's Avatar
    Try adjusting the AVRCP version from 1.4 to 1.3 under developer options for Bluetooth. Then do a hard reset by holding the power button until it resets.

    Had the same issue where Bluetooth was working with my new pixel 3 xl last week and then suddenly topped this week with other older Bluetooth devices also connecting and disconnecting every several seconds (my Tune2air device}.

    Reverting to 1.3 fixed everything.
    Fixed 2 issues for me:restored connectivity to my bose bluetooth speaker and restored download ability to an app
    04-21-2019 11:17 AM
  20. pbc's Avatar
    Well, out of the blue my phone started acting up again last week. Keeps disconnecting from my cars Bluetooth, and I double checked but it is still on AVRCP1.3, there isn't an option to go lower, though there appears to be a 1.5 and 1.6 now (not sure if those were there before).
    05-13-2019 07:49 AM

Similar Threads

  1. Pie update for X4 Prime rolling out
    By pazzo02 in forum Moto X4
    Replies: 1
    Last Post: 01-15-2019, 12:31 PM
  2. Android Pie for Nokia 8 Sirocco finally!!
    By Ultra Male in forum Nokia 8 & Nokia 8 Sirocco
    Replies: 2
    Last Post: 01-09-2019, 02:02 PM
  3. phone vs bluetooth, battery life
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2019, 11:21 AM
  4. Replies: 0
    Last Post: 01-09-2019, 07:36 AM
  5. Can I get a working android tablet?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2019, 07:02 AM
LINK TO POST COPIED TO CLIPBOARD