1. TrophyNostalgia's Avatar
    Hey guys,

    So I'm not sure if it was after a recent update, but in the last couple of days my HTC 10 has erratically started popping with dialogue on-screen that states the following error message:

    "Error: java.lang.SecurityException:
    PermissionDenial: writing
    com.htc.launcher.LauncherProvider uri
    content://com.htc.launcher.settings/favorites?notify=true from pid=28864
    uid=10156 requires com.htc.launch
    er.permission.WRITE_SETTINGS, or
    grantUriPermission()"

    This appears for a brief second or two when I switch between applications or when I return to the home screen. It appears that something is attempting to perform a write function or setting adjustment for an HTC Launcher application? However, I don't do any coding, breaking, etc with my phone. Everything online points to this as being a developer code error. Any thoughts how to get rid of this or why it's happening in the first place?

    Thanks!
    07-20-2018 07:32 PM
  2. kwsv's Avatar
    I'm getting the same message. It started yesterday. Any help would be greatly appreciated!

    Thanks bunches!!!
    07-21-2018 03:49 AM
  3. 47Ash47's Avatar
    Bump!

    I'm having this same etror, every message i send results in this error.

    Please advise.
    07-21-2018 04:30 AM
  4. Tim98TA's Avatar
    Same here but only when using Textra.
    07-21-2018 09:01 AM
  5. pootyash's Avatar
    Me too! This pops up every time I send or receive a message on Textra but stops when switching to "Messages" app. Would this mean the problem is on Textra's end?
    07-21-2018 10:22 AM
  6. Caticusrex's Avatar
    Same issue here. It seems to have started when my phone updated Textra. It's definitely all Textra on my end. Any news as to a fix?

    Cheers
    07-21-2018 12:00 PM
  7. pootyash's Avatar
    Not sure... I sent a message to Textra. Sure hope they fix it; I love their app!
    07-21-2018 12:20 PM
  8. pootyash's Avatar
    I'm on Verizon... Other carriers also affected?
    07-21-2018 12:22 PM
  9. Nikki LikesPandas's Avatar
    Same problem sending and receiving messages on AT&T M8. I switched to Android messages to avoid the error, set it as my default app then went back to Textra. Now I am no longer getting this error, but I've only sent a few messages since. We'll see if it's fixed, maybe this will work for someone else.
    07-21-2018 04:02 PM
  10. 47Ash47's Avatar
    I'm using textra too now that you mention it, guess it must be a Textra thing :O
    07-21-2018 08:29 PM
  11. pootyash's Avatar
    Just heard back from Textra:

    "Known issue. Pls disable Badge App Icon in Textra settings which will fix it while the dev team is working on it."
    07-21-2018 08:50 PM
  12. ksmith2282's Avatar
    Thank you, this has been driving me crazy. At least there's an easy way to suppress the error
    07-21-2018 10:06 PM
  13. kwsv's Avatar
    Disabled badge icon. Still receiving message. 😔
    Anyone else still having problem?
    07-21-2018 11:51 PM
  14. pootyash's Avatar
    Disabled badge icon. Still receiving message.
    Anyone else still having problem?
    No, this stopped the problem for me. Did you disable badge within the actual app's settings?
    07-22-2018 10:50 AM
  15. kwsv's Avatar
    Yep
    07-22-2018 11:00 AM
  16. Haley Brown2's Avatar
    I to started getting this error a few days ago..I seen textra mentioned in a comment below because I use textra too. Just uninstalled all apps downloaded in the last few days but it's still happening. It's annoying as hell.
    07-22-2018 01:36 PM
  17. Haley Brown2's Avatar
    Yay thanks a bunch
    07-22-2018 01:37 PM
  18. TrophyNostalgia's Avatar
    Haha, wow ok it wasn't just me. I confirmed it was Textra too within the last couple of days. Hope they fix this soon.
    07-22-2018 09:52 PM
  19. Tim98TA's Avatar
    Just heard back from Textra:

    "Known issue. Pls disable Badge App Icon in Textra settings which will fix it while the dev team is working on it."
    This worked for me too!!
    07-23-2018 06:53 AM
  20. Tim98TA's Avatar
    Textra update this morning seems to have fixed it. I turned back on the Badge App Icon setting and did not get error.
    07-23-2018 09:07 AM

Similar Threads

  1. Replies: 1
    Last Post: 07-20-2018, 06:44 PM
  2. How do I fix error 6500 to get service in Mexico?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-20-2018, 05:27 PM
  3. FAIL(flash_cmds error! ) appearing while flashing with a custom rom
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-20-2018, 06:14 AM
  4. LG X Charge Getting Strangely Hot And Authentication Errors?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-19-2018, 03:12 PM
  5. Priv “raw download failed because storage location is not reachable error”
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-18-2018, 09:31 PM
LINK TO POST COPIED TO CLIPBOARD