11-19-2018 05:50 AM
55 123
tools
  1. Mapleleiah's Avatar
    Hello,

    Happy New Year to you all!

    I have owned a Huawei P9 Lite for roughly 6 months now and am quite happy with it. However, for the past few days, I've been having the following problem ...

    Whenever I open the camera, I get an error, which, roughly translated from Dutch, says "Camera is recording audio. Com.google.android.googlequicksearchbox:interactor can't open at the moment"

    (I added a screenshot)

    If I tap "OK", the error message disappears, but pops right up again seconds later. I can use the camera, but it is of course very annoying if you can't see what you're snapping pictures of.

    I've been Googling about this and I found out that Quicksearchbox refers to a search box or Google Now. However, I do not have a search box widget on my screen and I also don't see the connection between the camera and that, nor the link with Google Now.

    I can't find any topics about the entire error on Google.

    Does anyone have any idea what's going on? I would prefer not to do a factory reset if not necessary.

    Greetings,

    Lenny
    Attached Thumbnails Error regarding Googlequicksearchbox in camera of P9 Lite-screenshot_2017-01-06-12-16-48.jpg  
    Tynish11 and Abolror77 like this.
    01-06-2017 06:39 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try wiping the cache partition: http://www.solvemix.com/index.php/an...rtition-solved. If the problem persists, see if it goes away in Safe Mode: http://consumer.huawei.com/ca/suppor...a.htm?id=55398. If it does, then something you installed is interfering. You might have to uninstall apps one by one until the problem goes away.
    01-08-2017 12:02 AM
  3. Mapleleiah's Avatar
    Thank you... Clearing the cache seems to have done the trick!

    Lenny

    Welcome to Android Central! Try wiping the cache partition: http://www.solvemix.com/index.php/an...rtition-solved. If the problem persists, see if it goes away in Safe Mode: http://consumer.huawei.com/ca/suppor...a.htm?id=55398. If it does, then something you installed is interfering. You might have to uninstall apps one by one until the problem goes away.
    B. Diddy likes this.
    01-09-2017 07:13 AM
  4. B. Diddy's Avatar
    Great! Let us know if the problem returns.
    01-09-2017 11:03 AM
  5. SHILSHIL's Avatar
    Also I am facing same problem with mate 9 .

    While using some apps like yeecall,WhatsApp or even phone above error will pop-up.

    In the begining I thought it's a software issue and I did reset the phone twice but nothing happened.

    So please advice
    01-15-2017 01:43 AM
  6. Gretar Gje's Avatar
    Also I am facing same problem with mate 9 .

    While using some apps like yeecall,WhatsApp or even phone above error will pop-up.

    In the begining I thought it's a software issue and I did reset the phone twice but nothing happened.

    So please advice
    I just bought a P9 yesterday and had the same problem, the issue is that I had enabled "OK Google" to work from every screen, soon as I disabled that, the error stopped showing up in various apps. To bad the mic can't handle two apps at a time :/
    semajm likes this.
    01-18-2017 07:46 AM
  7. Adamh3005's Avatar
    Just to confirm what Gretar has said, go to your Google Now settings - Voice - and disable the bit where you can access Google now from any screen by saying "OK Google". I had exactly this problem but as soon as I disabled this it sorted it out.

    Obviously the 'ok google from any screen' setting means having the microphone permanently on, which seemingly causes lots of issues in other apps.
    semajm and spewak like this.
    02-18-2017 09:49 AM
  8. Bigbadboogie's Avatar
    I had the same problem with my p8 (not lite)
    However I solved it differently. (Edit did not solve, issue came back)
    (Wiping cache did not help)
    I disabled quick calling (Huawei feature) since it seems Huawei related and I trust Google SW more than Huawei =)

    1 Search for voice in settings (in settings search box)
    2 choose voice control
    3 choose quick calling
    4 turn quick calling off
    Done

    no more issues and I have "hello google" still active so I guess the 2 features were fighting about mic and when camera also request, 3parties was too much.
    Issue came after updating to latest build nr ending with b390 and emui 4.0.1 on Android 6.0

    Edit: issue came back, so it seems like I need to turn off hello goggle as well.
    Oh and it was a l8tr phone I have
    02-24-2017 04:43 AM
  9. semajm's Avatar
    I had the same problem with my p9 (not lite)
    However I solved it differently.
    (Wiping cache did not help)
    I disabled quick calling (Huawei feature) since it seems Huawei related and I trust Google SW more than Huawei =)

    1 Search for voice in settings
    2 choose voice control
    3 choose quick calling
    4 turn quick calling off
    Done

    no more issues and I have "hello google" still active so I guess the 2 features were fighting about mic and when camera also request, 3parties was too much.
    Issue came after updating to latest build nr ending with b390 and emui 4.0.1 on Android 6.0
    I tried this route unfortunately it didnt work for me on my P9 but turning google voice off on every page did.
    Hopefully 1 of the 2 will for future readers
    02-28-2017 09:21 AM
  10. Ahmad A R's Avatar
    I can't find voice in setting. Care to give step by step instructions?
    03-02-2017 03:55 AM
  11. ampentium2's Avatar
    Is there anyway to fix this without turning off the "OK Google" from any screen??? I use that features heavily. Clearing the cache doesn't fix it for me.

    Since this used to work for me, but not anymore... I'm hating Huawei right now...
    03-02-2017 05:42 AM
  12. ChrissO's Avatar
    I can't find voice in setting. Care to give step by step instructions?
    It is if you go in to like your making a call then press on the right bottom lines and go to setting you have it there.

    But mine was off and cleaned cache.. still get the error on my P9
    03-02-2017 06:58 AM
  13. nurfikri fahmi's Avatar
    unfortunately, my problem still not solve. I've done the wipe cache but it doesn't work on my Huawei p9 lite. Is this the problem that caused by this phone since I'm Huawei p9 lite user as well? I hope that there will be other ways to solve this problem. Please kindly help me.
    03-02-2017 11:01 AM
  14. nurfikri fahmi's Avatar
    Just to confirm what Gretar has said, go to your Google Now settings - Voice - and disable the bit where you can access Google now from any screen by saying "OK Google". I had exactly this problem but as soon as I disabled this it sorted it out.

    Obviously the 'ok google from any screen' setting means having the microphone permanently on, which seemingly causes lots of issues in other apps.
    This method really solved my problem. Thank you for sharing ^_^
    03-02-2017 11:15 AM
  15. grandpa220's Avatar
    I had the problem on the Mate 9. The above solution to disable 'access Google Now from any screen' worked beautifully. Thanks.
    spewak likes this.
    03-03-2017 09:34 PM
  16. Nicu Scorus's Avatar
    Just to confirm what Gretar has said, go to your Google Now settings - Voice - and disable the bit where you can access Google now from any screen by saying "OK Google". I had exactly this problem but as soon as I disabled this it sorted it out.

    Obviously the 'ok google from any screen' setting means having the microphone permanently on, which seemingly causes lots of issues in other apps.
    Thanks, it was useful for me as well. I met the same situation on a P9.
    I tried turning off Huawei's quick calling, but nothing changed. Disabling OK Google seems the easiest solution.
    03-04-2017 02:58 PM
  17. Muhammad Jasim's Avatar
    i got solution for my P9 lite.
    Following the Steps

    1- settings
    2- google
    3- search
    4- voice
    5- 'Ok Google' detection
    6- Delete voice model
    7- Ok
    8- Enjoy
    Linarian, rickd88 and JazzyBen like this.
    03-04-2017 03:05 PM
  18. GF Wong's Avatar
    This happened on my Mate 9. The persistent error message will pop up in every app that uses the microphone. Tried clearing cache, wiping cache partition but didn't help. The only way is to disable OK Google detection from any screen. Sad that there's no other way.
    Error regarding Googlequicksearchbox in camera of P9 Lite-img_20170306_111044.png
    Error regarding Googlequicksearchbox in camera of P9 Lite-img_20170306_111952.png
    Error regarding Googlequicksearchbox in camera of P9 Lite-post-474391-1488758225_thumb.jpg
    Abolror77 likes this.
    03-04-2017 07:31 PM
  19. Kajaal Pradeep's Avatar
    Thank you for the steps below.. It really helped me locate ok Google on my honor 8.


    i got solution for my P9 lite.
    Following the Steps

    1- settings
    2- google
    3- search
    4- voice
    5- 'Ok Google' detection
    6- Delete voice model
    7- Ok
    8- Enjoy
    03-04-2017 07:39 PM
  20. glella's Avatar
    I have the same error in my mate 9

    It used to work with no issues but not these dialogs pop-up all the time while using the mic on other apps. The only way to disable is to disable voice control from any screen as stated above

    Also everytime I connect or disconnect phone to computer or charger another dialog pop-ups. Very annoying

    Seems like a Huawei soft issue as it started happening after the last update. Tried cleaning cache, etc but did not work
    03-08-2017 10:31 PM
  21. jackmichealb's Avatar
    Just to confirm what Gretar has said, go to your Google Now settings - Voice - and disable the bit where you can access Google now from any screen by saying "OK Google". I had exactly this problem but as soon as I disabled this it sorted it out.

    Obviously the 'ok google from any screen' setting means having the microphone permanently on, which seemingly causes lots of issues in other apps.
    This worked so well. Thank you, tried cleaning cache, but it didn't work on P9 lite.
    03-11-2017 03:33 AM
  22. brad7529's Avatar
    Clearing cache in play services worked for me. Definitely coming from there bc I just got the google assistant update...lost features vs google now. Only setting I have is for it to always listen...no separate settings for any screen, screen off, personal results....plus I couldn't even turn off that 1 always listening option to troubleshoot so, ironically, I deleted voice model, then set it back up, THEN I started getting this error and ended up here. But I want voice so started by deleting cache and that's working for now. Despite wanting it so badly, assistant has just been a pain on Honor so I'm sure this or something else will be broken again tomorrow.
    03-11-2017 05:43 AM
  23. Fio Tryff's Avatar
    This has definitely something to do with the latest update.
    Tried all the solutions above, none worked on my Honor8.

    For now, I've completely denied Google app access to the microphone.

    Settings - permissions - microphone

    So far so good
    03-11-2017 08:39 AM
  24. Aliboy27's Avatar
    Thank you for sharing this. I've had this problem for 2 weeks and it is finally solved. You are an absolute legend.
    03-11-2017 03:39 PM
  25. Aliboy27's Avatar
    Hopefully Huawei release an update to fix this problem if its possible.
    Abolror77 likes this.
    03-11-2017 03:41 PM
55 123

Similar Threads

  1. Replies: 2
    Last Post: 02-06-2017, 12:38 PM
  2. Galaxy core prime camera not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2017, 03:28 PM
  3. Desire 816 camera is not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2017, 07:52 AM
  4. Replies: 1
    Last Post: 01-06-2017, 07:49 AM
  5. gallery is not displaying even in apps list
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2017, 05:10 AM
LINK TO POST COPIED TO CLIPBOARD