1. Henry Wang1's Avatar
    My LG G4 on a Tmobile network running Android version 5.1 use to work perfectly fine on my home WiFi. Now, the phone connects to the router but then prompts me with the message "Internet not available". I have other devices (Iphone, Ipad, Amazon fire stick, Galaxy note tablet) that work fine. I've done a factory reset on my phone which solved the issue for a day or two but then the issue started again. I've also did a hard reset on the router. If there is more information needed please let me know and I'll post it. Thanks!
    01-15-2016 07:52 AM
  2. fotyc's Avatar
    I don't know why this happens, but it's happening to my daughter every once in awhile - she streams a lot of video so she uses our wifi and says this occasionally.
    We have Comcast/Xfinity and one of their boxes. I also have a G4 and the few times I use wifi I never have an issue.
    01-15-2016 08:48 AM
  3. Nyjac's Avatar
    Happens to me occasionally as well, I just go into settings and reconnect to my WiFi. Sometimes I let it be and it reconnects to my WiFi on its own. Don't know why this happens, I just deal with it.
    01-15-2016 09:24 AM
  4. tardus's Avatar
    I've had a few issues with other devices on my network when I switched to pure WPA-2 instead of WPA/WPA/2 mixed mode.

    My G4, unlike iPhone 5s and some older wireless cards has been solid.
    01-15-2016 12:10 PM
  5. OrangeScuba's Avatar
    I have been dealing with this for almost a month now with my G4. My wife also has a G4 but has no issues at all. It all started once I installed a new Modem and a Netgear Nighthawk 8500 Router that has a tri-band 5Ghz and 2Ghz. I've tried creating static ip's, reset router default, tweeked ALL of the router settings per internet blog suggestions, changing channels, disconnecting all devices... and so on and so on. I found the best way for a (somewhat) stable internet connection is to just reboot my router and my phone in the morning and that (usually) works. I am hoping either the Marshmallow upgrade or a router firmware upgrade will eventually resolve it. Knowing my luck though, I'm not holding my breath.

    Posted via the Android Central App
    01-15-2016 11:35 PM
  6. fotyc's Avatar
    It all started once I installed a new Modem and a Netgear Nighthawk 8500 Router that has a tri-band 5Ghz and 2Ghz.
    That's when it started for her too, we went from a simple Verizon DSL router to a dual band 5/2.4 router. My network printer also started having connection problems at the same time although my other devices (laptops, tablets) are fine - just the printer and one G4 are freaking out.
    01-16-2016 09:33 AM
  7. nik19605's Avatar
    I am having the same problem with my G4, I upgraded the router from a Linksys EA6900 to a Nighthawk X8. I got the Marshmallow update and that did not fix it. Last night i factory reset my G4 and it is still doing it. I have been working with Netgear tech support, but they are not sure what is wrong. If anyone wants to help me, can you please message me your model number and a list of all the apps that is on your phone.

    Posted via the Android Central App
    01-16-2016 11:34 AM
  8. OrangeScuba's Avatar
    That's when it started for her too, we went from a simple Verizon DSL router to a dual band 5/2.4 router.
    Yeah, I was thinking about returning my Netgear tri-band router for the Asus but it seems the reviews on that one has similar issues.
    I am wondering if it might be some kind of weird cache issue because I have noticed as I attempt to monitor the Mbps speed test, that it slows down after awhile before dropping. The more I test it the faster I lose internet and have to reconnect or restart my phone. Or reboot both phone and router.

    Posted via the Android Central App
    01-17-2016 04:34 AM
  9. OrangeScuba's Avatar
    I upgraded the router from a Linksys EA6900 to a Nighthawk X8. I got the Marshmallow update and that did not fix it. Last night i factory reset my G4 and it is still doing it. I have been working with Netgear tech support, but they are not sure what is wrong.
    Great.. so Marshmallow won't fix it... Netgear tech support isn't very good. I do love the X8 though just wish they would hurry with a real firmware update. I installed the beta firmware they have for it but Its not a fix. (firmware ver. V1.0.2.28_1.0.42) found it on Netgear community site. https://community.netgear.com/t5/Nig...1022273#M23449
    You might wanna update. The MU-MIMO adds some improvement.

    Posted via the Android Central App
    01-17-2016 04:58 AM
  10. nik19605's Avatar
    I do not want to dredge up an old thread, but i found that after my G4 died and got my refurbished ones I still had problems with the router with my G4. I finnally had enuff of the crap with the G4 (both my wife and I went thru 5 refurbished between the 2 of us) I dumped the G4 and got Galaxy S7 and never had a problem with the WiFi again. That leads me to believe it was the G4 causing the problems not the Nighthawk X8 router.
    08-29-2016 08:02 PM
  11. RapidTurtle's Avatar
    I've had the same issue for a while. I know it's not the router, because it happens in multiple places on wifi. It irritates me just enough to start looking for a new phone.
    08-30-2016 09:09 AM
  12. nik19605's Avatar
    I remember when i had the linksys EA6900 i did not have a problem, but when i switched to the nighthawk X8 that was when i had the problem, and I had it with multiple G4s, once i got rid of the G4s and went to the Galaxy S7 i never had a problem again. Now with the G4s I found this as a workaround, do not use the 5.0 ghz wifi signal, only use the older 2.4ghz WiFi to connect to the G4, I never had a problem with it then besides a slower network since the 2.4ghz is slower thay 5.0ghz WiFi
    08-30-2016 12:24 PM
  13. tomingchen's Avatar
    I'm frustrated with LG G4 basic capability issue. Wifi is not stable at all with latest software.
    10-07-2016 03:53 PM

Similar Threads

  1. Galaxy S5 Does Not Charge
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 06-29-2016, 01:08 AM
  2. Network not stable
    By nkrumahisaacivan in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 3
    Last Post: 01-17-2016, 08:49 AM
  3. Replies: 1
    Last Post: 01-15-2016, 06:59 AM
  4. My phone will not come to the end of optimizing?
    By AC Question in forum Google Nexus 5
    Replies: 1
    Last Post: 01-15-2016, 06:56 AM
  5. my phone will not come to the end of "optimizing"
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-15-2016, 06:56 AM
LINK TO POST COPIED TO CLIPBOARD