1. firelightguitarist's Avatar
    ok everyone, i was about to start a thread asking for help to fix this error, but then i found this right here on the android central forums:


    it's for the evo 4g, but it works perfectly. i wish i'd found this a few days ago when this all started, i could've saved several hours of work flashing, reflashing, restoring, returning to stock, and flashing some more.

    so! if you also have this problem, check out the forum post i listed above and enjoy updating your apps!

    Instructions! Just 4 easy steps! (you must be rooted to do it without a computer. for computer instructions, see the link to the evo forum post above)

    1. (if you don't have it already) get the app "adao file manager"

    2. open adao file manager

    3. open "sd card" and navigate to ".android_secure"

    4. delete "smdl2tmp1.asec" (obviously, since i have done it already, my directory is empty)
    johnacc2011 and Titus37 like this.
    02-07-2011 03:52 PM
  2. johnacc2011's Avatar
    I will try this out although why is it that my phone is alright for a few weeks and then acts up like "I'd like to make it a paperweight" I mean HTC EVO 4g, w/2.2 Froyo? What's actually causing this to happen? HTC firmware, Sprint URL update, Droid Marketplace out of sync? I copied the apps asking to be updated back to my phone and the apps updated OK. I have not tried to copy them back to SD card however. I tried downloading a new app and it failed also with a "Installation error, Unknown reason - 18". Thanks.
    02-23-2011 04:57 PM
  3. Titus37's Avatar
    Thanks a lot for that link! I started getting the unknown error -18 last night. My phone has seemed a lot less stable since I accepted the latest OTA update. I have not hacked my phone at all and am running stock everything, but problems like this make me think that potential bugs within the custom ROMs can't be much worse.
    02-24-2011 11:44 AM
  4. VW Maverick's Avatar
    Per that other link, here are the steps:

    Step 1 - Move all apps to internal memory from card
    Step 2 - Delete android_secure file on the SD
    Step 3 - Move all apps back to SD as you please, and everything will update fine.

    Step 1 - Completed
    Step 2 - I am sure I am missing something easy, but where/how can I access my SD card to be able to delete the file?


    02-24-2011 12:36 PM
  5. Titus37's Avatar
    I think you need to hook up your phone to the computer and delete the directory that way.
    02-24-2011 03:33 PM
  6. firelightguitarist's Avatar
    I am sure I am missing something easy, but where/how can I access my SD card to be able to delete the file?
    I prefer Adao File Manager. Just navigate to it with that and delete it. That's what I did.

    BTW, there's absolutely no need to move your apps like that. all you have to do is delete the file. i'll edit my OP with instructions, maybe even screenshots
    02-24-2011 04:18 PM
  7. MaXXimus's Avatar
    And what if that file isn't in the android secure folder? I still get app update errors.

    Swyped from my LS670 using Tapatalk
    02-24-2011 06:49 PM
  8. firelightguitarist's Avatar
    That's a very good question that I can't answer. Hmm. Very sorry :-(
    02-24-2011 07:04 PM
  9. Titus37's Avatar
    I just deleted smdl2tmp1.asec and sure enough, updates are working for me again. WOO HOO!
    02-24-2011 11:59 PM

Tags for this Thread