1. Rush01's Avatar
    Hey guys, I know webview isn't being used on Nougat anymore, but seems that the embbed Chrome's webview is crashing.

    Every app that needs to open a site won't work.
    Ex: if I click on a link in Gmail, it was supposed to open the site inside Gmail. I just get a blank page. After this my Chrome crashes and need to be forced closed.

    I've already tried to clear the cache in fastboot and reinstalled Chrome...
    06-30-2017 07:18 PM
  2. Javier P's Avatar
    Have you already tried switching back to the old Webview app using the Developer options? Just remember to update it from the Play Store.

    https://developer.android.com/about/...0.html#webview

    Chrome's embbed "webview" not working on Nougat-screenshot_20170630-215256.png
    06-30-2017 08:55 PM
  3. Rush01's Avatar
    There is no option... I can't switch to Google Webview
    07-01-2017 12:08 AM
  4. Javier P's Avatar
    Which phone do you have?
    07-01-2017 08:55 AM
  5. ThatGuyLurkin's Avatar
    Do you have Android System WebView downloaded from the Play Store when trying to switch?
    07-01-2017 10:26 AM
  6. Rush01's Avatar
    I can't activate webview... Even when I disable chrome.
    This is what I get in the play store.
    Phone is Moto Z stock ( non rooted)
    07-01-2017 11:15 AM
  7. Javier P's Avatar
    Strange. Try this. Install Chrome Beta, restart the phone and see if you get it in the Developer Options under Webview implementation.

    https://play.google.com/store/apps/d...om.chrome.beta
    07-01-2017 11:35 AM
  8. Javier P's Avatar
    Mod note. I moved your thread to the Moto Z forum where it'll be easier getting feedback from other owners.
    07-01-2017 11:53 AM
  9. Rush01's Avatar
    Hey guys, seems that ticking the box "run webview renders separately" does the trick. Not a single crash since then.
    Javier P likes this.
    07-02-2017 08:07 AM
  10. Javier P's Avatar
    Hey guys, seems that ticking the box "run webview renders separately" does the trick. Not a single crash since then.
    That's very interesting. Thanks for the tip! Obrigado!
    07-02-2017 10:20 AM
  11. Rush01's Avatar
    The blank screens came back... Ticking the box didn't do the job... I'm thinking about a fresh install of Nougat, but it's a pain in the *** to have everything installed again...
    07-06-2017 10:47 AM
  12. Javier P's Avatar
    The blank screens came back... Ticking the box didn't do the job... I'm thinking about a fresh install of Nougat, but it's a pain in the *** to have everything installed again...
    Before that you could try using Chrome Beta as Webview provider and see what happens.
    07-06-2017 10:50 AM

Similar Threads

  1. Replies: 3
    Last Post: 06-30-2017, 07:24 PM
  2. My tablet is Samsung Tablet A6 i can not find the menu button
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2017, 06:42 PM
  3. How much screen on time are you getting?
    By justnivek in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 06-30-2017, 06:31 PM
  4. Services I have turned on keep getting turned off
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2017, 06:03 PM
  5. I cant find the menu button on my tablet
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-30-2017, 04:51 PM
LINK TO POST COPIED TO CLIPBOARD