06-26-2013 10:56 AM
26 12
tools
  1. ips's Avatar
    I was just trying to change the boot animation on my droid using the following code in android terminal
    su
    mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
    cp sdcard/bootanimation.zip /system/media
    reboot

    It replaced the original boot animation but instead of replacing it with the new animation nothing shows up at all besides the Motorola M and then the lock screen. Any idea what I did wrong

    Im using this boot animation version .05
    AllDroid - View topic - [Release] "Red Rage" Boot Animation v0.5 (2/08/10)
    02-10-2010 06:53 PM
  2. Jared DiPane's Avatar
    hmmm. I did something different. I downloaded the boot animation and placed it in the android / tools folder . then in cmd i did

    adb push bootanimation.zip /data/local
    then
    adb reboot
    02-10-2010 06:57 PM
  3. ips's Avatar
    Im not using adb from the sdk because I cant seem to get it to play nice with the terminal on my macbook pro. I dont see why the code I used wouldnt work unless the boot animation.

    EDIT: just rebooted and its using the original boot animation so I at least have that but i still dont know why my code didnt push the new boot to the phone and instead pushed a blank file
    02-10-2010 07:06 PM
  4. Jared DiPane's Avatar
    Ah. what is your issue with Terminal on your mac? I am using a mac as well. maybe I can help if you are interested
    02-10-2010 07:07 PM
  5. ips's Avatar
    it never recognizes adb push commands... ive tried adb-mac and just adb. when I open adb it runs but will not allow me to type and when I just open the terminal the above happens. Im semi new to using the terminal with the droid so I could just be doing something wrong. I put the droid in usb debugging mode beforehand which I assume i was supposed to do.
    02-10-2010 07:13 PM
  6. Jared DiPane's Avatar
    Yes you are supposed to have it in debugging mode to do this.

    Have you downloaded the SDK?
    02-10-2010 07:16 PM
  7. ips's Avatar
    I had it but I deleted it yesterday after getting frustrated with adb not working... I didnt think you could get adb without the sdk.
    02-10-2010 07:17 PM
  8. Jared DiPane's Avatar
    You will need the SDK for it to work. IF you want to download it again, we can try it again, if not, no big deal.
    02-10-2010 07:18 PM
  9. ips's Avatar
    I just re downloaded the sdk. I opened adb and it went through the process and said process complete but I can not type. I tried your command in the terminal and got the reply -bash: adb: command not found. Did the same thing for adb-mac and same results.
    02-10-2010 07:37 PM
  10. Jared DiPane's Avatar
    ok so lets start at the beginning, download the SDK. unzip it, place it on your desktop.

    rename the main file as android.

    place the boot animation in the tools folder.

    then go to where you can highlight the tools folder, right click, go to get info and then copy the "where" line

    then open up terminal with your droid connected to your computer

    paste in the "where" line and press enter

    then try the command listed above.
    02-10-2010 08:12 PM
  11. ips's Avatar
    This was the result of what you suggested
    Last login: Thu Dec 10 21:03:07 on console
    ian-saggeses-macbook-pro:~ iansaggese$ /Users/iansaggese/Desktop/android
    -bash: /Users/iansaggese/Desktop/android: is a directory
    ian-saggeses-macbook-pro:~ iansaggese$ adb push bootanimation.zip /data/local
    -bash: adb: command not found
    ian-saggeses-macbook-pro:~ iansaggese$

    Seems the computer is not recognizing the adb push command.... Ill play around with it more but im still pretty lost

    EDIT: I tried dragging adb into the terminal first from tools and then did the commands above with adb-mac and adb and it still says the commands are not recognized.
    02-10-2010 11:18 PM
  12. woahboi's Avatar
    Ahhh... I can help here . I had big trouble trying to change mine. Took me all week. All the help I got was "do a search" or just adb blah blah blah. So...for me I found it easier to download Droid root helper from the market. Then plug your phone into the CPU.open to view files. Go to the tools folder on your sdcard and go into bootanimation. Remove the old one and replace it with the new one.now unmount and use phone To open droidroot helper and find the mount option with the number 4 and the go to flash boot animation choice then sync and reboot. Works with very little knowlage of anything but drag and drop. Let me know if it was ad easy for you as it was for me.
    02-10-2010 11:47 PM
  13. ips's Avatar
    did you mean droid root manager by any chance I cant find droid root helper
    02-11-2010 12:02 AM
  14. woahboi's Avatar
    No. I don't thinkso. Mine is called Droid root helper. Maybe its not from the market??? Just do a Google search for it.
    02-11-2010 12:53 AM
  15. ips's Avatar
    I found it on google but cant find where to download it. It is definitely not in the market.
    02-11-2010 01:01 AM
  16. ips's Avatar
    Tried installing the apk with astro...it was the only apk I could find and it didnt work so I guess it was a bad file to begin with. Where did you get droid root helper?
    02-11-2010 01:33 AM
  17. woahboi's Avatar
    somewhere on alldroid or droidforums. I'm having a blackout so ill post a link for you tomorrow.
    02-11-2010 01:56 AM
  18. woahboi's Avatar
    How To: Root The Motorola Droid (Update 01.07.10!) | The Unlockr that page has a link called Droid root tools. Use that link and follow those instructions more or less to get busybox and all that good stuff if you already don't. If you do then just follow my directions. I promise it will be super easy once you get the root helper app. No more run around.
    02-11-2010 02:09 AM
  19. ips's Avatar
    Still wont work, it wont let me install the apk with either task managers.
    02-11-2010 08:54 PM
  20. mclarryjr's Avatar
    Droid rooter helper is called droidrootpro (no spaces) in the market and another way maybe you have tried but use root explorer also found in the market. With root explorer just find the apk file on the sdcard and either just hit or long press and choose install that's how I changed mine.
    02-11-2010 09:51 PM
  21. ips's Avatar
    I should be able to instal the apaks with astro like I did wiht the 2.1 app drawer before I rooted, there must be a problem with the file now or something because I dont see why I couldint instal it with any of the file managers in the market. Any ideas on fixing the issues with my terminal based on the code I posted on the first page and the results I got?
    02-11-2010 09:55 PM
  22. mclarryjr's Avatar
    I would use root explorer and make sure you hit Mount R/W before you try to install the apk, I don't think you can install using astro but not positive.
    02-11-2010 10:13 PM
  23. mclarryjr's Avatar
    Ok forget what I just said and use root explorer and long press and select copy on the apk on your sdcard then go to /system/media and paste the apk (you will also have to hit Mount R/W first thing) it should then ask if you want to replace the current boot and just say yes the restart to test.
    02-11-2010 10:17 PM
  24. ips's Avatar
    No matter what I do, the boot animation is replaced with a blank screen.

    EDIT: I dont know if this has anything to do with the problem but when i dl the file it unzips because of the unarchiver but I rezip it using yemuzip.
    02-12-2010 12:01 AM
  25. abdullah122511's Avatar
    i have a problem, i changed boot animation, and now its stuck after the animation. doesnt turn the tab on, what to do to reset or turn it on
    help plz
    06-26-2013 09:31 AM
26 12
LINK TO POST COPIED TO CLIPBOARD