1. lehman44's Avatar
    I ran into an issue yesterday where my X2 received a voicemail. i listened to that thru visual voice mail. When I tried to make a call the phone just hung there and then I got a "unable to connect phone call do you want to retry or cancel. I tried placing several other calls with the same thing. My wife called my phone also a verizon phone and I did not get the call, she received my voice mail. I was able to receive email, twitter, facebook, and get on the browser. I attempted several battery pulls and no luck. I then spoke to verizon and they had me do a bunch of different things, even trying to push an activation. I ended up having to do a factor data reset, I am now stuck with the droid emblem that takes me to activating my phone. When I do this it sits at the activation call and does nothing.

    Has anyone seen or heard of this before? Is there anything else I can do to try and get this back up and running?
    10-07-2011 01:42 PM
  2. jondevere's Avatar
    Call verizon is all I can think of doing. That stinks
    10-07-2011 02:56 PM
  3. lehman44's Avatar
    Unfortunately Verizon is sending me a refurbished x2 now... I have to wait until Tuesday to get it. For now I'm back to an Eris
    10-07-2011 07:09 PM
  4. fargles's Avatar
    that's crazy, a little while ago I was trying to use my moms droid charge and the cell towers were down or something because I couldn't make the call at all. If I remember correctly I could make calls, but I am not 100% sure lol
    good luck!
    10-07-2011 11:22 PM
LINK TO POST COPIED TO CLIPBOARD