1. Dev36's Avatar
    I'm trying to root my Droid X2 which is currently running Gingerbread 2.3.5 but I keep getting an error saying read only filesystem. I have tried removing the sd card and flipping its write protection switch with no luck. Can anyone tell me how to fix this error? I am dual booting with Windows XP and Backtrack 5 so the OS is no issue. Thanks
    04-06-2012 10:07 PM
  2. Devinator's Avatar
    Isn't Backtrack another ROM? Wouldn't you have to be rooted to have done this?
    04-10-2012 09:06 AM
  3. Dev36's Avatar
    No sir, Backtrack is an operating system based on unix for penetration testers.
    04-14-2012 12:35 AM
  4. Dev36's Avatar
    Solved my own problem...
    04-14-2012 12:38 AM
  5. Devinator's Avatar
    Gotcha. How did you solve your problem?
    04-14-2012 01:31 AM
  6. _lobster_'s Avatar
    I am currently trying to root a droidx2 running 2.3.5 and getting the same error message.
    How did you end up solving the problem?
    05-03-2012 12:33 AM
  7. stmasi's Avatar
    Yes. I, too, am stuck with not being able to root my newly-acquired 2.3.5 update. I've tried 6 different tools now and nothing is working. It always comes down to things like "permission denied" or "not enough free space on /system!!!" or "read-only file system" or the like. Nothing seems to work. Has anyone been able to successfully root the 2.3.5 update on an X2? Thanx.
    05-04-2012 08:52 PM