1. tpmbb10's Avatar
    Hi, I received my OP3 on Thursday and I've enjoyed using it. But I noticed really odd behavior in the camera - taking photos upside down and the settings menus being at the bottom of the screen and upside down. Then, I noticed in general that the auto-rotate was really sketchy.

    I dialed 808 and did the Sensor self-test and calibration and the Accelerometer test failed. "Error: Sensor Specific error: 4". I'm guessing this will warrant an exchange or refund.

    Has anyone else had this issue? I couldn't find a lot of information about the error online apart from other forum posts in the past with no real description.
    07-02-2016 11:04 PM
  2. anon(1733)'s Avatar
    Huh. I have not seen that yet. Mine had been fine so far. No issues as of yet with screen rotation. I wonder what the cause is. Did you try clearing the cache while booting into recovery mode. That might do the trick.
    07-02-2016 11:47 PM
  3. tpmbb10's Avatar
    Huh. I have not seen that yet. Mine had been fine so far. No issues as of yet with screen rotation. I wonder what the cause is. Did you try clearing the cache while booting into recovery mode. That might do the trick.
    Yes, I cleared the cache and all that. I also did a factory data reset. It seems really odd that the camera menus are upside down the first time I open the camera app after resetting.
    Auto-Rotate not working-1467547865320.jpg
    07-03-2016 08:11 AM
  4. anon(1733)'s Avatar
    Yeah that's weird. Last thing I can think of would of be to try a update and see if that fixes the issue. Either that or a exchange. Not sure what software version your on but 3.1.3 is floating around if you don't have it.
    07-03-2016 09:11 AM
  5. fuzzylumpkin's Avatar
    I doubt you'll find anything online, this is more likely a "sometimes electronic components are faulty" issue than a OnePlus 3 issue. Just get in contact with them and get it replaced,. It's really your only option besides living with it.

    Posted via the Android Central App
    07-03-2016 09:17 AM
  6. tpmbb10's Avatar
    Looks like I'm on 3.1.3 as well. On my 3rd attempt with OP3 support they at least created a ticket for me. I have to say they haven't instilled me with much confidence with their lack of any attempt to troubleshoot beyond resetting but I'll go through the process with them when they email me back. The accelerometer test looks like a smoking gun. If you have a few moments of free time would you mind running the accelerometer test from the *#808# menu and confirm you receive a pass?
    07-03-2016 09:22 AM
  7. tpmbb10's Avatar
    Cheers. Sounds like the best plan. Appreciate the feedback.
    07-03-2016 09:23 AM
  8. fuzzylumpkin's Avatar
    I'd like to help you out, but it seems these codes don't work in my non stock dialer, and it looks like I forgot to back the stock one up with titanium, whoops!

    Posted via the Android Central App
    07-03-2016 12:19 PM
  9. tpmbb10's Avatar
    I'd like to help you out, but it seems these codes don't work in my non stock dialer, and it looks like I forgot to back the stock one up with titanium, whoops!

    Posted via the Android Central App
    LOL no worries!
    07-03-2016 02:31 PM

Similar Threads

  1. Turbo's mobile data does not work
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-03-2016, 01:24 PM
  2. My headphone jack stopped working, how do I fix it
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-03-2016, 07:33 AM
  3. POP3/IMAP not connected to server
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-02-2016, 10:52 PM
  4. Why is my Galaxy tab2 4.2.2 not connecting to my pc?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-02-2016, 10:44 PM
  5. Replies: 0
    Last Post: 07-02-2016, 10:12 PM
LINK TO POST COPIED TO CLIPBOARD