01-14-2013 03:16 PM
1,049 ... 3132333435 ...
tools
  1. anthonycr's Avatar
    [ROM][WIP]CM9.1.0-BobZ-uploadfromtaptalk1347410512936.jpg

    This is amazing... over 13 hours of battery life and the screen has been on almost 4 hours (I was on tapatalk and reading news articles). I'm amazed.
    09-11-2012 08:42 PM
  2. rcmarotz's Avatar
    I'm also having white screen problems. Gmail, default browser, Google reader, dolphin browser mini. I'm willing to run experiments to help track down the solution.

    Another thing that I noticed about the white screen is that the text is still there. In Gmail with the white screen I was able to select all the text and copy it into a notepad type program and read the text. Hope this helps.
    09-12-2012 12:10 AM
  3. Rudeco's Avatar
    I'm also having white screen problems. Gmail, default browser, Google reader, dolphin browser mini. I'm willing to run experiments to help track down the solution.

    Another thing that I noticed about the white screen is that the text is still there. In Gmail with the white screen I was able to select all the text and copy it into a notepad type program and read the text. Hope this helps.
    Pleaseeee. The white screen is my onlyyy gripe.
    09-12-2012 12:31 AM
  4. Harue25's Avatar
    Weird,

    I re-flashed again everything installs great. Only thing is I can charge now thru usb to computer but not directly to the wall? Anybody else have any ides of the issue I am having. Honestly I just now for fact my wall charger is working and the outlet is ok.

    I just re-flashedCM10 JB rom and same thing is happening. I cant charge thru the wall, only thru usb from comp.

    Anyway not complaining just curious.
    I'm having this same issue, has anyone found a resolution to this yet? my GB rom lets me charge from the wall just fine so I know it's not my wall charger.
    09-12-2012 09:03 AM
  5. ThatGuyLurkin's Avatar
    Click image for larger version. 

Name:	uploadfromtaptalk1347410512936.jpg 
Views:	314 
Size:	22.4 KB 
ID:	37174

    This is amazing... over 13 hours of battery life and the screen has been on almost 4 hours (I was on tapatalk and reading news articles). I'm amazed.
    Good to see I'm not the only one with bad battery readings. :thumbup:

    Sent from my LG-VM670 using Tapatalk 2
    09-12-2012 11:23 AM
  6. rcmarotz's Avatar
    About the white screen. I've also messed around with the "Force GPU rendering" with no luck. One thing I found *extremely* interesting is when I played with the "Show screen updates" feature. The idea of this feature is to flash the portion of screen that gets updated. For example when you open an application, the whole screen flashes, when a notification shows up in the top bar, only the top bar flashes.

    Ok, so when I use Gmail (one app that always shows a white screen for me in the body of the email, not the header information) the whole screen flashes as expected as the Gmail app opens. Then I choose an email to read, once again the screen flashes as the email gets displayed. The body of the email also gets displayed temporarily for about a second. During this second after the email appears and the app is done paining itself, there is no "Show screen updates" flashing going on as expected. After the second, the "white screen" problem appears and the body text of the email vanishes. At this point the "Show screen updates" flashing goes berzerk and the whole screen flashes.

    So what did I learn, My guess is that the white screen problem is happening because something is painting/updating/refreshing the screen constantly when it should not. I don't have time to delve into the code but should have some time in three weeks. If this isn't fixed by then, I'll pursue this further.
    09-12-2012 11:59 AM
  7. rcmarotz's Avatar
    About the white screen. I've also messed around with the "Force GPU rendering" with no luck. One thing I found *extremely* interesting is when I played with the "Show screen updates" feature. The idea of this feature is to flash the portion of screen that gets updated. For example when you open an application, the whole screen flashes, when a notification shows up in the top bar, only the top bar flashes.

    Ok, so when I use Gmail (one app that always shows a white screen for me in the body of the email, not the header information) the whole screen flashes as expected as the Gmail app opens. Then I choose an email to read, once again the screen flashes as the email gets displayed. The body of the email also gets displayed temporarily for about a second. During this second after the email appears and the app is done paining itself, there is no "Show screen updates" flashing going on as expected. After the second, the "white screen" problem appears and the body text of the email vanishes. At this point the "Show screen updates" flashing goes berzerk and the whole screen flashes.

    So what did I learn, My guess is that the white screen problem is happening because something is painting/updating/refreshing the screen constantly when it should not. I don't have time to delve into the code but should have some time in three weeks. If this isn't fixed by then, I'll pursue this further.
    Small update. I also played with "Show CPU usage". When I'm in the Gmail app looking at the email list, there is no "white screen" problem. The top cpu process (and using very little by what I can tell) is ami304d. The next highest process varies, but like I said before, these are using very little cpu. See attached pic:
    [ROM][WIP]CM9.1.0-BobZ-ss_ws_0.png

    Now for the interesting part, when I open an email and the body text disappears ("white screen" problem), the cpu usage goes way up. The top on the list is com.google.android.gm, then surfaceflinger, then ami304d. The com.google.android.gm process uses *a lot* of cpu. surfaceflinger uses more than what I'd consider normal given I should be looking at a static screen of the email now. See attached pic:
    [ROM][WIP]CM9.1.0-BobZ-ss_ws_1.png

    So I'm beginning to think that the problem lies in com.google.android.gm or surfaceflinger where for some reason they're causing the screen to rapidly refresh/repaint resulting in the "white screen" problem.
    Badboytoast likes this.
    09-12-2012 12:29 PM
  8. sellers86's Avatar
    Small update. I also played with "Show CPU usage". When I'm in the Gmail app looking at the email list, there is no "white screen" problem. The top cpu process (and using very little by what I can tell) is ami304d. The next highest process varies, but like I said before, these are using very little cpu. See attached pic:
    Click image for larger version. 

Name:	ss_ws_0.png 
Views:	157 
Size:	16.4 KB 
ID:	37222

    Now for the interesting part, when I open an email and the body text disappears ("white screen" problem), the cpu usage goes way up. The top on the list is com.google.android.gm, then surfaceflinger, then ami304d. The com.google.android.gm process uses *a lot* of cpu. surfaceflinger uses more than what I'd consider normal given I should be looking at a static screen of the email now. See attached pic:
    Click image for larger version. 

Name:	ss_ws_1.png 
Views:	283 
Size:	15.3 KB 
ID:	37223

    So I'm beginning to think that the problem lies in com.google.android.gm or surfaceflinger where for some reason they're causing the screen to rapidly refresh/repaint resulting in the "white screen" problem.
    If I remember right they used surfaceflinger files to fix color banding.. could be something related. Your on to something here

    Sent from my One V using Android Central Forums
    09-12-2012 03:43 PM
  9. Psn1's Avatar
    I'm having this same issue, has anyone found a resolution to this yet? my GB rom lets me charge from the wall just fine so I know it's not my wall charger.
    I guess we are the only ones. I re-flashed couple of ICS roms and none of them are capable of charging thru the wall. They charge thru USB to computer only. Strange since I tried 4 different ICS roms and all of them have this issue. I gave up and I am back at IHO Backside and charges fine.
    09-12-2012 04:31 PM
  10. Conrail16's Avatar
    I guess we are the only ones. I re-flashed couple of ICS roms and none of them are capable of charging thru the wall. They charge thru USB to computer only. Strange since I tried 4 different ICS roms and all of them have this issue. I gave up and I am back at IHO Backside and charges fine.
    This issue dates back to the Optimus S GB update (which our ICS kernel is desended from). No one in all this time has been able to identify what causes it, primarily beacuse it's been impossible to replicate on most phones.
    09-12-2012 05:53 PM
  11. ThatGuyLurkin's Avatar
    The S had a no charging issue?

    I only remember the Phone saying Charging(##%) when it wasn't even charging :P.


    Or was it both?

    Sent from my LG-VM670 using Tapatalk 2
    09-12-2012 05:57 PM
  12. Psn1's Avatar
    I was trying different options to even fix permissions that some recommended. I doubt ZV update has to do anything with it? Will see just like to play around with it and maybe find the glich!

    Thanks all!
    09-12-2012 06:07 PM
  13. jonny5449's Avatar
    The S had a no charging issue?

    I only remember the Phone saying Charging(##%) when it wasn't even charging :P.


    Or was it both?

    Sent from my LG-VM670 using Tapatalk 2
    No zvh had no charging my friend noticed this

    Oh well time to figure out how to root Droid x for a friend

    Did cyanogenmod stop working on cm9

    Sent from my LG-LS670 using Tapatalk 2
    09-12-2012 06:58 PM
  14. norosesnoskiesx's Avatar
    super noob question.

    under; settings->lock screen-->weather. how do you change from celsius to fahrenheit?
    09-12-2012 08:58 PM
  15. BlairFam07's Avatar
    super noob question.

    under; settings->lock screen-->weather. how do you change from celsius to fahrenheit?
    Un-check the metric box
    norosesnoskiesx likes this.
    09-12-2012 09:20 PM
  16. redrunner1985's Avatar
    I guess we are the only ones. I re-flashed couple of ICS roms and none of them are capable of charging thru the wall. They charge thru USB to computer only. Strange since I tried 4 different ICS roms and all of them have this issue. I gave up and I am back at IHO Backside and charges fine.
    not sure what ur issue is, but I have been able to charge using the wall on all ics and jb roms

    Sent from my LG-VM670 using Android Central Forums
    09-12-2012 09:36 PM
  17. flapjack.fiasco's Avatar
    This issue occurred fairly early in the first ICS builds, but only one or two people were affected. I remember it only seemed to affect one guy at first, then later, another. It seems like there's been maybe 4 people who've reported it since then.
    I wonder if maybe there's some small hardware change in a small number of phones that's causing it.

    Sent from my LG-VM670 using Tapatalk 2
    09-12-2012 10:11 PM
  18. nerdmastax's Avatar
    both my plastic screen v and glass screen one charge via all cables i have (lg wall charger, usb, usb in car) on this rom and cm10 and mirage cm7... cant speak for any others though.
    billabong71 likes this.
    09-12-2012 11:28 PM
  19. Psn1's Avatar
    Thanks guys Just been testing all other options as well myself!
    09-12-2012 11:55 PM
  20. anthonycr's Avatar
    both my plastic screen v and glass screen one charge via all cables i have (lg wall charger, usb, usb in car) on this rom and cm10 and mirage cm7... cant speak for any others though.
    Where'd you get an OV with a glass screen...
    snobro likes this.
    09-13-2012 08:19 AM
  21. rcmarotz's Avatar
    I tried FoxFi, but it outright failed. Maybe I'll buy Bobzhome a beer or three to move wifi tethering up the Todo list.
    Until I can get WiFi tethering to work, I have been successful at using PDAnet on my tablet and FoxFi on the phone to Bluetooth tether.
    A-android-B likes this.
    09-13-2012 10:25 AM
  22. flapjack.fiasco's Avatar
    Where'd you get an OV with a glass screen...
    I imagine that he's talking about old vs new screen. But didn't the Optimus One have a glass screen? They're similar phones right? Maybe he did a screen swap?
    Sent from my LG-VM670 using Tapatalk 2
    09-13-2012 10:26 AM
  23. nerdmastax's Avatar
    no the older optimus v has the plastic screen, the new one has a glass screen. and a zv5 baseband that dosent like to work well with cm 9 & 10. my old v can rum cm 9&10 no problems and no rebooting. but cm7.2 works fine on both phones. I dont use the older one because the internet sucks compared to the new one.
    09-13-2012 10:32 AM
  24. anthonycr's Avatar
    no the older optimus v has the plastic screen, the new one has a glass screen. and a zv5 baseband that dosent like to work well with cm 9 & 10. my old v can rum cm 9&10 no problems and no rebooting. but cm7.2 works fine on both phones. I dont use the older one because the internet sucks compared to the new one.
    Dang I have an old v. I'd rather have one with a glass screen
    09-13-2012 11:27 AM
  25. flapjack.fiasco's Avatar
    That's right, I think I remember LeslieAnn talking about the new one having glass. My memory needs a hand occasionally.

    Sent from my LG-VM670 using Tapatalk 2
    Psn1 likes this.
    09-13-2012 11:29 AM
1,049 ... 3132333435 ...

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD