07-17-2015 11:04 AM
75 123
tools
  1. scottp51's Avatar
    OK, at this point I'm pretty sure it isn't me. I've done multiple clean installs, repeated pasting in the binary file in case I screwed that up, every variable I could think of was tracked and checked. Was I supposed to copy the "update-binary" file into all of the Toucan files, or just Wipecache.zip? In any case, after repeated failures to install, I made a modded copy of each file and tried those too. When I tried the alternate file you so kindly provided, it said:

    Finding update package...
    Opening update package...
    Installing update...
    E:Error in /sdcard/Toucanscrypt-1.1alternate.zip
    (Status 0)
    Installation aborted.

    When I tried the alternate file that I pasted the binary into, and pretty much every other file I tried, it just said:

    Installing update...
    Installation aborted.

    It is not outside the realm of reality that I screwed this up somehow, but I have no idea where my error would be. Do you have any other suggestions?

    (I'm waiting until I see how this works on my spare phone before I try it on the one I actually use daily. But I appreciate the effort and thinking behind this whole thing, so I will do it eventually. I may also be able to get my hands on a rooted Optimus F3, so I can provide another test bed for you. I apologize I can't contribute knowledge, but I can certainly follow instructions (don't tell my GF I said that, she may disagree)).
    06-25-2015 07:19 PM
  2. Toucan4267's Avatar
    try just the modified Toucanscrypt alternate, not the wipecatch or others as they may need some editing to work as well.
    Sorry you missed this from my previous post. If you flashed anything else, that's probably why it's messed up. I'll need to create a version of each to work with your specific setup, but I need to know whether the alternate Toucanscrypt itself works before I waste time rewriting all the others if it still needs some tweaking.
    06-25-2015 07:45 PM
  3. Toucan4267's Avatar
    What you need to do is binary swap into the Toucanscrypt alternate, then run just that (make sure if you're using bigsupersquid's recovery, that it's set to internal rather than os2sd). I'll try the alternate on my phone to see if anything else may be messed up, and then reflash the original so I don't Bjork up my phone :-). Will let you know how that turns out.
    06-25-2015 07:53 PM
  4. scottp51's Avatar
    Nope, I caught that. At least the error message for that one had some information, although I have no idea if it means anything to you. The rest of them just didn't work. I'll try it again, and I will only use your unaltered-by-me alternate file - what I'm doing is, when I reach the spot in the instructions (this site won't let me post a link yet, but the androidcentral page I'm using is titled "[ROM][MOD][THEME] Bean_Whiz-CM10 Updated 05/02/2014") where he says to install wipecache.zip, I use your alternate file instead. I didn't try anything else in my previous runs until I had used your alternate file that I had downloaded. I'll do another clean install now and I'll report back.

    EDIT: Just saw your other message. I'm using the flashable CWMTRecovery_5.0.2.7-th7_thunderc from that thread. I'll re-download your alternate and re-paste in the binary.
    06-25-2015 08:00 PM
  5. scottp51's Avatar
    No dice. It just says:

    Finding update package...
    Opening update package...
    Installing update...
    Installation aborted.

    This was a fresh install, and I used the recovery to try to flash the modded (with the binary file) alternate file you provided in post 48.
    06-25-2015 09:20 PM
  6. Toucan4267's Avatar
    Just downloaded and flashed it myself and it worked without a hitch, so file's fine. That says the issue is in a incompatibility, or file corruption between download and flash. Either way, update-binary should be the answer, as swapping should fix incompatibility and it's the only step where the file might have gotten messed up. I've also be reading about the error 0 and it can be caused be recovery settings as well. You might flashing with Signature Verification off, and with /system and or /data mounted or unmounted as this fixed things for some I read about. Without having the same setup you do, I'm kinda stuck troubleshooting without being able to test for myself.
    06-26-2015 01:11 PM
  7. scottp51's Avatar
    Should I be pasting the "Updater-script" too?
    06-26-2015 01:28 PM
  8. Toucan4267's Avatar
    Good question. Since that hasn't fixed things yet, and I never read about AndyOpie ever doing so, you can probably do without. I would double check that signature verification is off, and that system and data are unmounted, then try flashing without swapping binaries. If that doesn't work, swap binaries, rinse, repeat.
    06-26-2015 01:37 PM
  9. Toucan4267's Avatar
    Don't worry about reflashing your rom in between steps, just keep recovery open.
    06-26-2015 01:38 PM
  10. scottp51's Avatar
    Aah, didn't realize I didn't have to keep reflashing. I already lost an sd card that I had repurposed from my SanDisk player on Wed. Was probably a decade old anyway.

    Now that I know I can carefully play around inside the recovery, I discovered a log file. When I viewed the log file, it said:

    0 /tmp ramdisk (null) (null)
    1 /boot mtd boot (null)
    2 /cache yaffs2 cache (null)
    3 /data yaffs2 userdata (null)
    4 /misc mtd misc (null)
    5 /recovery mtd recovery (null)
    6 /sdcard vfat /dev/block/mmcblk0p1 /dev/block/mmcblk0
    7 /sd-ext auto /dev/block/mmcblk0p2 (null)
    8 /system yaffs2system (null)

    Since you said that "The script works right when they're in this order: mydblock0 boot, 1 cache, 2 recovery, 5 userdata, 6 system," it looks to me like all of my settings are different than your directions...
    06-26-2015 02:38 PM
  11. scottp51's Avatar
    I just downloaded "Storage Partitions" again, and it says:

    mtdblock0
    boot | xx | Not mounted

    mtdblock1
    cache | yaffs2 | /cache

    mtdblock2
    recovery | xx | Not mounted

    mtdblock3
    splash | xx | Not Mounted

    mtdblock4
    FOTA_STO | xx | Not Mounted

    mtdblock5
    system | yaffs2 | /system

    mtdblock6
    userdata | yaffs2 | /data

    mtdblock7
    misc | xx | Not Mounted

    mtdblock8
    persist | xx | Not Mounted
    06-26-2015 02:58 PM
  12. scottp51's Avatar
    Oops, forgot to mention that I tried your suggestions but they didn't work. That's why I started exploring.
    Signature Verification - it was off, but I turned it on and, when that install didn't work, I turned it off again and the install still didn't work. Tried it with the stock and modded alternate file. I also tried "toggle script asserts." Didn't work either way. Both system and data were unmounted. I mounted data, didn't work with either file. Then I also mounted system, so both were mounted. Neither file worked. Then I unmounted data, so only system was mounted - no joy with either. Then I unmounted system, so neither were mounted (the way I started), and tried again in case the mounting/unmounting shook something free but was still unsuccessful. As far as I can tell, I've tried every permutation of what you suggested.

    If the data about the partitions isn't useful, please let me know and I'll drop trying to make this work on the Bean Whiz. I hope there are no hard feelings, and that I didn't screw something up that put you to unnecessary trouble!

    However, in the process of monkeying around with two phone ROMs simultaneously while knowing nothing about what I'm doing I have botched something in my daily driver (the Mirage ROM), so I have to reinstall it again. Since I no longer have anything to lose, and the failures to install didn't do anything horrible to my Bean Whiz phone, I'm going to try that next (once Bean Whiz is off the table). I was hoping that I could install the Bean Whiz to my daily phone, which is why I've been testing it, but my workaround of downloading the apk, moving it to the phone with no space and installing it from the sd card didn't work as I'd hoped, so I really want your program to work!

    Please let me know if there is anything I can do to help. Thanks for all your effort on this idea!
    06-26-2015 04:50 PM
  13. Toucan4267's Avatar
    Sorry about all the difficulty on your end too! Man, what is up with this? Wish I had another idea of what to do. I'll still keep monkeying with it (I enjoy it =) ), and see if I can come up with anything, although I'll be outta cell service till tomorrow evening, so I won't get much chance till then.
    06-26-2015 06:19 PM
  14. Toucan4267's Avatar
    Should I be pasting the "Updater-script" too?
    Hey, just realized you said script, not binary. The binary should be the only thing to swap. The script says what needs to be installed, and so if that's switched it would really mess things up, so no don't swap the updater-script.
    06-26-2015 06:21 PM
  15. Toucan4267's Avatar
    Hey, one more thought. I know at one point, before AndyOpie added parts of my script to his rom, he had to install my script to beanwhiz the same way that everyone else does, following the basic instructions on the first couple posts in the thread here. I suppose you could try that.
    06-26-2015 06:24 PM
  16. scottp51's Avatar
    I tried both ways, since your instructions and his dovetailed as to the appropriate time during the process for the install. He just says use wipecache.zip, while yours say to use the Toucanscrypt 1.1.zip. Unfortunately, neither the as-downloaded or the modded w/the binary swap versions worked, for either file. Is it possible that you were using a different wipecache.zip file at the time he wrote those instructions? If so, and you can provide it to me, I can see if it works and it might be another clue as to what's going on...

    Man, I wish we had some mountains here. The only "mountain" around me (it has "mountain" in the name) would probably be described by you as a big hill.
    06-26-2015 07:24 PM
  17. scottp51's Avatar
    I didn't quite understand what a Nandroid backup was, but now that I do I was able to try ToucanScrypt on a fresh copy of the Mirage ROM on my spare VM670. All of the following was tried on this fresh Mirage install copy.

    I tried both the 1.1 and the 1.1 alternate zip files, but unfortunately the result was the same.

    So I went and did the binary mod to both 1.1 and 1.1alternate, but it didn't work.

    I saw a line in the recovery titled "Fix Permissions," so I hit it, waited for it to do its stuff, and tried again with all four files. No change.

    I have no idea what Busybox is or does, but I've seen it referenced many times while I'm trying to get up to speed with Android, so I went and installed the newest version from the Play Store, and then tried again with all four files. Still didn't work.

    I guess the problem must be incompatibility with the Optimus V, rather than the ROM in use?
    06-27-2015 09:50 PM
  18. Toucan4267's Avatar
    I guess the problem must be incompatibility with the Optimus V, rather than the ROM in use?
    No, cuz multiple people (myself and AndyOpie included) have gotten it to work on the Optimus S/V with multiple different roms. There's something really strange going on here. I did read this link which may be informative. Basically, it may be the recovery that is the issue. Which recovery are you using? Is it the one AndyOpie recommended or the one I recommend in my script?
    06-28-2015 12:49 AM
  19. scottp51's Avatar
    I was using the recovery Andy recommended, Flashable CWMTRecovery_5.0.2.7-th7_thunderc. I also tried ZenGarden-Touch-Recovery without success.

    At this point, I had my Mirage ROM flashed. I installed TWRP2.8.0.0_multi_thunderc and tried to install the modded 1.1, and it still didn't work, but this time the error message said "E:Unable to mount '/data'. Then I switched the recovery to "Internal" mode (via the "Advanced" menu-Oops!). The modded 1.1 still failed, but this time it said:

    E:Unable to mount '/data'
    Full SELinux support is present.
    MTP Enabled
    Updating partition details...
    Installing '/sdcard/ModAlt Toucanscrypt-1.1alternate.zip...
    [something about an MD5 check, skipped]
    Error flashing zip '/sdcard/ModAlt Toucanscrypt-1.1alternate.zip...
    Updating partition detail...

    Then I tried installing the unmodified Toucanscrypt-1.1alternate.zip that you made for me and...

    SUCCESS!

    I haven't tinkered with it yet, but with the TWRP2.8.0.0_multi_thunderc recovery I was able to:

    Install your alternate main script from my Mirage ROM.
    Install unmodified wipecache for the Bean Whiz ROM as Andy instructed.

    Thank you so much for your troubleshooting help! I can't wait to set up the full Toucanscrypt on my Mirage!
    06-28-2015 01:04 PM
  20. scottp51's Avatar
    To be clear, an important note for people using the TWRP 2.8.0.0_multi_thunderc recovery on a ROM different than the [ROM+Kernel][CM-11.0][4.4.4][OS2SD/internal][f2fs]bigsuperROM-thunderc-4.4.4 (meaning ROMs without the unique multiple partition setup he uses):

    When you load the TWRP recovery You MUST FIRST go to the "Advanced" menu and select "Internal Mode" to change it from the OS2SD mode to which it defaults. You must do this EVERY TIME! For example, if you want to make a nandroid backup using this TWRP and you don't switch it first, you will get an error message and a failed backup.

    Other than that, the UI for this recovery is the nicest of the three I've used.
    06-28-2015 01:17 PM
  21. Toucan4267's Avatar
    🙌 Woohoo! So glad you got it working! So I now know that, apparently, the recovery used makes a large difference. I'll have to take note of that somewhere. Let me know how app installation works. Some notes that I mention in the thread, but thought I'd say again: Link2sd unlocks the full power of this script. Use some app to monitor internal partition sizes and keep most apps linked. Apps I keep internal: Swype keyboard, maps (linked data and cache only), avast security, Google voice, widgets I use, link2sd itself (obviously), tasker, Greenify, clock, voice search/wrapper (for Google now functionality via the physical search button), and hangouts dialer. Basically, if it's a widget out phone app, runs constantly, or loads slow because of needing to read a lot of data, I run it off internal as long as space permits. Also, it's sometimes beneficial to change large system apps to user apps so they can be linked. Gapps is sometimes a tight fit. The unlimited installer helps there (although I'll need to write an alternate, so don't flash that yet). After I get that written, you can flash that, reboot rom, re-enter recovery, flash gapps, convert any system apps to user, link apps, then flash the unlimited uninstaller to go back to a more balanced internal vs. external proportion (or just keep it installed--just expect a slight speed loss and reduced sd life, but unlimited app installs).
    06-28-2015 04:23 PM
  22. scottp51's Avatar
    Well, I installed it today on a clean Mirage install for my main phone, and everything went fine but I have a few more questions:

    1. Was I supposed to run "Wipecache" at some point? The only time I saw it mentioned in the directions is when you said to not use the option in the recovery. However, the time when I think I'm supposed to wipe stuff is before I install the ROM, right? Should I have used wipecache before I installed Toucanscrypt-1.1alternate? After?

    2. How can I tell if it's working again? The Link2SD (I bought the pro version per your suggestion) storage sections now are: Internal, SD Card, SD Card 2nd Part., System and Cache. I guess I should have made a note of the sections prior to install, but I didn't and I'm not familiar enough yet with Android to know if I have the extra section(?) that your script made?

    3. Is the part about "Do not use Link2SD to move any libs or dalvik to sd; APPS ONLY" in effect for me now? Or is this warning for the time when I use the Unlimited Installer (after you mod a version, right?)?

    Thanks again for all your hard work!
    06-29-2015 07:14 PM
  23. Toucan4267's Avatar
    Sorry for the LONG time between replying, Scott! Life get's busy!

    1. No, unless otherwise specified. The initial install wipes cache naturally, but if anything you read requires you to wipe cache or dalvik, MAKE SURE you use the wipecache script rather than the recovery command as the recovery command would now wipe system data contained on the cache partition.
    2. The easiest way to tell that it works is installing a bunch of apps =). I also have a log file that it creates in /data/local titled "linknlog" =). Paste me the contents and I'll double check that all's working fine for ya.
    3. It is for always. My script links the ENTIRE folders containing dalvik and libs, so linking them through Link2SD would only require android to look for the files first internally, follow my link to external, where there would be another link to another external location. Probably wouldn't hurt anything, but you'd get no space savings and would incure a small, perhaps large performance hit.

    You're welcome! I don't have any donate methods open, but might someday, so the biggest thanks I could receive is you passing the word! ...but don't forget to hit like or thanks on any posts that were helpful in the forum. Keep me posted!
    07-04-2015 01:02 AM
  24. troyguitarman's Avatar
    ya it says this rom has the wifi hotspot working but goo is done PAC_JB_4.2.2-v22.0.1_20130414-042136 no one is hosting the file. Does cyanogenmod.org support the optimus v or s?
    07-13-2015 05:21 PM
  25. bigsupersquid's Avatar
    ya it says this rom has the wifi hotspot working but goo is done PAC_JB_4.2.2-v22.0.1_20130414-042136 no one is hosting the file. Does cyanogenmod.org support the optimus v or s?
    cm7 works with superior irken organs repo last i heard. zero cm support past gingerbread. Androidarmv6 abandoned, kitKat repo not working. their JB branch may still be good.
    also per earlier info request:
    /tmp/recovery.log has more data than shows in the recovery screen output.
    sorry not to have replied about that sooner, but I'm usually on my v instead of PC, and cyanogen browser crashes constantly attempting replies since Android Central "upgraded" their mobile site.
    installing the armv6 mod Crossbreeder I posted in the kitKat thread fixed those crashes though.
    07-17-2015 11:04 AM
75 123

Similar Threads

  1. Replies: 2
    Last Post: 05-01-2014, 11:19 AM
  2. Replies: 3
    Last Post: 04-04-2014, 01:39 PM
  3. Replies: 1
    Last Post: 04-01-2014, 12:52 PM
  4. Sync apps with Facebook
    By kanesmith41 in forum Sprint Galaxy Note 2
    Replies: 1
    Last Post: 03-31-2014, 10:26 PM
  5. [VIDEO] AT&T Note 3 w/ KitKat Update - Antutu Benchmark and AC Display
    By chrisngrod in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 03-31-2014, 08:47 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD