06-23-2019 12:29 PM
64 123
tools
  1. sdsubball23's Avatar
    I prefer the USB stick, you can install software that isn't included in the distro, like fastboot and adb, from the command line easily.

    But to your question... when you boot into Hboot, you are starting fastboot, correct? You highlight Fastboot with the volume key, press Power to select it, then in reversed red letters it should say FASTBOOT USB about a quarter of the way down from the top of the screen, then you can issue fastboot commands. Try `fastboot devices` to see if the device is recognized.

    Note that in Linux, you may need to preface the command with sudo, so it would look like `sudo fastboot devices`
    I may try the usb way, but I simply hit the try Ubuntu button when I loaded up the DVD after starting the pc.

    I tried the fastboot command after I went into the fastboot usb mode.

    I'll try the fastboot devices later and report back. Thanks.

    I'm thinking the phone isn't being recognized by Ubuntu after I booted into the hboot and fastboot screens.
    05-02-2016 07:16 PM
  2. acejavelin's Avatar
    I may try the usb way, but I simply hit the try Ubuntu button when I loaded up the DVD after starting the pc.

    I tried the fastboot command after I went into the fastboot usb mode.

    I'll try the fastboot devices later and report back. Thanks.

    I'm thinking the phone isn't being recognized by Ubuntu after I booted into the hboot and fastboot screens.
    There is nothing special you need to do to get Ubuntu, or any other Linux distro, to recognize an Android device. Try a different cable... and make sure you are connected to a USB 2.0 port and not a 3.0/3.1 port, or any other standard troubleshooting technique. It could be a bad phone, but that would be a very rare case.
    05-03-2016 09:16 PM
  3. sdsubball23's Avatar
    There is nothing special you need to do to get Ubuntu, or any other Linux distro, to recognize an Android device. Try a different cable... and make sure you are connected to a USB 2.0 port and not a 3.0/3.1 port, or any other standard troubleshooting technique. It could be a bad phone, but that would be a very rare case.
    If the cable is the issue, how come I'm able to access the phones internal storage on both my computers? I think my computers aren't recognizing the htc rezound drivers for some reason as it shows an exclamation mark symbol on the driver when viewing the device manager.
    05-04-2016 02:02 AM
  4. Hank Johnson9393's Avatar
    Hey Guys, don't know if you've fixed it, but I was stuck on the same issue. Haven't read the whole thread because I've found out on my own. I thought it was my USB Port on my computer but it turned out it wasn't.

    As for the ones that use ubuntu, here's the solution. Instead of just typing :~/Downloads/fastboot$ ./fastboot-linux flash boot boot.img
    < waiting for device >

    TYPE: sudo ./fastboot-linux flash boot boot.img
    06-23-2016 05:05 AM
  5. ajb_htc's Avatar
    Hi,

    I have the waiting for device issue. I had used the link to an older TWRP in a guide to flashing. Once I downloaded and flashed the latest version of TWRP from the TRWP site I was able to then apply the ROM.

    Thanks
    07-18-2016 03:16 AM
  6. Letlhogonolo Fanampe's Avatar
    I've been messing with this for the last several hours. KreemN, your suggestions at least allowed me to move forward a little. While in recovery, the adb reboot-boatloader command rebooted the phone into the bootloader. But, the Fastboot devices command still doesn't do anything. Nor do any of the fastboot commands: they only yield the report, Waiting for Device.

    Any more ideas? So frustrating. I do appreciate the suggestion you made.
    I'm also stuck here, any solutions yet?
    09-18-2016 02:56 PM
  7. insearching's Avatar
    You made a typo in word devices.
    11-03-2016 05:18 AM
  8. xhellobitx's Avatar
    i have the issue, i use win 10, have all the drivers installed
    the problem come out when i succsess get in into fastboot mode (csc mode) by using the command adb reboot bootloader

    after in csc mode i type fastboot flah recovery twrp.img
    and that us the problem come out
    <waiting for any device>

    i already trying to restart my pc, change usb port but still have the same problem.

    my devices is zenfone max zc550kl, hoping someone helped me out. thanks
    11-04-2016 05:56 AM
  9. cody simmons2's Avatar
    I figured it out the bootloader for the lg smartphone is outdated to today's latest is ports on the computers it needs a 2.0 port computers today are made with a 3.0 port. 😕
    11-06-2016 04:33 PM
  10. Deneasta's Avatar
    I did the following and it sorted the issue. Install all the regular stuff that you need to run adb and fastboot.
    1. adb reboot-bootloader : This will boot our device into boot loader.
    2. fastboot devices: Now you can see the devices.
    3. fastboot oem get_identifier_token : to get your token and use the instructions as in htcdev website.
    4. fastboot flash unlocktoken Unlock_code.bin

    This should unlock the phone. Worked for HT One X
    vvbogdanc likes this.
    01-28-2017 08:59 AM
  11. carltasmania's Avatar
    Be warned - there is no such thing as fastboot mode for most Samsung Galaxy devices - you'll be wasting your time doing this and typing "fastboot devices" for many hours!
    If you have problems with your recovery, it works to just reflash the CF-autoroot kit, which happens to flash the cache partition too. My problem was a bootloop with TWRP's obviously buggy OpenRecoveryScript, which was installing a ZIP file over and over again.
    01-30-2017 03:31 PM
  12. Deli Seli's Avatar
    I solved the problem

    1) Open device manager in windows

    2) Connect usb cable to your phone pushing volume up button(for xperia sola)

    3) Device manager will show you fastboot device for 2-3 sec (before the phone go to charge mode) Right click on fastboot device and install drivers from C:\Android\sdk\extras\google\usb_driver

    4) Reconnect usb cable pushing volup button
    You sir, really deserve a medal of honor. I spent approximately 6 f*cking hours for that issue. The only hard part was trying the install it befor it skips the charging mode. Thanks a lot again.
    08-04-2017 10:36 AM
  13. loughlast's Avatar
    Hey folks
    I have this problem in my Asus zenpad 10 Z300cnl tablet.
    It suddenly goes into Fastboot mode with the options to choose 'recovery mode', Power off mode', 'Normal boot mode', and 'Restart bootloader mode'. Each time I chose any of these options it goes off and comes on again with same condition.

    These are what I see under the Fastboot mode:
    PRODUCT_NAME - P0IT_1
    VARIANT - P0IT_1
    HW_VERSION - PR
    BOOTLOADER VERSION - 1.00
    IFWI VERSION - 0099.0063
    SERIAL NUMBER - 59DC78AC
    SIGNING - unknown
    SECURE_BOOT - unknown
    DROIDBOOT BUILD - 3.0_0218.1

    FASTBOOT CMD WAITING...?
    02-18-2018 02:03 PM
  14. Rukbat's Avatar
    Very old thread, but if anyone comes across it, one thing to try is to hold the power button down until the device (phone or tablet) vibrates. Then, at least, (assuming you've installed the drivers to the PC) the PC will recognize the device and you can boot the boot.img file to see if there's any Android installed at all. (If there is, just fastboot flash boot boot.img and you should be back in business. If there isn't, you'll have to reflash the ROM (which wipes the device with most devices, which is why a phone, like any other computer, should always be backed up).
    06-23-2019 12:29 PM
64 123

Similar Threads

  1. Stuck on "Waiting for Device" trying to unlock bootloader
    By internettoughguy in forum Google Nexus One Rooting, ROMs, and Hacks
    Replies: 42
    Last Post: 09-21-2016, 02:35 PM
  2. Stuck at "Waiting for device"
    By REHolt218 in forum Xoom Rooting, ROMs and Hacks
    Replies: 4
    Last Post: 03-27-2011, 07:51 PM
  3. unrevoked is "waiting for device"
    By pat0neill in forum Incredible Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 01-18-2011, 05:31 PM
  4. OS X fastboot "Waiting for device"
    By patbenatar in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 1
    Last Post: 08-26-2010, 02:09 AM
  5. Replies: 7
    Last Post: 08-03-2010, 05:20 PM
LINK TO POST COPIED TO CLIPBOARD