1. Mrsfwh3's Avatar
    Not sure if this a phone thing or an app thing. I have to go in and manually refresh for notifications, almost all the time. Very rarely do I get my notifications timely. What setting am i missing?
    09-12-2019 08:42 AM
  2. Super Spartan's Avatar
    We had a thread about this a while back, it's a problem with the Gmail app on the Note 10, the only solution that works is switching to Samsung Mail and disabling Gmail. Notifications now come instantly.
    09-12-2019 10:00 AM
  3. mustang7757's Avatar
    Not sure if this a phone thing or an app thing. I have to go in and manually refresh for notifications, almost all the time. Very rarely do I get my notifications timely. What setting am i missing?
    Check the in the gmail settings and you account there are lot of sub menu to toggle on in the app..I get mine instantly while turning them on and push
    msm0511 likes this.
    09-12-2019 10:05 AM
  4. strikeIII's Avatar
    There are now multiple threads about this issue. Some have been able to fix it, including myself, buy disabling Gmail from the Optimize Battery Usage setting. But there are other settings to check and it would probably be best to search for those threads.
    Rukbat, LadyEpic and Disk4mat like this.
    09-12-2019 11:19 AM
  5. Fr0gburp3r's Avatar
    Go into Settings > Go into Apps > Select GMail > Select Battery > Make sure Allow Background Activity is enabled > Select Optimize Battery Usage > Select the down arrow to show all > Find GMail > Disable > Reboot.

    Let me know if it fixes your problem.
    MrPibb01, Disk4mat and areyes1631 like this.
    09-12-2019 12:06 PM
  6. Rukbat's Avatar
    One of the ways 10 optimized battery is by not allowing apps like Gmail to receive email when they're not running. Eventually, as other email apps get updated to 10, they'll exhibit the same behavior. (Taking the app off optimization fixes it, at the cost of some battery.)
    09-12-2019 03:11 PM
  7. toenail_flicker's Avatar
    One of the ways 10 optimized battery is by not allowing apps like Gmail to receive email when they're not running. Eventually, as other email apps get updated to 10, they'll exhibit the same behavior. (Taking the app off optimization fixes it, at the cost of some battery.)

    I don't need or want the optimization. anyway to completely disable it? I tried several ways.
    09-12-2019 03:43 PM
  8. Jona005's Avatar
    For me, turning off battery optimization on the Gmail app itself fixed this problem instantly.
    09-12-2019 05:33 PM
  9. awl_bidness's Avatar
    Thank you Fr0gburp3r. I have made several unsuccessful attempts at forcing gmail to poll for new mail automatically. I followed this exactly, and it worked for me. I don't need the optimization, even with heavy use and a bright screen setting I have never been below 50% battery, most evenings I am still in the high 60's or low 70's.

    Galaxy Note 10+
    10-13-2019 09:30 AM
  10. lonestar1135's Avatar
    Uninstall and reinstall was the only thing that worked for me.
    10-13-2019 01:03 PM

Similar Threads

  1. New Worrying Behavior
    By rabernet in forum Samsung Galaxy Note 10 & Note 10+ (2019)
    Replies: 43
    Last Post: 09-13-2019, 10:16 PM
  2. Call display not shown on screen
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 09-13-2019, 01:37 AM
  3. Where do i find the wps push button on samsung A10
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 09-12-2019, 05:01 PM
  4. samsung s6 not charging properly
    By Ryan Stone1 in forum Android 6.0 Marshmallow
    Replies: 1
    Last Post: 09-12-2019, 05:17 AM
LINK TO POST COPIED TO CLIPBOARD