01-17-2018 10:09 PM
29 12
tools
  1. Marshall Reid's Avatar
    I would like to be able to sync my Google contacts to my phone (Galaxy S4) as well as the other way around. Is there a way to do this?

    When I go into my phone's contacts and look at which contacts to display, there is no option for Google Contacts. Also, when I go to my Google account settings, there are plenty of choices of what to sync but Google Contacts is not one of them.

    What am I missing?
    01-06-2016 05:39 PM
  2. PDX97229's Avatar
    Yes, it is possible to see and sync your contacts to and from Google. The best way to handle this IMHO, is to keep all of your contacts in Google. While it isn't necessary, it does keep things simpler. The first thing to do is go into the settings on your phone. Settings/Accounts/Google - Is the account that contains your contacts listed? If not, add it. Next tap on that account and go through the Sync Settings. One of the lines should read Sync Contacts - make sure it is set to ON. You might want to check the rest of the settings while you are there too. I don't use it, but you might want Sync People Details on too. I'm not sure if that only applies to Gmail, or Contacts too. When you are done exit your Phone Settings and go into your Contacts app Settings. On my Samsung Note 5 stock Contacts app I am only allowed to choose 1 account. Yours may allow more. If you want all your contacts in Google select Import/Export Contacts and export your contacts to vCards. You will be able to use those to import into your Google account. Next go back to the previous screen where you will see a line Contacts To Display - make sure that your Google account is listed, and add it if it isn't there. Then exit Settings and confirm that your Google contacts are now visible. If you are able to see your Google contacts and your Phone contacts you will also have the option of merging the data so that you only see 1 entry for each contact. If you can only see the contacts from one account, or you want all of your contacts in Google, go back to Contacts/Settings and go back to Import/Export Contacts. Now select Import and you will be able to import the contacts previously exported from your phone. At this point you should be able to see your contacts on any device that you own which has access to Google (some set-up may be required). I hope this helps.
    TwitchyPuppy likes this.
    01-06-2016 06:53 PM
  3. Marshall Reid's Avatar
    Yes, it is possible to see and sync your contacts to and from Google. The best way to handle this IMHO, is to keep all of your contacts in Google. While it isn't necessary, it does keep things simpler. The first thing to do is go into the settings on your phone. Settings/Accounts/Google - Is the account that contains your contacts listed? If not, add it. Next tap on that account and go through the Sync Settings. One of the lines should read Sync Contacts - make sure it is set to ON. You might want to check the rest of the settings while you are there too. I don't use it, but you might want Sync People Details on too. I'm not sure if that only applies to Gmail, or Contacts too. When you are done exit your Phone Settings and go into your Contacts app Settings. On my Samsung Note 5 stock Contacts app I am only allowed to choose 1 account. Yours may allow more. If you want all your contacts in Google select Import/Export Contacts and export your contacts to vCards. You will be able to use those to import into your Google account. Next go back to the previous screen where you will see a line Contacts To Display - make sure that your Google account is listed, and add it if it isn't there. Then exit Settings and confirm that your Google contacts are now visible. If you are able to see your Google contacts and your Phone contacts you will also have the option of merging the data so that you only see 1 entry for each contact. If you can only see the contacts from one account, or you want all of your contacts in Google, go back to Contacts/Settings and go back to Import/Export Contacts. Now select Import and you will be able to import the contacts previously exported from your phone. At this point you should be able to see your contacts on any device that you own which has access to Google (some set-up may be required). I hope this helps.
    As I mentioned in my OP, there is no option to sync Google Contacts. All the other sync options are there with various aspects of Google, but not sync Contacts.

    As I also mentioned in my OP, there is no option in the phone's contacts to use Google or even add it as an account.

    This is why I posted my question.
    01-06-2016 07:26 PM
  4. PDX97229's Avatar
    I'm sorry for the misunderstanding Marshall. You are correct when you say that you can't sync Google Contacts. When you set up the Google account on your device you also tell it how frequently you want it to sync between the web and your device. Not just the Google Contacts, but everything in your Google account. Then you tell it what information you want to sync. On my phone it is a list of items that I toggle on or off. At the appropriate time span your phone will send a request by one of the following methods: direct connect to a computer with Internet access via a USB cable, cell tower data, wifi, or maybe even Bluetooth (I have my doubts about the last one, but I'm not an expert), and Google will send the data back. If you have no cell, or web access the request won't be able to go out and the sync won't happen. The same is true if your device is turned off. I can't currently find out where on my phone or tablet I set up the frequency for the sync, I just remember doing it. When you go into your phone Settings/Accounts/Google do you see any Google account listed? Do you have more than 1 Google account? If you do, is the one containing your contacts listed? For now forget about syncing. You need to get your Google account that contains your contacts onto your phone. Note that I said Google Account, NOT Google Contacts! Reread my original post for better instructions on how to do that. If you see the necessary Google account listed then continue through my instructions. If you don't see the needed account, add it. You don't need to find a place in your phone's Contact app to see Google. That will come later. Again let me stress that it isn't your Google Contacts, or just Google that you need to see. You have to have the specific Google Account on the phone, that contains the contacts you want to see on the phone. Many of us have more than 1 Google account. Start there and see how far you can get. I will try to follow your progress on this thread. Good luck.
    01-06-2016 09:06 PM
  5. Marshall Reid's Avatar
    I only have 1 Google account, and yes, it is listed under the email address I have attached to that account. When I go to Settings>Accounts>Google, this is what I see:

    my email address
    Sign-in & security
    Personal info & privacy
    Account preferences

    When I click on my email address, this is what I see:

    Sync App Data
    Sync Calendar
    Sync Chrome
    Sync Google Fit data
    Sync People details (this is not Contacts - already verified this through a search I did since I wasn't sure if it had just been renamed)
    Sync Picasa Web albums

    There is no option for Sync Contacts, yet everything I've read says there should be. And at one point, I'm pretty sure it was there. However, I wasn't using Google Contacts at the time, so if/when it went away, I didn't notice it. Now that I'd like to start using my Google Contacts and Google Calendar, I don't see an option to Sync Contacts.
    01-06-2016 11:07 PM
  6. badcat's Avatar
    I faced a similar issue when I got my Droid Maxx 2 except it was the calendar that didn't show up or sync. After trying a variety of fixes I tried removing my Google account and then re-adding it. I think I restarted the phone in between but I'm not sure that was necessary.
    That fixed it. The option to sync calendar showed up and my calendar started working.

    Hope this helps.
    01-07-2016 07:23 AM
  7. Marshall Reid's Avatar
    FYI...someone on another thread helped me, and it's working properly now.

    Thanks.
    badcat likes this.
    01-07-2016 11:15 AM
  8. SM1982's Avatar
    HI,

    I've had the same issue (Contact sync option doesn't exist) - can you share the solution you found?

    Thanks
    02-02-2016 05:07 AM
  9. Al Faiz Ramadan's Avatar
    FYI...someone on another thread helped me, and it's working properly now.

    Thanks.
    can you please give a link to the thread that helped you marshall? i have the same problem also
    07-13-2016 02:29 AM
  10. ben mohan's Avatar
    FYI...someone on another thread helped me, and it's working properly now.

    Thanks.
    I am also facing the same issue. If I am creating a new user profile in the same phone, then I am getting the contacts option. But it's not coming for the owner profile.
    Tried removing and adding the Google account. Still not working.
    Somebody please help.
    07-16-2016 07:25 AM
  11. ben mohan's Avatar
    I am also facing the same issue. If I am creating a new user profile in the same phone, then I am getting the contacts option. But it's not coming for the owner profile.
    Tried removing and adding the Google account. Still not working.
    Somebody please help.
    Got the fix. The reason was that the Google Contacts Sync was disabled somehow.
    Fix-
    go to the settings>apps .
    In the options , select to show system apps.
    Then check for 'Google Contacts Sync', and enable it.

    After doing this, go to settings>accounts and uncheck and check the 'auto-sync data' option.

    This will bring back the contacts sync option for the Google account.

    Thanks,
    Ben
    07-16-2016 07:57 AM
  12. Jimznz's Avatar
    Hi Ben,

    After I tap show system process, I don't still see "Google Contacts Sync", I can see only below 4 starting with Google, not sure why?
    • Google Account Manager
    • Google Cast
    • Google Play services
    • Google Play Store
    • Google Services Framework



    I am really appreciated your assistance.

    Jim
    07-25-2016 04:51 AM
  13. Anton Yap's Avatar
    Hi Ben,

    After I tap show system process, I don't still see "Google Contacts Sync", I can see only below 4 starting with Google, not sure why?
    • Google Account Manager
    • Google Cast
    • Google Play services
    • Google Play Store
    • Google Services Framework



    I am really appreciated your assistance.

    Jim
    My phone does not have Google Contact Sync and have same problem. So I obtain the apk and use the version suitable for my phone. Here is the link Google Contacts Sync 4.0.4-488656 APK Download by Google Inc. - APKMirror
    Then after install, voila my google contact appear now and I can sync properly.
    09-24-2016 01:39 AM
  14. Domi65's Avatar
    I read your post, and it's my hope that it will work, but it's so scary to hit the export button. I am scared to loose everything...lol
    09-26-2016 09:20 AM
  15. SreeB's Avatar
    As Google Contact Sync is disabled already, I found the same under the Tab "Disabled". You will find all in grey as they are all disabled apps. Touch on Google Contact Sync, same will open its data, touch on 'Enable' so that it will turn to 'Disable' (means got added).

    If your Sync is on, it will automatically Sync as per the time lines set by you.

    This saved me. Hope it will save you too !
    12-03-2016 05:22 AM
  16. papla's Avatar
    Very simple. Go to setting> acounts & sync > google.
    remove google and then re-add it again. That should solve the issue.
    12-17-2016 02:12 AM
  17. Ivailo Manolov's Avatar
    If you miss Google Contacts Sync for some reason in your apps then search and download for Google Contacts Sync APK. I downloaded version 7.xx the first time but it didn't work on my Android 6.0 then i downloaded Google Contacts Sync 6.0.1 and it worked (i had to restart)
    01-25-2017 06:42 PM
  18. Holyton's Avatar
    If you miss Google Contacts Sync for some reason in your apps then search and download for Google Contacts Sync APK. I downloaded version 7.xx the first time but it didn't work on my Android 6.0 then i downloaded Google Contacts Sync 6.0.1 and it worked (i had to restart)
    I tried this now but it dint work for me. Do you have another way around it please?
    01-27-2017 11:07 AM
  19. Tchenv's Avatar
    thank you very much you solved my problem , I love you
    02-16-2017 10:37 AM
  20. Tchenv's Avatar
    My phone does not have Google Contact Sync and have same problem. So I obtain the apk and use the version suitable for my phone. Here is the link Google Contacts Sync 4.0.4-488656 APK Download by Google Inc. - APKMirror
    Then after install, voila my google contact appear now and I can sync properly.
    thank you very much you solved my problem , I love you
    02-16-2017 10:41 AM
  21. Mohammad Sohankar's Avatar
    My phone does not have Google Contact Sync and have same problem. So I obtain the apk and use the version suitable for my phone. Here is the link Google Contacts Sync 4.0.4-488656 APK Download by Google Inc. - APKMirror
    Then after install, voila my google contact appear now and I can sync properly.
    Thanks
    04-04-2017 01:23 AM
  22. Realcap's Avatar
    Turning off the Power Save feature fixed this problem on my Galaxy s7 phone.
    dollkn and 1amarie4 like this.
    06-02-2017 01:21 PM
  23. M8822's Avatar
    Turning off the Power Save feature fixed this problem on my Galaxy s7 phone.
    This did resolve the issue. thank you. apparently in order to save power samsung removes other sync options.

    damn it not contacts i need contacts to be able to contact.

    thanks
    1amarie4 likes this.
    06-06-2017 05:28 PM
  24. Davey126's Avatar
    Another possible solution for anyone experiencing a similar issue (see OP):

    ...Need to give permissions to 'Google Contact Sync': settings->apps->gear icon->app permissions->contacts->3-dot menu->show system->google contacts sync

    Navigation path is for Nexus 6.0.1 (AOSP) but should be similar for most MM/N based ROMs. There are other ways to access and provide permissions; above simply represents one approach.

    Source: https://forum.xda-developers.com/sho...7&postcount=76
    07-10-2017 02:22 PM
  25. AzizSakerwala's Avatar
    I only have 1 Google account, and yes, it is listed under the email address I have attached to that account. When I go to Settings>Accounts>Google, this is what I see:

    my email address
    Sign-in & security
    Personal info & privacy
    Account preferences

    When I click on my email address, this is what I see:

    Sync App Data
    Sync Calendar
    Sync Chrome
    Sync Google Fit data
    Sync People details (this is not Contacts - already verified this through a search I did since I wasn't sure if it had just been renamed)
    Sync Picasa Web albums

    There is no option for Sync Contacts, yet everything I've read says there should be. And at one point, I'm pretty sure it was there. However, I wasn't using Google Contacts at the time, so if/when it went away, I didn't notice it. Now that I'd like to start using my Google Contacts and Google Calendar, I don't see an option to Sync Contacts.
    Did you see if Google contacts sync has permission to access your contacts? Go to settings, apps, show system apps in menu, scroll down to Google contacts app sync and check permissions.

    If permissions are allotted, then go to Accounts in settings and turn off auto sync. Go back to Apps, show system apps and scroll to Contact Storage, delete its data after disabling it and then re-enable it. Then go to Accounts and turn on your auto-sync. That should do the trick.
    jedson01 likes this.
    08-05-2017 12:14 AM
29 12

Similar Threads

  1. How do I uninstall FitBit on my tablet?
    By AC Question in forum Fitness Trackers
    Replies: 1
    Last Post: 01-06-2016, 06:30 PM
  2. Facebook not syncing with contacts
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-06-2016, 06:29 PM
  3. No option to sync Google contacts
    By Marshall Reid in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 01-06-2016, 05:51 PM
  4. No sound only during calls! 😢
    By Muhammadshaikhcb in forum Ask a Question
    Replies: 0
    Last Post: 01-06-2016, 04:55 PM
  5. Replies: 0
    Last Post: 01-06-2016, 04:38 PM
LINK TO POST COPIED TO CLIPBOARD