1. cydewaze's Avatar
    I'm in Canada for the holidays and to avoid the stupid roaming notices, I've turned mobile data off. Except that the phone keeps turning it back on. . This is VERY annoying! Any ideas on how to make it stay off?
    01-01-2015 06:55 PM
  2. anon(5600632)'s Avatar
    Within the mobile data settings, you can turn off roaming. Are you certain it is turning mobile data back on, or is it just the notices? Here in Southern CA near the Mexican border, those roaming notices come through the cellular phone network via text, not the mobile data network.
    01-01-2015 07:15 PM
  3. AZgl1500's Avatar
    macroDroid will make darn sure it stays off if that is what you want, and I can understand you needing that feature.

    install MD => * MacroDroid - Device Automation - Android Apps on Google Play


    Make two macros:

    Trigger: Screen On/Off (select ON)
    Action: Mobile Data On/Off (select OFF)
    right arrow
    right arrow
    Name it something useful: Scrn ON, Data Off (or whatever you like)



    hit the Plus sign again
    Trigger: Screen On/Off (select OFF)
    Action: Mobile Data On/Off (select OFF)
    right arrow
    right arrow
    name it : Scrn Off, Data Off


    Those two macros will ensure that the Data is always OFF until you disable those two macros.

    MacroDroid is extremely powerful, I have 12 macros running on my phone.

    .
    01-01-2015 10:05 PM
  4. cydewaze's Avatar
    Ahhhh, I have that macro, and that's what's turning it on. . Thanks, I'll dissappear it for this trip.
    01-02-2015 11:04 AM
  5. AZgl1500's Avatar
    You can edit each individual macro independently, or you can just turn off the one macro that you think might be causing the problem.

    If you were already using it to "turn on the radios" as I do, then you/I would need to turn OFF the macro that turns the data ON.

    That way, every time you closed the screen, the data would be turned OFF.
    the macro that turns data ON would not be activated, therefore, data would stay OFF.

    Unless of course, you did it manually.
    01-02-2015 01:20 PM
  6. cydewaze's Avatar
    Yep, I just disabled the 'on when screen on' one.
    01-02-2015 09:17 PM

Similar Threads

  1. Replies: 25
    Last Post: 02-24-2017, 10:01 PM
  2. T-mobile Gear S working with Verizon Note 4.
    By Axr6 in forum Samsung Gear S
    Replies: 4
    Last Post: 01-09-2015, 05:27 PM
  3. fsck /data
    By polhallen in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 01-05-2015, 07:18 AM
  4. Samsung Galaxy Note 4 Car Mode keeps coming on
    By Mike Rosekrans in forum Samsung Galaxy Note 4
    Replies: 8
    Last Post: 01-02-2015, 09:02 PM
  5. Why isn't my mobile network showing?
    By Kumar Pokharel in forum Ask a Question
    Replies: 1
    Last Post: 01-01-2015, 01:21 PM
LINK TO POST COPIED TO CLIPBOARD