1. stealth_fingers's Avatar
    S5 is switching between the 2.4GHz & the 5GHz bands every few seconds. (Phone gets hot during.) Had the phone since Verizon released it; issue just started 2 days ago. No problem with daughter's S5 using same network.

    Posted via the Android Central App
    02-06-2015 08:09 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does it work normally if you set the Wi-fi Frequency Band preference to 2.4 GHz (in the Settings>Wi-fi menu, after tapping Menu>Advanced)?

    Try wiping the cache partition, which won't erase any personal data: http://support.t-mobile.com/docs/DOC-10404

    If that doesn't help, try booting into Safe Mode, which prevents all 3rd party apps from starting. This will help figure out if it's an app you installed that is causing the instability, or if it's the system itself.
    02-06-2015 09:29 PM
  3. montanaxvi's Avatar
    Curious, I don't have any settings on my stock Verizon S5 that allows me to pick between the 2.4 or 5 bands.
    02-06-2015 10:37 PM
  4. sanyka78's Avatar
    Neither do I on Canadian s5
    02-06-2015 11:04 PM
  5. B. Diddy's Avatar
    Hmm, I'm basing this on my phone (Nexus 5). So the setting might be in a different place, or just not accessible to the user on the S5. Sorry, don't want to mislead anyone.
    02-06-2015 11:13 PM
  6. LBTRS's Avatar
    I don't think it has anything to do with 2.4GHz and 5GHz switching...I think you're experiencing the same problem that a lot of us are that just started. Wifi keeps disconnecting and reconnecting. You just happen to have both networks enabled (like me) so it looks like it is a 2.4/5GHz issue. Remove either network and it will still do the same thing.

    This problem just started for me 2 days ago. A work around is to disable the smart switching in the wifi/advanced section. Something recently changed to cause this problem that many are seeing.
    02-07-2015 11:16 AM
  7. Devenchi's Avatar
    Turn off Smart WiFi under the WiFi settings

    Posted via Android Central App
    02-07-2015 11:27 AM
  8. Devenchi's Avatar
    Go to settings > WiFi > Advanced and turn off Smart network switch

    Posted via Android Central App
    Attached Thumbnails S5 switches from 5GHz to 2.4GHz every 5 seconds-screenshot_2015-02-07-11-28-00.jpg  
    02-07-2015 11:30 AM
  9. stealth_fingers's Avatar
    It's been a while...I had issues with the AC app not allowing me to post. I upgraded to the S7 edge and forgot about the forums.
    Disabling smart switch worked. I do, indeed have both bands active so when one connection was dropped, it would connect to the other one. Never figured out why the connection was constantly dropping.
    11-19-2016 07:42 PM

Similar Threads

  1. Why is device different from IMEI given?
    By jeobsplyr in forum Ask a Question
    Replies: 4
    Last Post: 05-29-2015, 06:17 PM
  2. Why is my Samsung Galaxy S5 dropping wifi?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 02-10-2015, 02:56 PM
  3. How do I remove synced photos from my galaxy 4?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2015, 09:37 PM
  4. Why does my phone not install the apps I have tried to add?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2015, 09:33 PM
  5. Replies: 1
    Last Post: 02-06-2015, 07:15 PM