1. tirrorex's Avatar
    Hello, following easy steps tutorials i enable developper mode, by whathever the type of usb connection i choose (seems that mtp is bugguy?) the option to activate usb debugging is grayed out.
    This is annoying considering i need this to backup my ios messages into my samsung.
    Any advice? thanks
    03-08-2016 10:04 AM
  2. vferrari's Avatar
    Did you hit the toggle and nothing happens? When USB debugging is turned off, the entry appears grayed-out until you enable it by toggling the grayed-out "switch". My problem is that there does not appear to be a "mass storage" option under usb configuration (which appears under "Networking" vice "Debugging" for whatever reason). Also, even though you can select choices other than MTP under usb configuration (such as "charging" and "picture transfer protocol" ) that does not seem to change the USB configuration which shows MTP regardless of the usb configuration setting you choose once you exit from the pop up dialog box. Strange. If anyone knows how to enable USB mass storage mode on the GS7 Edge, that info would be much appreciated since popping out the sim/microSD tray using the mini-tool just so you can stick micro SD in a card reader to transfer data is a PitA (not to mention that does not help you transfer data onto internal memory).

    Thanks.
    03-10-2016 11:03 PM
  3. KimJongOMG's Avatar
    Hello, following easy steps tutorials i enable developper mode, by whathever the type of usb connection i choose (seems that mtp is bugguy?) the option to activate usb debugging is grayed out.
    This is annoying considering i need this to backup my ios messages into my samsung.
    Any advice? thanks
    I'm not having problems activating usb debugging. Are you sure developer options is turned on? At the very top when you go into the developer mode menu?
    flintlock likes this.
    03-10-2016 11:10 PM
  4. vferrari's Avatar
    I'm not having problems activating usb debugging. Are you sure developer options is turned on? At the very top when you go into the developer mode menu?
    If developer options were not turned on he would not even be able to see sub debugging since you have to be able to open developer options to see it. T

    To the OP - for tranfserring messages from your old IOS device try using the USB otg adapter plug [that big white thing with micro usb female and male connectors) and the usb cable provided in the box along with the built-in Samsung Smart Switch software (it is not a separate app but appears in the Backup and Reset options under Settings). This should enable you to transfer data including messages directly from your ios device (unless that is what you were referring to as mtb bugguy [sic])
    03-10-2016 11:20 PM
  5. KimJongOMG's Avatar
    If developer options were not turned on he would not even be able to see sub debugging since you have to be able to open developer options to see it. T

    To the OP - for tranfserring messages from your old IOS device try using the USB otg adapter plug [that big white thing with micro usb female and male connectors) and the usb cable provided in the box along with the built-in Samsung Smart Switch software (it is not a separate app but appears in the Backup and Reset options under Settings). This should enable you to transfer data including messages directly from your ios device (unless that is what you were referring to as mtb bugguy [sic])
    Actually, you can gain access to the developer options menu and toggle developer mode off.

    See the difference?

    flintlock likes this.
    03-10-2016 11:47 PM
  6. vferrari's Avatar
    Yes, good point. Do you see a Mass Storage option for USB on your S7 device.
    03-12-2016 04:55 AM
  7. Thomas Briggs's Avatar
    Unfortunately for me I still cannot access USB Debugging mode, it's always greyed!
    Any help would be welcome

    How to enable usb debugging on s7 edge?-screenshot_20160313-131708.jpg
    Attached Thumbnails How to enable usb debugging on s7 edge?-screenshot_20160313-131724.jpg  
    03-13-2016 08:36 AM
  8. gjavv's Avatar
    I have the same issue!
    Could it be it has something to do with "my Knox"? Did you install it?
    Thomas Briggs likes this.
    03-13-2016 12:21 PM
  9. Thomas Briggs's Avatar
    I have the same issue!
    Could it be it has something to do with "my Knox"? Did you install it?
    Thanks Gjavv that fixed it!!! Let it be known :P
    03-13-2016 12:42 PM
  10. gjavv's Avatar
    I didn't even try before you did.... But after uninstalling MyKnox it works.
    03-13-2016 01:23 PM
  11. PJRed2008's Avatar
    Yes, good point. Do you see a Mass Storage option for USB on your S7 device.
    If you're just trying to transfer files, the second option under USB when plugged in to a PC works as mass storage, but doesn't have the label. Gives access to both internal and external (SD) files and folders.
    03-13-2016 02:01 PM
  12. Mikal723's Avatar
    Another item to note is that it will not go into the MTP mode unless the GS7 is connected to a computer or other device. Once disconnected it reverts back to charge mode.

    To bad there is not a way to keep it in the MTP mode and charge at the same time.
    03-18-2016 05:06 PM
  13. Tummy Yummy's Avatar
    Smart phones have been around for over a decade now and still the developers can't manage a simple way to connect your phone with your PC. If I were running a company that had this problem I'd be replacing my software PR staff real quick.

    It seams that the newer the programs, the more buggy they are and the more you need a doctorate degree to manage the settings. I heard the computer industry is getting ready to hire tens of thousands of new programmers. I wonder why.
    03-24-2016 05:04 PM
  14. bencleric's Avatar
    so simple. the reason why you had gray scale in usb debugging after enabling the developer mode, its because of myknox. i have encountered the same problem but i able to fix it. to fix your problem just follow my instructions.

    1. go to https://my.samsungknox.com (use laptop or pc)
    2. login your account by entering the email and password you had registered in your samsung account phone.
    3. a several option will appear. just click UNLOCK and UNREGISTERED your phone option. then your myknox will automatically uninstalled in your phone. (make sure your phone has a connection)
    4. go back to developer option after myknox has been removed automatically, then you can enabled the usb debugging now.

    thats it. i fix mine. 100%. dont forget to say thanks once you fixed yours. have a nice day.
    04-15-2016 11:56 AM
  15. zolom's Avatar
    Thanks

    This procedure did not rectify the situation. USB Debugging is still grey on my S7 Edge Developers Options scree
    05-03-2016 08:32 AM
  16. Joe Steele3's Avatar
    Thanks gjavv! I just ran into this today and this was the first thing I tried. Saved me a ton of searching. +100 internet points
    05-13-2016 04:04 PM
  17. James Barry1's Avatar
    Same issue with me remove My Knox worked... Thanks
    05-15-2016 02:46 PM
  18. Wajahat3256's Avatar
    Very easy !! Its because that you installed the Knox app !!
    Just uninstall the app My Knox ! And you r done !!
    05-26-2016 05:44 PM
  19. florus2901's Avatar
    Is there a way, to fix this problem with out removing Knox?

    I use Knox to give an extra security layer to my banking apps. And so do not want to remove that layer.
    06-24-2016 07:27 AM
  20. adeyemi00's Avatar
    Bencleric many thanks for the suggestion. However, after several failed attempt to login online on my PC, I decided to just do that with my Samsung GS7 then was able to uninstall My Knox via the Application manager of the phone then restarted the GS7 to be able to enable USB Debugging successfully.
    adeyemi00.
    07-23-2016 08:12 AM

Similar Threads

  1. Voice commands on 2nd Gen moto 360
    By eric002 in forum Moto 360 (2015)
    Replies: 4
    Last Post: 06-24-2016, 07:50 AM
  2. How do I send pictures?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 03-08-2016, 12:49 PM
  3. Why don't any of my apps work on my Alcatel OneTouch Pixi?
    By AC Question in forum Alcatel Android Phones
    Replies: 1
    Last Post: 03-08-2016, 12:49 PM
  4. Smart remote is not working, how can I get it working?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 03-08-2016, 09:51 AM
  5. How do I erase an event from the calendar?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 03-08-2016, 09:49 AM
LINK TO POST COPIED TO CLIPBOARD