11-19-2017 05:59 AM
40 12
tools
  1. piannetta's Avatar
    Piannetta: Ok, That second (and very long) thread that I referred to does seem to suggest it's a general Android 6 problem, not limited to Google Maps. Again: https://code.google.com/p/android/is...tail?id=190376 I haven't fully digested it, but it does look strikingly similar to your/our issue, IMHO.
    Dude, I'm so sorry, my bad. I just scanned the thread and didn't take the time to properly read it, it does look exactly like the problem I have. Thank you for sharing!
    05-05-2016 03:26 PM
  2. Senators Rule's Avatar
    Dude, I'm so sorry, my bad. I just scanned the thread and didn't take the time to properly read it, it does look exactly like the problem I have. Thank you for sharing!
    I have a Samsung S5 and had resisted the update for weeks. Decided to go for it and since updating to Android 6.0 the GPS started to crap out. I use sports apps like Strava to record stuff and it randomly drops signal and every event I've recorded since updating to Android 6.0 had failed an hour or so in - what a major fail when GPS is given standard on any phone these days.
    06-04-2016 08:43 PM
  3. natty_8's Avatar
    Same issue here, I'm requesting a refund. Want a different phone now. I bought a galaxy s7 edge from Optus in March 2016. Samsung did a software re flash on it, still had the same GPS issue, then they replaced the PCB , and it still didn't fix the problem. Then I got a replacement S7 from Optus it still had the same issue. It only works if I restart the phone or toggle location on/off. The issue not only affects Google maps but also my running apps.
    You are lucky you got a replacement that worked, coz my replacement didn't.
    06-21-2016 05:36 PM
  4. piannetta's Avatar
    You are lucky you got a replacement that worked, coz my replacement didn't.
    I got a replacement but the problem remains. It worked fine for the first 3 weeks then the GPS issue started happening again. It's not the phone, it's an issue with Marshmallow that Google needs to fix. Head over to this URL https://code.google.com/p/android/is...ort=&id=190376 and add your situation to the list so we can hopefully get a response from Google.
    06-23-2016 02:30 PM
  5. 1mary1's Avatar
    Ive had the same issue for about 2 months, i was at my wits end this morning after many failed suggestions by others, until i came across this thread and gave Greg's suggetion of turning power save off a go and waze worked instantly. You buddy are a legand!!!!!! It was so damn simple but also so hidden, i thought i had been through every setting possible, clearly not.
    THANKYOU THANKYOU THANKYOU!
    07-04-2016 07:54 AM
  6. logandro's Avatar
    Have tried several things and the only thing that worked wonderful for my was to disable power save.

    I have the following config on my s7 edge:
    Power save: Off
    Location method: GPS only

    Thank you!
    07-08-2016 07:06 PM
  7. Jon05177's Avatar
    I have had the exact same issue with my S7. The only fix I have found is to reboot before travelling to and from work. I will keep looking for answers too
    08-02-2016 03:14 AM
  8. aaroncavanaugh2's Avatar
    Hi,
    The fix for me was to make sure GPS only was checked not the option where it uses wifi like "WIFI help to get full GPS accuracy." I think this confused my phone and made the connection drop whenever wifi was in the area.
    Thanks. God Bless.
    Aaron
    08-11-2016 12:24 PM
  9. Alistair Erskine's Avatar
    The problem I'm having is not exclusive to Google Maps, any app that uses the GPS is reporting no GPS signal. But if I reboot the phone, it works fine, sometimes for days, sometimes a few hours. I can't seem to pinpoint the root cause. Anyway, I'll see what happens with turning off the power optimisation, for apps.
    I have exactly this problem, and i think it has something do with me plugging my phone in to charge. When that happens it's like the gps chip shorts itself and just stops working, but a reset totally fixes that. It's so frustrating.
    09-07-2016 07:24 AM
  10. French's Avatar
    I've been having issues with my SmartThings app...it's constantly showing me as present and then away within a minute or two of each other, even when I haven't moved!

    I did two things. The first...I'm not really convinced fixed it for me, but I did it so I'll post it: downloaded GPS Test (https://play.google.com/store/apps/d...tcross.gpstest) and then the menu on the right (3 dots) I selected clear AGPS and then went back into the menu and selected Update AGPS.

    The second thing I did, and I believe this one is the key...I'm using My Places and somehow it was set to optimize battery. I use it to turn wifi on when I arrive at home (and for some other things)...but what was happening is I think it was going into a doze or close mode which would then make My Places think I was out and about rather than home. That in turn would turn wifi off and disconnect my router, and THAT in turn was causing SmartThings to think I had left. So for me the key was making sure My Places is set NOT to optimize. Go to Settings>Phone>Battery>More>Optimize Battery Usage (and you will probably need to change the drop down to show all apps...mine defaults to showing the optimized ones only) and then scroll down to My Places, and flip the switch so that it's off. This seems to have fixed the constant in-and-out of SmartThings. I thought I was having a GPS issue but now I think it was just that the app was trying to optimize.

    Also, try this optimize menu for any other specific app that's giving you issues (for example someone mentioned Waze specifically). It might just be that the app is going into a sleep mode and flipping the switch will prevent that.

    I'll update my post if this turns out to not have fixed my issue but so far I've had no false reportings of leaving home when I haven't since I did these two things.
    11-03-2016 09:42 AM
  11. bluelove2's Avatar
    Hey guys,

    I think we have this problem because we are using Taiwan version in Australia.
    I have double sim card Taiwan version and I am using optus and Telstra simcard.
    Please let others now about your phone version and operators.
    New note5 update is completely ****ed my phone. before this update disabling power saver and chooaing gps only solved my problem but after last update, gps is rubbish as before.
    11-07-2016 01:37 AM
  12. AZchips's Avatar
    I've S7 G930FD (Dual sim) model and I've the same problem. GPS signal can't be detected (Verified through "GPS Test" Apps).

    https://code.google.com/p/android/is...ort=&id=190376
    11-11-2016 12:29 PM
  13. Fulano deTal's Avatar
    Turning off wifi while using the GPS resolves the problems. It appears to be a software driver issue in Android 6.0. The wifi beacon is degrading the GPS satellite signal. The GPS L2 frequency is 1227.60 MHz, and 802.11b wifi channels 9 and 10 are right in the middle of THE first harmonic of the GPS signal.

    Attached Thumbnails Losing GPS signal, how can I stop this?-2n86jd.png  
    pontiac005 likes this.
    02-05-2017 01:22 PM
  14. handinpalm's Avatar
    I recently lost use of my GPS on Nexus5X. Finally uninstalled Mapquest app and now it works fine. Something about the new Mapquest update. I use Google maps anyway.
    08-12-2017 10:15 AM
  15. JBee101's Avatar
    So glad I found this thread! My Motorola MotoG3 running Android 6.0.1 (Marshmallow) had exactly the same issues. GPS fix was flaky at best. Sometimes turning off "location" then re-enabling got a lock, sometimes only a complete reboot of the phone would do.

    I use GPS on Runkeeper and on Google Maps Navigation & Driving. Both were hit and miss. Even standing outside in full view of the sky would sometimes not get a GPS lock. It would never lock indoors at all.

    So, following earlier suggestions (thanks!) I had a look at whether the Apps were being battery optimised and it seems everything on the Motorola was subject to optimisation so I removed the Apps listed below from optimisation and suddenly the GPS is absolutely fine and locks in seconds like a champ!

    For Motorola Moto G3 on Marshmallow (6.0.1.):

    Settings > Battery > Click the three vertical dots in the top right hand corner to get two further options.
    Select 'Battery optimisation'
    Change the dropdown that says 'Not optimised' to 'All Apps' and you'll see every app you have.

    At this point I selected the 'LocationServices' App and it gave me a pop-up allowing me to set 'Don't optimise'. I repeated this for the 'Maps' and 'Runkeeper' apps. Since then, no problems.

    Hope this helps someone. It's as frustrating as hell getting in the car only to find the phone won't lock to GPS!
    11-19-2017 05:59 AM
40 12

Similar Threads

  1. Replies: 3
    Last Post: 06-09-2016, 02:36 PM
  2. LG G3 D805 no signal?
    By AC Question in forum LG G3
    Replies: 3
    Last Post: 04-14-2016, 01:46 PM
  3. No 4G signal
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-14-2016, 07:18 AM
  4. LG G2 VS980 + Marshmallow = GPS solved
    By ellisol in forum Verizon LG G2
    Replies: 0
    Last Post: 04-12-2016, 10:53 AM
  5. Why am I losing random sounds on S7?
    By AC Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 04-08-2016, 01:36 PM
LINK TO POST COPIED TO CLIPBOARD