1. AMRROL's Avatar
    Whenever I try to pair my Fitbit Flex to my Galaxy Tab 3 (SM-T310) I get the error message "unable to communicate with Flex". Bluetooth detects and shows it as an available device, but can't pair with it. My previous Fitbit Charge never had this problem.

    The mobile android app has been properly installed, and the Flex registered with it. It had no problem connecting to the Flex during the installation process.

    Funny thing is that using the mobile application, I can sync if both a Wi-Fi internet connection and Bluetooth are turned on, even if it is not paired. If either one is turned off, no go. I don't understand this because the Fitbit Flex is not a Wi-Fi enabled device. I really need the Bluetooth paired to this device because I do not always have an internet connection.

    I have posted this question on the Fitbit community, as well as to their customer support, but have not gotten any response in the past 48 hours. So I am hoping that someone here can help.
    03-12-2015 10:08 AM
  2. ovdevil's Avatar
    You need 4.0 or higher Bluetooth for the Fitbit, I have a Fitbit Charge and I can't sync.
    03-12-2015 11:26 PM
  3. AMRROL's Avatar
    Thank you for the reply. I thought that the Tab 3 (SM-T310) did have 4.0 Bluetooth. Do you know what version it has? Thanks in advance.
    03-13-2015 05:36 AM
  4. AMRROL's Avatar
    Forgot to mention. I originally had the Fitbit Charge and it paired perfectly with my Tab 3 tablet. I had to return the Charge as it stopped working and downgraded to the Flex. And the Tab 3 is definitely listed as a supported device on the Fitbit website.
    03-13-2015 05:38 AM
  5. wkopera's Avatar
    Having the same exact problem. Samsung s4 and samsung s5 will not consistently communicate with the Charge. Phone notifications will not work, though once in awhile the sync will work.
    03-21-2015 10:25 AM
  6. Kim Stomboli's Avatar
    I have a flex fitbit. It was working perfectly fine for the last month and a half until yesterday. On my mobile app it is now suddenly saying unable to communicate with Flex. I am using Samsung Note 4 on Verizon. I have removed the Bluetooth and reinstalled it. I'm not sure what to do at this point. Any ideas?
    03-29-2015 01:33 PM
  7. Sarn Ng's Avatar
    Charge HR with Note 4 - unable to communicate error when trying to pair. Bought a Charge HR small and went through the process of pairing. Returned to the shop the next day and exchanged for a large. Did the pairing again and found 2 devices paired via Bluetooth. Both displayed Charge HR and deleted both. Tried to pair again, but started coming up with message "unable to communicate".

    Resolved by deleting the Fitbit app and reinstalling. Once installed, did the pairing process again and it now works. Device is paired once again with the phone.

    Hope this works for you.

    Cheers, Sarn
    04-19-2015 07:22 AM
  8. sillylaughter's Avatar
    Thank you, Sarn! Uninstalling and reinstalling the app also worked for me (on my Samsung Galaxy Note and Charge HR). I had tried everything else (turning off/on Bluetooth, unpairing/repairing devices, restarting the Charge HR) and the reinstallation of the app was what solved it
    06-18-2015 04:41 PM
  9. Melanie Crouch's Avatar
    I have a samsung s5 and the charge HR. I fully charged my fitbit then downloaded the app and all worked great. It would sync and the bluetooth worked the first day and a half. Then the fitbit wouldn't sync nor give me the caller ID. I looked up there trouble shooting and did all that. took app off put it back on, hooked fitbit to comp and held side bottom down until it reset its self. I even went as far as factory reboot on my phone thinking it was the reason all quit working. Oh and called costumer services, was told do all I did already. They were no help.
    over night my fitbit started to sync again but it will not hook to bluetooth. I get either no divide found or the unable to communicate with the charge HR. I am about ready to call for a refund.
    I don't know what else to do.
    07-25-2015 04:49 PM
  10. Jessica Whitaker's Avatar
    This worked for my Note 5 to get call notifications:
    I was trying to pair my fitbit Charge HR through the regular process within the Bluetooth setting on the phone. The Charge would appear as a device but when I tried to pair it I would receive "Paired rejected by Charge HR".
    I then went into the Fitbit app on my phone, went to "Devices", touched "Charge HR" icon, not the sync on the right side of the screen but the actual Icon of the device on the left side. Then touched "Call Notifications, not the "On/Off" toggle on the right of the screen, but the actual words "Call Notification" on the left. Received a message that the device had to be paired. Selected "OK" on the message and it paired my Charge HR with the phone and I started receiving call notifications on my.
    Hope this helps someone!
    Matthew Wade1 likes this.
    11-30-2015 05:44 PM
  11. Matthew Wade1's Avatar
    +1 to Jessica Whitaker. Her solution worked on my Galaxy S5
    12-25-2015 10:22 AM
  12. danid0odle's Avatar
    This worked! thank you !
    12-26-2015 10:09 AM
  13. rdrr's Avatar
    I had the same issue with a new Fitbit Surge and Galaxy S5...was driving me nuts. I'm computer savvy so thought no problem. Arrr, tried everything that was on every forum and in the end, just deleted the app and re-installed. It connected immediately and so far so good. Some good advice here folks, thx
    12-26-2015 09:52 PM
  14. budcurtis's Avatar
    My Tab 3 connected right away with my FITBIT Charge. I view the FITBIT APP more often on my tablet than my phone, so far it synchronizes every time.
    01-03-2016 07:57 AM
  15. atmavalon's Avatar
    I was unable to sync my Charge with my phone. I set my account up on my computer, synced the device, everything worked fine. Then downloaded the Android app (Samsung S6). Was unable to sync, the phones bluetooth couldn't find the fitbit. Logged off of the fitbit site on my computer and the phone and fitbit started to communicate. Seems obvious now, but the fitbit can only talk to one device at a time.
    02-15-2016 11:54 AM
  16. gezza2468's Avatar
    My Bluetooth said "unable to connet with device". It was because you download and use the Smartwatch app that you downloaded to your phone to connect via Bluetooth. Not the phones bluetooth settings.

    I hope that helps.
    02-29-2016 05:12 AM

Similar Threads

  1. Can someone please close my account?
    By Deb20 in forum General Help and How To
    Replies: 2
    Last Post: 03-13-2015, 04:58 PM
  2. Replies: 1
    Last Post: 03-12-2015, 10:32 AM
  3. Replies: 2
    Last Post: 03-12-2015, 10:08 AM
  4. Why can't I turn on my AT&T HTC One M7?
    By AC Question in forum HTC One M7
    Replies: 0
    Last Post: 03-12-2015, 09:52 AM
  5. Odin 3.09 doesn't detect my GT-i9100G in any possible way
    By D13H4RD2L1V3 in forum Samsung Galaxy S II
    Replies: 2
    Last Post: 03-12-2015, 09:45 AM
LINK TO POST COPIED TO CLIPBOARD