1. realism51's Avatar

    Root access with a Samsung Galaxy S3 (T-mobile) on android 4.3 can prove to be a pain, especially if Samsung's Knox app rears it's head.

    It has been a while since I last rooted a phone (HTC Incredible). I have had my S3 for over a year now, but grew tired from the battery drain and the many many apps running in the background that I just could not fully remove. My phone screamed, "Root Me!"

    So to the web I took myself, and thus my struggle with Knox began.

    With all the options out there I wanted to quickest and easiest route for me. Odin showed me the way. Honai of Android has a really great walk-through of how to root using Odin and Cf-Auto-root. How to Root Galaxy S3 (T-Mobile) SGH-T999 on Android 4.3 Jelly Bean Firmware - Honai of Android

    Followed it to a T and ended up running into the issue with SuperSU not wanting to run and crashing of sorts. Even though the one on the Play Store is updated it wasnt providing any answers for me, so i followed the "How to fix" instructions on the bottom and downloaded the latest APK of SUperSU Download file SuperSU-v1.93.apk and copied the APK into a folder on my SD card.
    Using "My Files" in app drawer I located the APK and installed it.This updated the binary and allowed me to block Knox from interfering . . . at least for the time.

    While trying to install other apps that require root I ran into the issue with Knox still not wanting to play nice with SuperSU and it eventually went back to an epic battle where I try not to turn a Samsung product into a hockey puck


    Scouring the internet and XDA forums I wasnt able to locate any information on how to permanently and completely disable and remove Knox.
    I did stumble on Imran Aftab's posting over on androidcentral on how to Disable/Uninstall Knox How to Disable/Uninstall Knox on your Samsung Galaxy Phones and Tablet

    I got a bit peeved when I found out the dirty trick Samsung was pulling with Knox (wont be buying another Samsung phone).
    Aftab had posted 3 different ways to accomplish this:

    one without root access (doesnt really uninstall/remove),

    For those already with Root: Eplorer or Titanium backup (couldnt get either to play nice, maybe try the paid version if you already have it)

    and for the tech savvy: disabling using Android Terminal Emulator ----> Keep this in mind, it is a life saver for a number of reasons.

    The listed instructions on what command to input is a bit off, most likely due to html formatting.

    I installed Android Terminal Emulator from the Play store - granted it SuperSU access - and proceeded to type the following command(s):

    su [enter]
    pm disable com.sec.knox.seandroid

    *NOTE - the above to lines require you to go to a new line after typing "su", the [enter] is only a reminder, DO NOT type [enter] after su

    This disabled KNOX for me - but that wasnt good enough for me - I was out for blood at this point.

    I brought in the heavy guns ^_^

    Ultimate deletion from phone, backups, and any other little hiding hold Samsung created for this monstrosity.

    "Nobloat Free" took to the android sky like an F-16 with laser guided missiles. After giving it permission I scanned the system for all amount of bloated evil and realized it worse than I thought, like Left 4 Dead, but more devious.

    I found every file associated with running and storing the KNOX, selected and knoxed it right out of my phone - no backup and delete.

    YaY!!!!!!!!!!!!!!!!!!!!! Death to forced apps......

    *Note if you want to keep KNOX in case at somepoint in the future the void warranty thing can be reset - ensure you back it up before deletion.


    End result = a happier me and a much faster and smoother running phone

    This worked for me, but might not work for the rest of you - but best of luck, some variant is bound to work out for you.

    SscoootzZ, SandyBaggy and GSDer like this.
    02-26-2014 11:16 PM
  2. Golfdriver97's Avatar
    Thanks for sharing.

    For anyone else reading, this method looks like it should work.

    Be Advised: This looks like it may potentially be messing with even the bootloader. Caution cannot be over-stressed here.
    VDub2174 and UJ95x like this.
    02-26-2014 11:21 PM
  3. UJ95x's Avatar
    Definitely seems legit. I'm luckily Knox free since I rooted prior to 4.3, but this would be extremely helpful for users with that dreaded "security" program.
    Thanks for sharing
    Like mentioned above, do this with extreme caution. Follow the instructions to the T and you shouldn't have any issues.

    Sent from my Galaxy S4 running SlimKat 4.4.2
    Golfdriver97 and VDub2174 like this.
    02-26-2014 11:29 PM
  4. saab61's Avatar
    i dont have knox in my aplication manager when i look by all.
    is it hidden ore just not there?
    03-05-2014 02:20 PM
  5. UJ95x's Avatar
    i dont have knox in my aplication manager when i look by all.
    is it hidden ore just not there?
    If you're not on 4.3 or later, then you don't have it

    Sent from my Galaxy S4 running SlimKat 4.4.2
    03-06-2014 06:07 PM
  6. arkibars's Avatar
    i download cf root in my s4 kitkat version, but i dont know still work in this process, mybe they updated the knox version in kitkat
    04-04-2014 10:48 AM
  7. lmanikam's Avatar
    Hi matey,

    Thanks for the instructions.

    Am having some trouble with it am afraid.

    When I run the commands in the Terminal Emulator I keep getting "retrying in 1 sec" and then "failing to connect to dumpstate"

    No Bloat Free doesn't work either as it says "denied root access" even though i've re-rooted the phone

    Super SU (updated) is unable to disable Knox (attempts but fails)

    Help! Any advice?

    07-04-2014 02:28 AM
  8. Neil Anthony's Avatar
    I want to tell my story of how I got rid of the dreaded knox and what problems I encountered, because it may help someone else. I am a total newbie to rooting and really did it out of neccessity because I was fed up with intrusive tracking and wanted to use something called Orbot which is a tor network, and consequently I needed root access for it to work properly.

    After checking out various sites I eventually got round to rooting my Galaxy Note 2 N7100, Android 4.42, using Odin 3.09 and a CF-Auto-Root-t03g-t03gxx-gtn7100.zip.

    As soon as I had rooted the phone I got the dreaded 'Unortunately SuperSu has stopped working' message. I simply downloaded the latest version of SuperSu off of Google Play and then was asked by the program if I wanted to disable Knox which I did and hey presto I got Root Access. Unfortunately my problems didn't end there though.

    I shut down the phone at work and later turned it on again and to my horror I got the 'SuperSu has stopped working' message again. I tried everything (ES Explorer, Terminal Emulator, NoBloat Free, among others) but there was no way that Knox was going to shift. I couldn't delete it with any of the programs simply because I needed root access for those programs to work. So I was stuck between a rooted phone (yes the phone was still rooted according to root checker) and having no access to that root because of Knox.

    Luckily for me I had backed up and the only option I had was to do a factory reset (SuperSu was still there upon factory reset, but not working - I didn't expect that one!) but everything else was gone and back to factory default and I didn't have root access on my phone according to Root Checker...which is only what you would expect, really, after a factory reset. I was determined to get rid of Knox at all costs or brick my phone trying! Either way...I was angry at Samsung for forcing that upon me when I didn't ask for it or want it.

    In the end I had to re-root it again and to my horror I could not get the phone to root. After several times trying to re-root or flashing as I believe its called, a flash of inspiration sent me back to the Settings > More > Security and unticked the Unknown Sources box and made sure the Verify apps box was unticked. I also went into Settings > More > About device: tapped the 'Build Number' seven times (I think) to put it into developer mode. Then I went back to Settings > More > Developer options and made sure the 'USB debugging was ticked before trying to root the phone again (tab). Unfortunately that didn't give root access at that particular point in time, but another flash of inspiration sent me to the Google play site to download SuperSu again, and to my complete surprise, it updated and finally, I was able to disable that exasperating, insideous, virus-like peice of trash disguised as a security program called Knox.

    This time though, I wasn't going to rest on my laurels, I immediately re-downloaded 'NoBloat free' from the Google Play store, and with root access now working I was able to get rid of that pesky Knox once and for all. The interesting thing is that the Knox program itself, wasn't even installed on the phone...just the shortcut to download it and install it. So what on earth was it doing being listed as an administrator at the O.S. level when I don't even have the full program? ARRRRRRRRRRRRRRGH! So the moral of the very long story is:

    After rooting...make sure you follow through with a program to delete or uninstall knox...otherwise on restart it will rear its ugly head and give you far more headaches...and there is nothing worse than losing all your new settings again and having to start from scratch like me. Oh and do make sure you check that it is gone by going to Settings > More > Security > Device Administrators, to check it is finally gone. And good riddance to idle rubbish!

    I'm glad I did it and it was a great learning experience and am now the happy owner of a rooted phone which is the best thing I have ever done...despite the initial headaches.

    08-02-2014 02:15 PM
  9. TomD's Avatar
    It appears that Samsung is abandoning KNOX. With all the heat they are taking from users who want to flash ROMS and Root, that seems to be translating into lost sales, combined with Google's decision to do enterprise security themselves.

    One thing that Android desperately needs is a way to backup Apps and App data without having to Root.

    Here's a Forbes article that lays this out:
    Samsung Nixes Knox: The Android Security Saga Continues - Forbes

    I'm amazed that this has not hit the Android blogs yet.
    08-25-2014 04:20 PM
  10. TomD's Avatar
    Can anyone tell me if this is an official way to remove KNOX, or am I misunderstanding this:

    How do I Remove or Uninstall KNOX™ Personal on my Samsung Galaxy Note® 3? : T-Mobile Cell Phones | Samsung
    09-03-2014 12:47 PM
  11. Helge Holt's Avatar
    OMG! You made my day! I was fighting with KNOX all day, I thought my Galaxy Tab 4 10.1 was jammed or could never be used again because of that nasty KNOX thing! Then... came this thread! Thank you so much!
    10-29-2014 04:38 PM
  12. Nic42's Avatar
    My SM-T900 (tab pro 12.2 wifi) came with Kitkat AND knox. I hate Samsung. Grr! Anyway rooted and disabled via pm ... hope this is enough.
    11-16-2014 10:12 AM
  13. pfoneguy1's Avatar
    I just picked up an SG SIII T999L and the device is stock not rooted. I had not even activated the device or installed a SIM.
    I get this Security warning: "An application attempted to access system on your device without authorization. This attempt has been blocked. Updating your security policy may solve this problem. Deleting applications obtained from unauthorized sources may improve security"
    Offers a box to cancel for 30 days
    Below that are option to: Cancel - Update- View apps
    Clear it and it comes back immediately. It gives me no reference to what application is causing this.
    Update and it just shows Latests security policy has already been applied.
    View apps and it goes to Down loaded and 1 app is present
    GALAXY Apps
    Long pressing the notification brings up the Knox Notification Manager with no ability to turn it off.
    Looking at the description to disable Knox without Root access (Link How to Disable/Uninstall Knox on your Samsung Galaxy Phones and Tablet above) tells me to open the app and then go to settings? When I open the app it asks me to install it? If it is not installed how can it be blocking apps?
    What to do? Install the app and then install it?
    I don't want to install making matters worse so I thought I would ask before attempting that..

    This all happens with a SIM installed and the device functioning as well. If I check the box it will cease notifications for 30 days, but I would just like to get rid of this if I can.
    12-15-2014 12:44 PM
  14. Dan Casaletto's Avatar
    I really liked your dramatic narrative, you're a badass.
    03-09-2015 05:56 PM
  15. Liz Kei Chan's Avatar
    ty so much , done all you wroth and i to got is all blast away from my phone
    this was really very helpfull
    grtz Liz
    07-03-2015 10:05 AM
  16. Timr617's Avatar
    This doesnt work! If you download an app called Usage Timeline from the play store you will see that Knox is still running under a "system" file with the name (com.sec.knox.containeragent) process id 437. This app is very sneaky and suspicious there is no way to remove it so far.
    07-22-2015 09:03 PM
  17. Sheri Southam's Avatar
    I contacted Samsung direct and they told me that if you enter the password incorrectly 20 times, the app will be deleted. So I just entered any old characters and numbers 20 times - and sure enough, KNOX has completely GONE

    And I don't know if it was just a coincidence but immediately after performing the 20 incorrect password routine, I was finally able to connect my Samsung Galaxy S4 to my new smartwatch
    10-21-2015 08:03 AM
  18. AdamEyes's Avatar
    I registered just to bump this. Totally works. 20th time is a charm. BBL getting reacquainted with my mobile device that I now own again.
    10-22-2015 10:26 AM
  19. Red_Chaos1's Avatar
    So if I succeed with this, then I should be able to flash other ROMs, etc.? I made the mistake way back updating to KitKat on my Verizon S4 and getting fully locked in, and until now had not seen any indication I would every be able to get rid of the Verizon crapware and such (the phone is mine, I bought it out, and I am no longer with Verizon anyway).
    11-07-2015 02:44 PM
  20. SandyBaggy's Avatar
    A thousand thanks, i can finnaly die in peace knowing there is no more knox on my phone thank you so much!! Verry good post
    11-10-2015 02:12 PM
  21. Darkhorse3211's Avatar
    Hi there. I"m a total newbie to Android coming from being a Blackberry gal.
    I mistakenly added knox, unaware is was a suction app(one that sticks and won't let go)

    I was able to use ccleaner to remove Knox, but for the life of me, I cannot remove 6 unwanted files. I've tried nobloat and ccleaner, and the files just won't budge. I've tried Ghost Commander as well and nothing.

    Any other suggestions? I had excess/useless files on my phone. I'm OCD, so it really bugs me.
    Thanks in advance.
    I have a Samsung Galaxy Note 5.
    05-19-2016 10:39 PM
  22. brandysgrove's Avatar
    I have figured out how to delete MyKnox from your Samsung, permanently. I work for a wireless carrier in Canada. I did have MyKnox downloaded, but honestly had no use for it. I could not "uninstall" from the Knox settings, and I honestly refused to download another app or do anything to my phone simply because I wanted it removed. I contacted Samsung chat support, and they were also completely useless. Here's how you do it kids...

    1.) Go to this website https://my.samsungknox.com/en-US/#/login
    2.) Sign in with the information that you used to sign up. If you forgot your username and password, it's incredibly easy to have those sent to you.. assuming you have access to the email you used.
    3.) Delete the phone from the account.
    4.) Click on settings and delete account.
    5.) After having done this, I no longer have MyKnox on my Samsung S7 Edge

    No need for rooting, or other apps to remove it and no backing up to factory reset. Hope this helps.
    03-15-2017 07:04 PM

Similar Threads

  1. How does the T-Mobile free data for tablet work?
    By vlee in forum General Carrier Discussion
    Replies: 9
    Last Post: 06-22-2014, 12:18 AM
  2. How to save numbers of incoming calls?
    By Drew Childers in forum Moto G
    Replies: 2
    Last Post: 04-16-2014, 01:52 AM
  3. AT&T 4.4.2 update removed some things from my S4
    By AlphaVictor87 in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 02-27-2014, 02:26 PM
  4. 'Ready To Cast' Screen Saver?
    By ninjiaChen in forum Google Chromecast
    Replies: 1
    Last Post: 02-27-2014, 09:29 AM
  5. Galaxy S4 connected to PC
    By pcprik in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 02-26-2014, 06:58 PM