08-14-2018 09:42 AM
28 12
tools
  1. MannyZ28's Avatar
    So for whatever reason, my computer no longer sees the internal storage and the sd card on my phone. It finds the phone itself, but just identifies it as a modem. I am running Windows 7. Any ideas on how to fix that?
    02-08-2012 03:27 PM
  2. JayWill's Avatar
    Do you have USB debugging enabled on your phone? If not enable it.

    Sent from my SPH-D710 using Tapatalk
    02-08-2012 03:50 PM
  3. MannyZ28's Avatar
    I looked in the settings but couldn't find it. where is it?
    02-08-2012 03:56 PM
  4. JayWill's Avatar
    I looked in the settings but couldn't find it. where is it?
    Menu > Applications > Development
    02-08-2012 04:27 PM
  5. MannyZ28's Avatar
    Hmm, the drives showed up, but I can't access them. They act like a card reader with no card plugged in.
    02-08-2012 05:44 PM
  6. JayWill's Avatar
    Hmm, the drives showed up, but I can't access them. They act like a card reader with no card plugged in.
    Are you pulling down your notification bar, clicking the notification then hitting the "Connect USB storage" button? You can also get to this by Menu > Settings > Wireless and network > USB utilities and hit "Connect storage to PC". In this case, you will plug in your phone after you hit the button.

    If you're doing this, the last thing I can think of is your computer has a USB driver issue or your cable went bad.
    chucklique likes this.
    02-08-2012 06:12 PM
  7. MannyZ28's Avatar
    Are you pulling down your notification bar, clicking the notification then hitting the "Connect USB storage" button? You can also get to this by Menu > Settings > Wireless and network > USB utilities and hit "Connect storage to PC". In this case, you will plug in your phone after you hit the button.

    If you're doing this, the last thing I can think of is your computer has a USB driver issue or your cable went bad.
    Yeah I forgot that you have to do that. I got a bunch of texts and when I pulled down the notification bar I got reminded to click on that.

    Thanks for the help sir!
    02-08-2012 09:03 PM
  8. JefJaxon's Avatar
    Hi, I was reading through this thread because I am experiencing a similar issue on my Samsung 4G LTE. I just purchased it and was able to access the DCIM folder as well as any other folder (music etc.) but now when I plug the phone in to my desktop, I find the phone shown as a drive but clicking on it opens a blank window that often has a green slider bar that chugs in the directory window but finds nothing. Using the advice from this thread, I found USB Debugging through Settings>Developer Options>USB debugging and see that option is checked. I don’t see another section specific to USB debugging in the settings menu. Is there another answer to this other than a USB cable or device driver?
    06-17-2015 02:54 PM
  9. Alex Bor's Avatar
    Hi, Jef.
    I've found the similar issue on my samsung tablet SM-T110.
    I've found that if I copy files from my computer to the tablet, into the folder "Dowloads" I can then find them from tablet and to use.
    So, the communication works in one direction.
    But I wasn't able to read any tablet's files, even that ones I copied before, from my PC.
    I've turned on the USB debugging, but I was able only to switch between two options: connect my tablet as "Media device"(MTP) or as "Camera".
    In "Camera" mode I was able to read from tablet the pictures that I made by the tablet's camera. But the other my files are not visible even from the same folder.
    So, I'm still very curious, how to read ANY kind of files from my Android device.
    Alex.
    06-20-2015 12:21 AM
  10. Joel Kalman's Avatar
    Go to Settings > About Device and tap on Build Number seven (7) times. This will enable Developer Options. Then go to Settings > Developer Options and you will see USB Debugging, so that you can put a check in the check box.
    07-14-2015 01:10 AM
  11. Vicky Ad's Avatar
    I have a similar issue. Ever since I upgraded to Windows 10. I can only see or transfer image files. Data files, videos, music, etc will not show up, so I obviously can't transfer them. It worked fine using windows 7. I'm hating windows 10 more and more each day. Anybody know if this is the way windows 10 wants it? Or is it some kind of bug? Is there any way to fix it? I'm using a Samsung Galaxy S4.
    09-01-2015 08:19 AM
  12. Justin T Kennedy's Avatar
    On you computer, click the start menu, settings, devices. On the left click connected devices, remove MTP. Unplug phone and plug it back in. Fixed
    09-14-2015 06:14 AM
  13. Greg Florko's Avatar
    Figured it out on my phone, (LG Nexus 5). When you connect the USB cable to the PC, the phone gives a notification that it is charging. Tap that notification and you will get a menu. You'll probably see it set to "charge only" mode. Select the option for "MTP", mobile transfer protocol. It turned out to be a very simple fix. T-Mobile Support couldn't help. Android Support tried, but, couldn't figure it out. I had tried the new Google USB drivers. I had tried going into Developer Mode, etc. I'm pretty sure it all started when I ran the latest Android OS upgrade to 6.0.
    manillegirl likes this.
    10-16-2015 10:41 PM
  14. mike b3's Avatar
    Thanks...... If I had read your reply sooner I would have saved hours of time....
    manillegirl likes this.
    10-20-2015 07:45 AM
  15. manillegirl's Avatar
    THIS WAS THE ANSWER! I tried everybody else's and only THIS worked. Thank you!
    06-09-2016 11:13 AM
  16. Redbud9's Avatar
    This worked for me!!!!!! Finally, am able to see all the internal storage files and transfer them. The USB was setup for charging and not transferring!
    Many thanks.
    06-21-2016 11:31 AM
  17. Alyssa Hopkins1's Avatar
    This worked for me!!!!!! Finally, am able to see all the internal storage files and transfer them. The USB was setup for charging and not transferring!
    Many thanks.
    I DON'T UNDERSTAND! WHAT DID YOU PEOPLE DO!? I'm so confused and frustrated. I have Windows 10 and a Samsung Galaxy 4S/S4 whatever
    07-14-2016 08:23 AM
  18. saikiran kommu's Avatar
    for android 6.0.1

    settings-> more->tethering & mobile hotspot

    check use tethering
    07-15-2016 10:14 PM
  19. xSpazztic's Avatar
    Mine started with the last update also, less than 2 weeks ago. I used to get the option to switch charging to file transfer, now there is no notification in the bar at all. (Also an LG Nexus 5). I have gone to tethering and it is grayed out showing the USB is not connected when the same cord is plugged in. I tried a different USB cord, nothing.
    08-14-2016 08:19 PM
  20. fkhuong's Avatar
    In my Galaxy S5, Setting does have Application but Application does not have "Development" as an option.
    09-04-2016 06:26 PM
  21. DL573's Avatar
    The advice on this thread helped me but I was unable to see a certain subset of files. I think I have figured out the cause so I will add another piece of advice here.

    I was unable to see pictures in a certain date range when I was on vacation no matter what I did. All the other files were visible, just not these; but they were available on the phone, and file manager software on the phone could see them. Just not Windows.

    Eventually I realized that those pictures were taken with another simcard in the phone (I bought a simcard for the country where I was at). After I got home and swapped the simcard again, everything worked but I had to reconfirm all the permissions. Evidently, when you change simcard in an Android phone the OS interprets this as a new owner, which is reasonable I guess, and it will not give you access to certain things unless you reconfirm them. I don't know exactly how, but Windows somehow knows which files are stamped with the "other identity" and only those files will be missing from Windows explorer. I saw a couple of other people here whose situations might be caused by the same problem.

    So if nothing else works, ask yourself, "were the files I am looking for created with another simcard in the phone"? And if the answer is yes, you might be able to make them come up in Windows again if you replace that simcard in the device then try again.

    That is speculation because I didn't actually solve my problem that way. Instead, I used a file navigator app within Android to go to the files; then I highlighted them, and saved them to a cloud drive that was synced with Windows. Once they synced, they were then available to copy directly into my Windows box.
    08-13-2017 04:29 PM
  22. Emmanuella Donani's Avatar
    Hmm, the drives showed up, but I can't access them. They act like a card reader with no card plugged in.
    thanks guys i realized i had to change the setting from charging only to file..... i really appreciate it
    10-17-2017 04:10 AM
  23. Bilal Abbas's Avatar
    i have the same issue
    11-01-2017 02:21 PM
  24. Rjrayhan's Avatar
    I cannot connect my pc to mobile and it is not showing the mtp in my mobile please help me
    12-14-2017 10:03 PM
  25. Rjrayhan's Avatar
    My phone is Lenovo s650 model
    12-14-2017 10:04 PM
28 12
LINK TO POST COPIED TO CLIPBOARD