1. macnassnam's Avatar
    Just about saturday morning, my phone alarm wake me up as usually but i snoozed it a few times before getting up. only to finally wake up to the dreaded "Unfortunately, clock has stopped" message and since then, the message pops up every time i unlock screen and do other things on my phone. Very annoying. I tried going into Application manager and clearing the data and cache for clock but problem still occurs. My last resort would be to reset it back to factory settings but would rather try and fix the issue before resorting to that. please help!
    04-28-2014 01:00 AM
  2. Planehopr's Avatar
    ***********Update*************POSSIBLE SOLUTION


    I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

    Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

    Before I tried clearing cache and doing a factory reset You don't have to do this if this "choose date format" works. Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!
    05-09-2015 05:20 PM
  3. Kerwyn Hodge's Avatar
    That did the trick, Planehopr! I previously cleared the cache and all data. All that managed to do was remove my alarms...and I need my alarms. The "Regional Settings" solution worked like a charm! The Clock app started working again, and I was able to access the alarms and recreate the settings I need in order to stay on point. Thanks so much!
    09-20-2015 11:34 AM

Similar Threads

  1. LG G2: Battery and Charging problem- super annoying.
    By xrabbite in forum Verizon LG G2
    Replies: 7
    Last Post: 08-30-2015, 05:12 PM
  2. Has anyone been using the Google Now Launcher?
    By craigrn16 in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 5
    Last Post: 06-16-2014, 11:00 PM
  3. A mess of problems
    By Cliff Woolfork in forum HTC One SV
    Replies: 9
    Last Post: 04-29-2014, 06:11 PM
  4. Rooted epic, need to change symbols...help plz!
    By lcchick in forum Sprint Epic 4G
    Replies: 0
    Last Post: 04-27-2014, 08:22 PM
  5. Greek android tablet needs rooting... but how.... HELP !
    By Davida1956 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 04-27-2014, 06:21 PM