1. brnf2008's Avatar
    My husband decided to root his Optimus T Blk. He rooted the phone successfully but he got as I have began to see it called on the forums "uninstall greedy" or "uninstall happy" Some where along that uninstalling spree he deleted what I am assuming is the LGhome.apk due the issues that we are having. Here is my thread from another site that I had no responses to, maybe you guys may be able to help.

    Ok here we go.
    Thanks in advance for reading this and maybe being able to help me.
    My husband decided to get adventurous with his Optimus T Black and try to root it because he was reading about all the extra things you can do with it, on it, app wise etc. . . I am usually the one that does all these kind of things NOT him. I thought he was joking, I was wrong. He made it thru the root process it looks like he was able to customize the font and options on it and then all of a sudden "force close" pop ups starting popping up non stop so he manually shut the phone down by pulling the battery. When he tried to turn it back on and will not go passed the "Android" screen.

    I have read many threads and just can't seem to figure out what it is, I thought it was bricked and then it came back on but everything was enlarged, kind of zoomed in it seemed, it was mainly unresponsive black background and icon tray at the top the only thing that appeared but nothing functions. Then I tested it and it goes into emergency mode just fine without a problem and comes out of it. The power key+vol. down does nothing for me, no download menu comes up it just boots up and then stops at the "Android" screen again.

    The laptop is not recognizing the phone when it is plugged into it and the LG Update tool isn't recognizing it either and there is no way to try to restore the firmware thru that tool since it won't recognize it.

    Any suggestions on how I might be able to solve this issue? For now I will continue to creep and crawl thru Google search results and forum posts to see if I can find anything that relates. But I am pulling my hair out

    Thanks again in advance for the help.

    Next was an update:

    UPDATE:
    MORE ISSUES THAT ARE OCCURING THAT MAY HELP IN FIXING OPTIMUS T

    The phone powered on to the home screen (with the sliders on it) but it comes up with the icon tray at the top and the screen is black with no background or icons. Here is the WEIRD part: phone is sending and receiving texts without a problem. You have to recieve the text and then it becomes visible (when it first comes in) you can type, respond and do everything you would normally do on the phone and then send it. It then returns to the inbox of messages but if you hit home or back out of that you are back to the black screen of nothingness. Now while typing this update his phone recieved a phone call from a friend and it came up as it normally would, I slid the slider and answered the phone call, once it was over it went to recent calls briefly and then to the screen of nothingness again.

    WHAT THE "F" (Pardon the "f") could be causing this? Did he erase an important file possibly? He rooted using the z4root way, I don't know much about it becuase I have never used it or do I want to risk rooting my G2 until I fully understand what the heck I am doing so that I don't end up like him and his phone. I asked him if he backed the phone up, he said "I don't know", I asked him what process he took in rooting it and he said "z4root" I asked him what files he deleted off of the phone and he said "There was instructions and color coded symbols with the files I could delete, green meant safe to delete, red was not to be deleted, I erased the 'green means go' files and nothing else" So he definitely did something wrong to cause this issue but no idea what. . . Thanks again for reading the post and attempting to lend me some tech advice on the issue

    BTW: His phone has Android 2.2 on it and yes it does have third party apps but it started this after the "thought to be successful root"

    HERE ARE SOME PICS:

    https://mail.google.com/mail/?ui=2&i...94ac8cdde496&a ttid=0.1&disp=inline&realattid=1361939324241707008-1&zw

    https://mail.google.com/mail/?ui=2&i...94d7ed690816&a ttid=0.1&disp=thd&realattid=1361939400041168896-1&zw

    https://mail.google.com/mail/?ui=2&i...94d7f1fee306&a ttid=0.1&disp=thd&realattid=1361939363600007168-1&zw

    and then the last update I posted on it. . .

    Okay, I have been searching for HOURS on end now, since about 8 am this morning and finally found something that seems like it may suit the issues. Does anyone or has anyone ever acccidently removed there "home app"? Reading these issues match right up with the ones we seem to be having. . . any input out there at all for me? Even just a suggestion in the right way would be more than highly appreciated.

    Now tonight/ early morning/ evening, depending on where you are in the world.

    When you plug it into the computer the driver reinstalled (LG updater will not update it, says it is current on firmware) and the phone functions completely normal EXCEPT when you try to use the home key/menu key/ search key/ back key then the black screen appears with the system tray at the top and that is it.

    I HAVE NO IDEA, I AM ABOUT TO TAKE THE DEFEAT. HERE ARE A FEW MORE PICS FROM WHEN IT WAS HOOKED UP BY USB TO THE LAPTOP. Also all the restore modes/emergency etc seem to work fine. . . the factory reset didn't seem to do anything tho even tho I saw the little box with the android buddy. Still same results as before. we downloaded Access point and I just simply added it to the phone in the download section but nothing, I am not sure how to use ADB and didn't want to chance anything else.
    IF YOU CAN HELP PLEASE PLEASE DO!


    https://mail.google.com/mail/?ui=2&i...755406336-1&zw

    https://mail.google.com/mail/?ui=2&i...755406336-2&zw

    https://mail.google.com/mail/?ui=2&i...755406336-3&zw

    https://mail.google.com/mail/?ui=2&i...755406336-4&zw

    https://mail.google.com/mail/?ui=2&i...755406336-5&zw

    https://mail.google.com/mail/?ui=2&i...755406336-6&zw

    https://mail.google.com/mail/?ui=2&i...815229440-1&zw

    https://mail.google.com/mail/?ui=2&i...577371136-1&zw

    https://mail.google.com/mail/?ui=2&i...755902976-1&zw

    https://mail.google.com/mail/?ui=2&i...441479168-1&zw

    https://mail.google.com/mail/?ui=2&i...447780864-1&zw
    02-28-2011 01:09 AM
  2. sspletts's Avatar
    Good news!!

    I think I have a solution for your problem. I to was very uninstall happy and screwed up my phone so I had to do some searching for a fix. I can't remember where I found this file but it worked great to reset my phone back to factory stock. I have uploaded a copy of this file for all who may need it. Download the file to your computer then unzip and double click on KDZ_FW_UPD to run the application. Next plug your phone in via USB and the app will find your phone. Where it says KDZ file browse to where you extracted the file and click on the V10L_00.kdz file then press Launch software update. Now just seat back and wait a few minutes for it to finish and your good to go.

    here is the download
    Stock-Factory-Optimus_T_Flash.zip

    Good Luck and let me know how it turns out for you.
    brnf2008 likes this.
    02-28-2011 11:47 AM
  3. MrSmith317's Avatar
    What are the proper settings? This app crashes everytime I try to use the read phone information button.
    02-28-2011 05:39 PM
  4. sspletts's Avatar
    What are the proper settings? This app crashes everytime I try to use the read phone information button.
    MrSmith317

    I have used this method many times and it worked great for me. So give these steps a try.

    The steps I used are Double click on the KDZ updater next leave all settings at their default.

    Next plug phone in USB ans set to debugging

    Next where it says KDZ file click the browse folder and click on the V10L_00.kdz file and click open.

    Next click Launch software updater and wait.


    It took mine about 4 min to finish.
    Attachment 6815


    DO NOT!!!!! click on read phone infomation that is not needed to update your software.

    Let me know how it went.
    02-28-2011 07:23 PM
  5. brnf2008's Avatar
    I couldn't figure out the flashing thing but I did fix this and this is how:

    This only works if you are not bricked!! If you are bricked I cannot help you nor will this tutorial, sorry.

    Did you get uninstall happy once you rooted your Optimus T? Delete something you were sure of and now when you press the home button you have no screen? Just black, no icons, background, or menu? Do other functions work? I.E. Recieve phone calls, texts, able to access internet etc. . . Then this SHOULD work for you

    The issue was a LGHome.apk issue. He must of deleted while being uninstall happy (;(my husband got a little TOO uninstall happy & I had to find the fix to the black nothingness of the home screen & came up with this tutorial) But the problem is fiixed (majority of the way) I was able to access the internet using the search button on the phone in doing so I pulled up ASTRO file manager download AND THANK GOSH it had a link to the Market app on the site (cause I couldn't access it from the phone otherwise) I downloaded it and then followed these steps:

    1.Download Astro File Manager from the Market
    2.Connect your phone to computer in disk drive mode (connect to USB cable, select Disk Drive(or USB Mass Storage drive) from the options that appear on the phone, press Done)
    3.Copy the APK file to the SD card (anywhere you like)
    4.Disconnect phone from computer (remembering to Safely Eject first)
    5.Open Astro and browse to the file
    6.Select the file and choose the Open App Manager option
    7.Press the Install button

    8.If you get a message saying: “Install Blocked. For security, your phone is set to block installation of applications not sourced in Android Market”, go to Settings > Applications > check the box which says Unknown Sources



    Notes
    Make sure that any apk files you download are from a reputable source
    If you’re concerned about phone security then turn the Unknown Sources
    option in Step #7 off again after installation

    IF YOU HAVE A COMPLETELY BLACK SCREEN AND CANNOT ACCESS THE MENU TO GET TO THE MARKET, TRY THIS, A BIT OF A PAIN BUT IT IS HOW I DID IT, YOU JUST DON'T HAVE TO DO ALL THE RESEARCH TO FIND EVERYTHING YOU NEED TO DO IT BECAUSE IT IS LISTED HERE
    [COLOR="rgb(72, 209, 204)"]
    THIS IS FOR AN OPTIMUS T.[/COLOR]

    -You have three buttons at the bottom of your phone, the menu button(squares), the combo button of home(house) and back(backwards arrow), and the search button(magnifying glass).

    - Press and HOLD the search button until the tutorial comes up, then press it again and it will tell you to "Speak Now" say "ASTRO file manager" (luckily this is the WAY SHORTER route then it took me to find out what to do)

    -It will open it in the browser. Once the results show the first one(usually) is ASTRO File Manager with the description below, then there are links: click "Download" it takes you to another page where it has three sentences telling you that you can find it in the Market and then last sentence says if you are browsing from and Android phone click here (hyperlink) this successfully takes you to the download in the Market.

    -Hit download and then install the app.

    Hopefully you have ALREADY DONE THIS STEP sometime through the root operation: Settings > Applications > check the box which says Unknown Sources. IF YOU HAVE NOT ALREADY CLICKED THIS IT WILL NOT INSTALL. AND SADLY AND UNFORTUNATELY I DO NOT KNOW HOW TO DO THAT STEP WITHOUT THE HOMESCREEN.

    I now have a home screen to access and am able to use the phone. There ARE A COUPLE ISSUES THO: So far the home screen icons seem to be enlarged, as if zoomed, it maybe something he did with an app before he caused this catastrophe, j/k he knows I love him, but he is never touching my electronics without supervision lol. The second issue is a pop up saying "The application LG Home [process android.process.lghome] has stopped unexpectedly. Please try again. {Force close} I have done some research and some threads are saying that it needs to be installed again, I am going to continue looking until I find a fix. Other than that works perfectly

    I hope this helps all the users out there that had the same issue I did. It is much simpler than some of the other ways.

    Good luck & Happy Hacking (;

    Here are a couple useful links:
    LG Home .apk file:
    File Crop.com
    Access point

    I used this one:
    LG Optimus "Home Launcher" - xda-developers
    You will probably have to register with the site to view the links/downloads.

    Here is a few pics of the steps to take:

    Buttons:

    Search button:










    Market:


    Result of installing LGHome.apk:
    02-28-2011 09:26 PM
  6. brnf2008's Avatar
    I found out the issue with the zoomed look, it was for an Evo which has a bigger screen and it didn't adjust to Optimus apparently. . . so you may want to search for a specific home.apk or use it and then do what my husband did and go into the market and download a different one, he just downloaded the Honeycomb theme
    02-28-2011 09:50 PM
  7. weaponofchoice22's Avatar
    Hi,

    First off, I have the Optimus T p509 (T-mobile phone) black. I am not sure if everyone who posted above me had a different Optimus T or not. Just thought I'd clarify.

    I had the exact same issue with my phone - deleted the lghome.apk and had no home screen, just the notification bar. I wasn't able to use the flash method listed above nor was I able to get to the Android market application via my phone's internet. I was able to get to the android market in the phone's browser, but wasn't able to get the option to open the market app on my phone.

    Anyways, long story short, I was able to get the official LG home screen back on my phone as well as update my phone from Android 2.2 to Android 2.2.2... not only that but it was extremely easy (well, if you don't consider all the time I spent pouring all over any and every android forum that related to this topic).

    Basically, you just go to LG Electronics: Consumer Electronics & Appliances from LG | LG USA and search for your phone (in this case "Optimus T p509), then find it in the search results. Go to that phone's product page, then click the product support button (right by features, technical specs and reviews). Then scroll down and click the link that says "click here to download your mobile driver". (if you have the same phone as me, here is the link - LG P509 Black Support: Find Manuals & Warranty Info | LG USA) Then you just install that exe file that you just downloaded and it will install the drivers you need. Then plug in your phone via USB and the program you just installed (LGMobile Support Tool) will find the phone. Click "Start Updating". After about 2-3 minutes your the update will install and then you are set. Reboot your phone and all of a sudden you have Android 2.2.2 and a working home screen. No 3rd party apps or home launchers involved.

    I hope this helps some of you. This was very frustrating for me and now I feel rather dumb that I didn't think to try LG's own product support first. I'm very impressed with their support and now I don't have to worry about a voided warranty from rooting the phone (the only down side to this is that all the t-mobile apps that came with the phone are back).

    Good luck!
    03-03-2012 04:16 AM
  8. redsunn21's Avatar
    My screen also went black from deleting the LGHome.apk.Simple fix if your phone isnt supported via LG Phone Software (like mine LG Vortex) is to download Go Locker Ex.If you have any type of battery saver app installed just plug your phone in and when it pops u just click on one of the ads and you can get to Google Play to d/l Go Locker that way.Once installed you will have your home screen back.Either keep it or open up your browser to get the LG Home.apk file downloaded and installed or better yet just do a software update from your phone via WIFI or 3G......
    07-27-2012 07:11 PM
  9. LaoGai's Avatar
    Go back to flash, and do a recovery, if you had backed up your previous files reflash it to them and you should be fine, if that doesn't work, whatever he used to flash it or however he did it he managed to forget an important file.
    09-27-2012 08:58 PM
  10. hidossaji's Avatar
    There is a simple solution to blank home screen problems. When I deleted my lghome.apk by accident, my phone was stuck on an android logo. I didn’t have backup, or recovery.

    After lots of reading on the forums, I made it to unlock screen, and then the first time setup started. I was able to setup my email account. But then the home screen was blank with only status bar. I could receive the phones and text, but couldn’t launch any apps.

    So I decided to email myself google play website link. On my status bar, a new email messege flashed. I opened it, and clicked on the link. I searched for adw launcher, and installed it. Then restarted the phone. It worked!

    Try it, and let me know if it works.
    02-26-2013 11:57 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD