Android Experts HELP! Contacts/People sync ruining my experience...

djritchie82

New member
Jun 5, 2013
4
0
0
Visit site
So basically I have all my contacts in Gmail - did so since having my iPhone.

If I edit a contact (say add a new number) in Gmail Contacts, it shows up on my phone... However... If I edit a contact on my phone it does not sync back to Google Contacts.

This is really pissing me off as when I restore my Nexus (trying different roms etc...) it does not resync all my contact details (which I updated off the phone). Not a great experience - I expect to be able to change a contacts details (on the people app) and for it to be then sync'ed with Google contacts...

What's up here?

Any advice appreciated.
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
Works fine for me.

On the phone, open a contact for editing and ensure that it says, "Google contact" at the top of the screen and shows your correct gmail address directly below.
 

djritchie82

New member
Jun 5, 2013
4
0
0
Visit site
Works fine for me.

On the phone, open a contact for editing and ensure that it says, "Google contact" at the top of the screen and shows your correct gmail address directly below.

Yep, checked all this, fine - added a phone number - NO SHOW in google contacts??? Could it be anything else? Sync settings all seem fine - it pulls stuff from gmail contacts, just wont send it TO there???

I have HaxSync installed (dunno if that matters)???
 

wunderbar

Well-known member
Dec 11, 2010
582
0
0
Visit site
have you tried turning off contact sync for your google account, and then turning it on.

Actually have you double checked that contact sync didn't actually get turned off at some point?
 

anon(354569)

Well-known member
Jun 9, 2011
58
3
0
Visit site
It should work flawlessly as it does for me. Try opening the people app, go to "Menu" (3 dots), contacts to display and make sure that your correct Google account is selected. Also check in your phone settings under you google account sync settings and make sure that "People details" is also checked.
 

djritchie82

New member
Jun 5, 2013
4
0
0
Visit site
Ok, so it seems if i add a contact it appears - but if I edit a contact - add a new/extra number - it does not appear in google contacts!?!?

so frustrating!
 

fernandezhjr

Well-known member
Mar 26, 2011
936
19
0
Visit site
I had a similar issue syncing contacts between phone and PC before. This is what I did to fix it. This may or may not fix it for you, but it might be worth a shot. First, make sure your contact list is exactly how it should be on your phone. Then in options choose the option to export to storage. This will create a vcf file on your storage. Next, transfer this file to your PC, then delete all contacts in gmail, and finally reimport the contacts using the vcf file. This gave me a fresh start where everything matched and seemed to reset the sync function. I haven't had a problem since.

Sent from my Nexus 4 using Tapatalk 4
 

djritchie82

New member
Jun 5, 2013
4
0
0
Visit site
I had a similar issue syncing contacts between phone and PC before. This is what I did to fix it. This may or may not fix it for you, but it might be worth a shot. First, make sure your contact list is exactly how it should be on your phone. Then in options choose the option to export to storage. This will create a vcf file on your storage. Next, transfer this file to your PC, then delete all contacts in gmail, and finally reimport the contacts using the vcf file. This gave me a fresh start where everything matched and seemed to reset the sync function. I haven't had a problem since.

Sent from my Nexus 4 using Tapatalk 4

I think... This may have fixed it! Just exported, deleted from gmail - then imported, removed a phone number from a contact on phone and it has updated in Gmail!

I have also turned off HaxSync - is that a problem for anyone? Most annoying that the phone wont automatically pull in facebook names/photos to contacts