App Issue - Unable to Connect with Outside Servers?


New member
Jun 15, 2019
Visit site
I'm having an issue with my phone (XZ1 Compact) that has me stumped. Most of my apps work fine on my phone, but I'm noticing the same issue with any app that appears to require syncing with an outside server of some sort--it isn't able to connect with the outside server and instead gives me an error message.

Here are the apps I've noticed issues with so far:
  • Reddit is Fun - When I open the app, instead of displaying the normal thread data of the reddit front page, it gives me this error message: "No threads here. Tap to refresh."
  • Garmin Connect - I'm still able to connect my Garmin watch via bluetooth to my phone, but trying to go my Activities News Feed, for example, gives me the message: "An error has occurred" and the screen reads "Some of your data could not be loaded. Pull to refresh." None of my gps-recorded runs from my watch are able to sync to my phone, even though the steps recorded by my watch ARE able to sync.
  • MyFitnessPal - Trying to open this app gives me the error message: "Synchronization Failed. We were unable to connect to the server to synchronize."
I haven't changed any of my phone settings recently--everything was working fine yesterday and then I ran into these issues today.

Things I've tried to fix the issue:
  • Restarting my phone. Multiple times.
  • Connecting to several different wi-fi networks and also connecting using mobile data. The same issue occurs regardless of my connection.
  • Clearing app cache and app data for the impacted apps
  • Resetting network settings
My nuclear option is to factory reset my phone, but I'd prefer to avoid that if possible. Any ideas what could be causing this issue?


B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Any 3rd party security/antivirus apps? Some of these might monitor and block certain kinds of web traffic.

Trending Posts

Forum statistics

Latest member