Battery Drain when using WiFi

awsalazar

Member
Jan 9, 2016
8
0
0
Visit site
The following is a summary of my experience with the Samsung Galaxy S6 on AT&T: I purchased the S6 in June of 2015. This is my first smartphone, so I was afraid that the battery life would be terrible, compared to the regular phone I was using. The battery life was great for the first 3 months and I loved the phone. In late September, I began to experience battery issues, seemingly after I updated to 5.1.1. At the time, the cell standby and Android System would be as high as 40-50%. In mid October, I took it to the AT&T service center. I was offered a refurbished device because the camera makes an audible noise when focusing, but I declined, going with the option to do a factory reset and reflash the software. The camera doesn't make this noise as often anymore, and it is the least of my worries. AT&T's reset and reflash didn't help, and then things took a turn for the worse. By December, the battery drain was occurring while I slept. In an 8 hour span, the batter would drain by around 50%! I would go to bed with my phone at 40% and when I woke up, it would be dead. Here is a screenshot, you can see that cell standby is no longer a high percentage.

Screenshot_2015-12-28-11-36-27.jpg
Screenshot_2015-12-28-11-36-44.jpg

This is when I decided to ship it to Samsung in Texas, as I did not want to settle for a refurbished phone from AT&T. They stated the problem as "WON'T DOWNLOAD SW/PRL " and the solution as "S/W UPDATED". I was excited to get my phone back, hopefully functioning as it was in the first 3 months that I had the device. Unfortunately, that did not work. After spending hours reading through many forums on this site and others, I have tried many things on my own, including: Turning off location, turning off NFC, wipe cache partition, turning off always allow WiFi scanning, setting Keep WiFi on When Sleeping to only when plugged in, unchecked Enhanced 4G LTE services (I almost always keep my data off), disabled all Google syncing, except Photos, which only occurs when charging. I currently don't use any email services, and have very few 3rd party apps. My cell signal and WiFi connection seems pretty good. This problem isn't isolated to my home, it happens anywhere I use WiFi, including my apartment and my university.

Temporary solution: I have found that I have a tolerable battery life when I keep my WiFi off. And last night I set my phone to airplane mode with WiFi off before going to bed, and experienced no battery drain whatsoever. This is why I am concluding that it is an issue with the WiFi, although I could be wrong. I don't want to keep my WiFi off though, as that defeats the purpose of having a smartphone, in my opinion. Here are screen shots of yesterday's use (keeping WiFi off for the most part) as well as overnight, when I turned on airplane mode, with WiFi off. Looking at GSam Battery Monitor, its seems that Android System could be the culprit.
From This morning:
Screenshot_2016-01-10-11-16-15.jpg
Screenshot_2016-01-10-11-16-52.jpg
Screenshot_2016-01-10-11-16-58.jpg

From last night. You can see an increase in slope occurring around 6PM, which is when I turned on WiFi to observe changes:
Screenshot_2016-01-10-00-13-27.jpg
Screenshot_2016-01-09-18-19-54.jpg

Ultimately, I don't want to disable a bunch of features in order to get a tolerable battery life. The battery life was perfect in the first few months of having the phone. I apologize for making this comparison, but my girlfriend got the iPhone 6 the same day I got the S6, and to this day the battery life of her phone is amazing, with no features disabled, and she is a much heavier user than I am. She sent me a screen shot yesterday, the phone was at 22% with over 7 hours of usage and 23 hours of standby since the last charge.

With all of this being said, here are some questions:
Should I just wait until the 6.0 update comes to the S6, in hopes that it will resolve my battery issues?
Is exchanging this phone for a refurbished S6 from AT&T a bad idea? I have until June to make this decision, as its a 1 year warranty. My reluctance to do this comes from AT&T and Samsung not resolving my issue when I sent it in, and in 2011 I got a refurbished iPhone 3 from RadioShack, and it would randomly make a very loud noise, I returned it in a week and went back to using a regular phone for another 4 years.
 

xocomaox

Well-known member
Jul 8, 2014
2,279
0
0
Visit site
I've seen something like this before with a nasty glitch on a custom firmware (aosp-based) for my LG G3. When WiFi was on, it would conflict with the data signal for 4G. That is, my phone would have a WiFi connection with data, but still think it needed a data connection with the 4G signal and never go into deep sleep. There was a specific wake-lock causing this, that you would only be able to see with a root required application.

When I had just WiFi on, and mobile data disabled, it would go to sleep and everything would be fine. If I have mobile data on and WiFi off, it would be fine as well. It conflicted with both on, as a process just continued to run over and over, keeping the phone awake.

I think if/when you update to 6.0, this issue will go away. Also, I would think flashing factory images on this phone could help, but I'm not sure if you have tried that yet.
 

awsalazar

Member
Jan 9, 2016
8
0
0
Visit site
Thanks for the reply xocomaox. I almost always keep my mobile data off (or at least I think it is off).

Screenshot_2016-01-11-14-29-26.jpg

As mentioned in the original post, there was no battery drain overnight during airplane mode. Last night I kept airplane mode off, and enabled WiFi, and observed a normal amount of battery loss as shown below. I believe this is because I have the option "Keep Wi-Fi on during sleep" set to "only when plugged in", so the WiFi is essentially turned off while I sleep, as I understand it. When in use, the WiFi seems to severely drain my battery (the steep slope around midnight on 1/11), and when I use it with WiFi off, the battery drain is at a more normal level (earlier in the day).

Screenshot_2016-01-11-11-47-17.jpg Screenshot_2016-01-11-11-47-21.jpg

I definitely will install the 6.0 update once it is released (hopefully that is by the end of January). For now, I will keep WiFi off if I really need to conserve battery. I do not want to root my device, as I am under the impression that this will compromise my warranty. Can you expand on the flashing factory images? When I took it too AT&T service center in October, they factory reset and reflashed the software, and when I sent it to Samsung at the end of December, they updated S/W, so I'm unsure if this is the same thing as flashing factory images.
 

brackenmakay

Member
Oct 23, 2015
12
0
0
Visit site
Try clearing your RAM. It happens to me as well and when I clear the RAM that usually takes care of it. You can do this via Smart Manager. It may also be your battery. You could have a problem though but pretty unlikely if it is fine when you are not using Wi-Fi.

You should also try clearing your background apps by closing them.
 

xocomaox

Well-known member
Jul 8, 2014
2,279
0
0
Visit site
Thanks for the reply xocomaox. I almost always keep my mobile data off (or at least I think it is off).

As mentioned in the original post, there was no battery drain overnight during airplane mode. Last night I kept airplane mode off, and enabled WiFi, and observed a normal amount of battery loss as shown below. I believe this is because I have the option "Keep Wi-Fi on during sleep" set to "only when plugged in", so the WiFi is essentially turned off while I sleep, as I understand it. When in use, the WiFi seems to severely drain my battery (the steep slope around midnight on 1/11), and when I use it with WiFi off, the battery drain is at a more normal level (earlier in the day).

Interesting. Can you see what happens with WiFi on and Airplane Mode on? I would like to make sure that the mobile radios are not conflicting with WiFi... This would be the only way to check.
 

awsalazar

Member
Jan 9, 2016
8
0
0
Visit site
Interesting. Can you see what happens with WiFi on and Airplane Mode on? I would like to make sure that the mobile radios are not conflicting with WiFi... This would be the only way to check.

I will do this tonight when I sleep and see what happens. I will set the "Keep Wi-Fi on during sleep" option to always.

Another thing that I noticed is the blue circle next to the on switch on the Wi-Fi page turns on for a few seconds, turns off for a few seconds, and this continues. When I'm connected, should that blue circle keep appearing?

Screenshot_2016-01-14-13-45-02.jpg

Try clearing your RAM. It happens to me as well and when I clear the RAM that usually takes care of it. You can do this via Smart Manager.
I can't find the Smart Manager on my phone, its not in my applications, and its not in settings. Would this help if I recently factory reset my phone?
 

xocomaox

Well-known member
Jul 8, 2014
2,279
0
0
Visit site
I will do this tonight when I sleep and see what happens. I will set the "Keep Wi-Fi on during sleep" option to always.

Another thing that I noticed is the blue circle next to the on switch on the Wi-Fi page turns on for a few seconds, turns off for a few seconds, and this continues. When I'm connected, should that blue circle keep appearing?

I am not familiar with Samsung firmwares so I cannot say for sure.
 

xocomaox

Well-known member
Jul 8, 2014
2,279
0
0
Visit site
Your girlfriend is the smart one here in this thread. View attachment 213322

Any phone can have excellent stand-by numbers. The iPhone is no different. Although your screenshot does not show Screen-On-Time, it does indicate that a lot of the battery power used over the past 25 hours has been mostly from background services that you're not actively using. Which means that your iPhone doesn't have very great stand-by and is being consumed by background services and run-away processes.

Compared to my LG G3 which can do about 200 hours idle (0.2% per hour, idle) with roughly 16 hours awake and be left with 60%. That is with zero screen on time, of course. But with the way Apple calculates "Usage", there really can be no comparison.
 

awsalazar

Member
Jan 9, 2016
8
0
0
Visit site
So keeping Airplane mode on AND WiFi on with the"Keep Wi-Fi on during sleep" option set to always seems to confirm that it is the WiFi causing the issue. Really hoping this issue will be fixed with the 6.0 update

Screenshot_2016-01-15-10-47-53.jpg Screenshot_2016-01-15-10-47-02.jpg Screenshot_2016-01-15-10-46-54.jpg
 

xocomaox

Well-known member
Jul 8, 2014
2,279
0
0
Visit site
Can you show a GSAM screenshot? I would like to see if the phone is staying awake during that time or not.

I will assume it is not deep sleeping.
 

whiteshoez

Member
Apr 28, 2015
7
0
0
Visit site
I am having the same issue. I charged my phone to 100% before bed and lost 26% overnight with WiFi being the culprit.

Posted via the Android Central App
 

Attachments

  • 4245.jpg
    4245.jpg
    37.2 KB · Views: 42

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,166
5,607
113
Visit site
Welcome to Android Central! Is Wi-fi scanning on? Go to Settings>Privacy>Location>Improve Accuracy, and make sure it's off.
 

Trending Posts

Forum statistics

Threads
945,935
Messages
6,927,869
Members
3,160,009
Latest member
estroner