Bluetooth keyboard doing weird things.

Captain Casual

New member
Mar 9, 2023
2
0
0
Visit site
Greetelings!

I bought myself a BT keyboard to use with my Lenovo M10 Plus (3rd Gen) tablet.

The so-called Fosmon Mini-Bluetooth-Keyboard.

Neat-looking little thing, but there's a bit of an issue. While it pairs properly and does indeed show up as a bluetooth input device, none of the buttons work, except for..... and get this, j,k,l and u,i and o. And rather than typing those letters, they put out 1,2,3 and 4,5,6, respectively. Oh, and backspace works too, for some reason.

Now this doesn't seem to be an issue with the Keyboard itself, 'cause if i connect it to my PC, or more tellingly my (android) phone, it works perfectly well out of the box. Only the Tablet seems utterly unwilling to accept it in the same way. I've tried changing the keyboard layout, which did nothing, and i tried to re-pair and so on, but i'm out of ideas. Hoping i've not bought something that's just straight up incompatible with the specific device i intended to use it with.

Any ideas and suggestions would be welcome, and thank you for your time!
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,195
5,657
113
Visit site
Last edited:

Captain Casual

New member
Mar 9, 2023
2
0
0
Visit site
I had meant the layout in the language settings, (Like variations of QWERTY, QWERTZ etc.), but had also tried the configuration changing. At least i think i did. On this little Keyboard, the Q, W and E keys aren't marked for it, and when i press FN+ any of them, nothing really seems to happen at all. The only reason i knew to try was because the manual does mention how to do it.
Mind you, i also just tested if anything happens if i press those buttons while i've got the keyboard connected to my PC and..... nope. It does seem like nothing happens when i push FN+ Q, W, and E. Though again, it also works perfectly fine on both Windows (10) and Android (11) on the phone. The Tablet's android 12.
Also, i figured out something rather curious. I noticed that on the Tablet, for a split second after the Keyboard connects via bluetooth, i -can- actually use any key on there properly. But literally for a fraction of a second, before it goes and ignores everything but those keys i mention in the OP. It's almost like it's pretending that the Keyboard is a mere Keypad, actually. The 789, UIO, JKL, and as it turns out, comma, period and forward-slash keys work, outputting as numbers arranged as on a key/numpad and a few symbols. It's utterly bizarre.
I've tried a few more things, like turning various assists on/off and changing to a different on-screen keyboard in case the physical one is somehow "filtered" through it, but i couldn't make any headway.
 

Forum statistics

Threads
946,040
Messages
6,926,039
Members
3,160,053
Latest member
veronika